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Chapter 1

Introduction

1.1 Kopete, the KDE instant messaging client

1.1.1 Before starting...

If you’re not familiar with Instant Messaging, please read the Getting Started
section to learn about this wonderful world before continuing.

1.1.2 What is Kopete?

Kopete is the KDE instant messaging (IM) client. It allows you to communicate
with your friends and colleagues using various instant messaging services. A
single program is easy to learn and convenient if your friends or colleagues use
more than one IM service.
Kopete is designed to integrate well with your KDE desktop; to make it im-
mediately familiar. The user interface is clean and simple, without any frills
to distract the user. At the same time, Kopete aims to make communication
the focus of IM, by removing the differences between different IM systems.
One feature Kopete introduced to support this is the Metacontact, combining
the various means there are to contact someone into a single ‘person’ in your
contact list. Other multiprotocol instant messengers list the same person’s var-
ious IM accounts separately, making it confusing for non experienced people.
Kopete makes life easy: a metacontact is a person, and contacts are ways to
communicate with that person. You will recognize contacts in a metacontact
easily as small icons representing the IM services you could use to communi-
cate with that person.

Kopete is intended for all levels of users. Out of the box, it supports a minimal
set of functions to make chatting as easy as possible. More advanced users can
add extra functions such as Statistics with Kopete’s plugin system.
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1.1.3 More Kopete Information on the Web

For more info about the Kopete project; the team maintains a website at http://kopete.kde.org.
The latest news and updates are always available there.

If you need to contact the team, the Kopete developers’ mailing list is hosted at
https://mail.kde.org/mailman/listinfo/kopete-devel.

If you want live support, there is an Internet Relay Chat channel for Kopete
where you can find the team discussing technical (well, not always) issues
or just hanging out. You can use any IRC client to join the channel (includ-
ing Kopete), just add an IRC contact and use irc.kde.org as the server and
#kopete as the channel name. See you there!

1.2 Introduction to Instant Messaging

What is Instant Messaging (IM)? IM is a way for you to communicate instantly
with your friends over the Internet. That might not sound so different to email.
Have you ever noticed how cumbersome it is to have a brief conversation via
email? You have to click Reply to each message, then find the right spot in the
message to type something new, then send it. Then you have to wait for the
next message to arrive! IM lets you to have a conversation almost as naturally
as on the phone or face to face, by typing messages into a window shared
between you and your friend’s screens.

Another difference between IM and email is that with IM you can see your
friends’ presence, that is, whether they are actually on-line at the same time
as you. This lets you send messages truly instantly, instead of sending off a
mail and having to wait for your friend to check their mailbox. An IM message
pops up on the other person’s screen as soon as you send it. Of course, if you’d
rather not be interrupted, you can change your own presence so others will
know not to disturb you.

There are lots of other fun and useful IM features you can explore with Kopete,
like group chats, file transfers and emoticons that reflect your mood. Read on
to find out more!
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Chapter 2

Getting Started

To use Kopete you need to set up one or more accounts for the instant messag-
ing services you wish to use.

You’ve probably already chosen a messaging service, either because you al-
ready use IM, or you need to use the same service as your friends. If you don’t
fit into either of these categories, please consider using a messaging service
based on open standards, because these are designed for use by Free Software.
Other messaging services are prone to changing the underlying technology
without making the details freely available, making them harder for Free Soft-
ware developers to support.

The messaging services that Kopete supports that are based on open standards
are Jabber and IRC.

The following section assumes you are registered with an IM service already. If
not, you can register with Gadu-Gadu, Jabber, and MSNTM from inside Kopete;
for other services, you’ll have to register using their respective web site before
creating an account in Kopete.

2.1 Creating Accounts

To create an account, use Settings→Configure... to display the Configure win-
dow.
The Configure window is the main way to set up and customize Kopete. On
the left a column of icons control which aspect of Kopete is being configured.
Click the Accounts icon. The main pane will change to display the account
management pane. This is currently empty, but will soon list your IM accounts.
Click New to display the Account Wizard.

The Account Wizard helps you create an IM account. After the Introduction
page, you are asked to select the messaging service that you’d like to use. Click

3
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one of the services shown and then click Next. On the following page, you
should enter your registration details for that instant messaging service.

Most services just require you to enter a username or unique identifying num-
ber (UIN) and password. The special purpose services Winpopup and SMS
work slightly differently, so please see their specific sections. There are a cou-
ple of other options that apply to most services that you should look at:

Remember password When this is checked, Kopete will store the password
for you, so you don’t have to enter it every time you connect to the IM
service. If you are security-conscious or want to limit access to the IM
account you can leave this unchecked.

Connect at startup When this is checked, Kopete will try to connect to the IM
service as when it starts. If you use a LAN, DSL or other ‘always-on’
connection, this is appropriate; dial-up modem users should turn this off
and connect manually when you have dialed up.

Once you’ve entered your IM details, you can proceed to the Finished! page
and then dismiss the wizard and the Configure window.

2.2 Go Online and Start Chatting!

Now you’ll notice that an icon representing the account has appeared in the
status bar at the bottom of the Kopete Contact List window. This represents
your current presence for this account. Right click on it and you can go online
from the menu that appears. The status bar icon will animate while Kopete
connects to the IM service.
Once you’re online, if you’ve used this IM service before, your contacts will be
fetched from the server and displayed in the Contact List. To start a chat with
a contact, just click their name and a Chat window will appear. The upper part
of the window is where the conversation appears - to say something, type into
the bottom part of the window and click Send.

If you’ve just created a new account you won’t have any contacts. See Adding
Contacts for details on how to add contacts.

TIP
The shortcut for Send is set to Ctrl+Enter by default; you can change it in the Chat
window using Settings→ Configure Shortcuts....
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Chapter 3

Using Kopete

This chapter gives an overview of Kopete’s basic features. We will look first
at the contact list, where your contacts are displayed, and then at the Chat
window, where you carry out a conversation.

3.1 The Contact List

The Contact List appears when you start Kopete. It’s the main window where
you can set your presence, start a chat, organize your contacts, configure Kopete
and quit.

3.1.1 Layout of the Contact List window

3.1.1.1 Menu

You will usually find the menubar at the top of the contact list. If it is not there,
you might have turned it off; you can re-enable it with Ctrl+M. Details on each
menu item can be found in the chapter on menu structure.

3.1.1.2 Tool bar

The toolbar holds the most frequently used Kopete actions. You can customize
it with Settings→ Configure Toolbars.... Notice the Show Offline Users and
Show Empty Groups buttons. With these you can hide contacts and groups
that are offline.
Kopete makes it even easier to set a status message to let your contacts know
about your mood or why you’re busy at the moment. Click on the Set Status
Message button and start typing to enter a new message, or choose from one
of the previous messages you have used.
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The Quick Search Toolbar quickly filters the contact list, by typing a few letters
from a contact’s name.

3.1.1.3 Contact List

The Contact List takes up the main part of the window. All your contacts are
listed here, in the groups you have chosen for them. You can open or close
groups by clicking the plus symbol adjacent to the group. You can reverse the
order the groups are sorted in by clicking the Contacts label above the list.

The context menu in the Contact List changes depending on the item under the
mouse. Groups, Metacontacts and IM system specific contacts have their own
options. In empty areas of the Contact List, the context menu allows you to
add contacts or groups, or change the viewing options for the list.

3.1.1.4 Status bar

The status bar shows an icon for each IM account you have created. The icons
represent the current presence of each account, which can be changed by right-
clicking the account icon.

Kopete also shows your current status message in the Status Bar>. By clicking
on the note icon in the corner, you can change or clear the status message as
well.

3.1.2 Setting Your Presence

We introduced you to setting presence in the previous chapter. ’Presence’ de-
termines how visible you are on the IM network. To use the network at all, you
have to connect to the network, so you can send and receive messages and see
others’ presence. Once you are connected, most IM systems allow you to indi-
cate what you’re doing and whether you want to chat by setting special types
of presence such as Away or Free For Chat. The difference presence settings are
particular to each away system; but Kopete allows you some control all your
IM systems at once by setting them to Away or Available at the same time.

You set your presence for individual IM accounts by right clicking the ac-
count’s icon in the status bar at the bottom of the Contact List. The context
menu for each account lets you choose the possible presence settings for each
IM system.

To change all your accounts’ presence together, click the Status, or use the File
→ Status menu.

3.1.3 Start A Chat From The Contact List

To start a chat from the Contact List, simply click a contact. A Chat window
will appear.
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You can also right click a contact and select either Send Message or Start Chat.
Send Message works differently in that it just sends a single message without
opening the Chat window, using a simple dialog. Use it for ‘fire-and-forget’
messages.

3.1.4 Send A File

You can send files from the Contact List, using the context menu on the person
you want to send to. If Kopete supports file transfer on their IM system, there
will be a Send File... item. Alternatively, you can drag a file from anywhere
else in KDE onto their name to start a file transfer.

3.1.5 Organizing Contacts

3.1.5.1 A Word about Metacontacts

One of the principles behind Kopete is that it offers a standardized way to use
IM systems. Differences between IM systems are smoothed over, making it
easier to communicate. We follow this principle in the way contacts are orga-
nized. When you use Kopete you just find contacts by name; the actual IM
system used is less important. Some people have more than one IM account -
Kopete puts the person using the account first.

To support this, Kopete introduced ‘Metacontacts’, which represent the person
you want to chat with. One Metacontact contains all the different IM IDs they
may have, making it easy to see with a glance at the Metacontact ’smiley icon’
whether someone is available, regardless of which IM system they are using
right now.

3.1.5.2 A Word about Grouping Contacts

Kopete lets you create groups to sort your contacts. A contact may be in more
than one group. Where possible, groupings are saved on server side contact
lists, so if you use other IM programs, group memberships are kept in sync.
However, if you change groups in another IM program, Kopete cannot know
to move a metacontact automatically; it is up to you to resolve this by hand.

To change the group a metacontact appears in, you can use its context menu to
move it or copy it to a new group, or remove it from a group. You can also use
drag and drop here - just drop the metacontact on a different group name.

3.1.5.3 Adding Contacts

To add a contact, either select File→ Add Contact or click the Add button on
the toolbar. This brings up the Add Contact Wizard.

The Add Contact Wizard creates a new Metacontact using one or more IM
systems, by leading you through the following pages.
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1. Welcome Page. Here you can choose whether you want to use the KDE
Address Book for this contact. Storing IM information in the KDE Ad-
dress Book will enable other KDE IM programs to share contact informa-
tion with Kopete and in future KDE applications may use Kopete to send
information via IM. If you prefer to keep your IM contacts separated,
clear the check box here.

2. Choose KDE Address Book entry. By choosing an entry from your KDE
Address Book, you can use its name as a Display Name in Kopete. You
can also create a new entry here. This page doesn’t show if you chose not
to use the KDE Address Book.

3. Select Display Name and Group. Here you can enter a Display Name (the
name used for this person inside Kopete), and choose the groups they are
a member of.

4. Select IM Accounts. Here you can choose which accounts you want to
use to chat to the new contact. If you only have one IM account, you
won’t see this screen.

5. Account-specific Add Contact Pages. For each account, you’ll get one
page where you can enter the UIN, buddy name or Email address, de-
pending on the IM system in use.

6. Finish Screen. All done. Except if the IM system requires authorization
(such as ICQTM) to add a contact to your list - in which case, you’ll be
prompted after the wizard exits.

You can add contacts to an existing Metacontact using its context menu.

3.1.5.4 Renaming Contacts

You can rename a contact using Edit→ Rename Contact or with the same item
on the metacontact context menu.
Some IM systems allow you to set a ‘Display Name’ that is different to your
username, such as ‘Alice loves crypto!’. If you change a contact’s name manu-
ally, this will override their Display Name. To get it back, open the Properties
dialog for that contact and check the Use the name given by the server check-
box.

3.1.5.5 Removing Contacts

If you no longer want a contact to be in the contact list, you can remove a
Metacontact and all the contacts under it with Metacontact context menu→
Remove Contact.
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3.1.5.6 Moving Contacts between Metacontacts

You can change the metacontact a contact belongs to. In practice, you only have
to do this when you have just added multiple accounts to Kopete, and you
know that HotDog76 and mikejones@hotmail.com are both the same person.

There are two ways to do this:

Drag and Drop The contact icon to the right of the metacontact name may be
dragged from one metacontact to another.

Contact Context Menu The context menu for contacts (Right-click the contact
icon) allows you to choose the new metacontact from a dialog.

If the move would leave a Metacontact empty (with no contacts), you’ll be
asked if you want to delete this contact.

3.1.5.7 Removing Contacts from Metacontacts

To remove a contact from a Metacontact, choose Contact context menu→Delete
Contact....

3.1.6 Configure Kopete

You can configure Kopete using Settings→ Configure.... See the next chapter
for details.

3.1.7 Exiting Kopete

To exit Kopete you should use File→Quit, Ctrl+Q, or the Kopete System Tray
icon’s context menu. If you just close the Contact List window, Kopete will
continue to run in the KDE System Tray.

3.1.8 Keyboard shortcuts

The following keyboard shortcuts are supported in the Contact List window:

Keyboard Shortcut Action

Up Arrow Select the previous item in the
contact list.

Down Arrow Select the next item in the contact
list.

Left Arrow Close the current group.
Right Arrow Open the current group.

9
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Enter Start a chat with the selected
contact.

Ctrl+M Show/Hide the menu bar.
Ctrl+U Show/Hide offline users.
Ctrl+G Show/Hide empty groups.

3.2 The Chat Window

3.2.1 Layout of the Chat Window

3.2.1.1 The Chat View

The Chat View usually takes up most of the Chat window and is where the
conversation between you and your contacts takes place. Messages appear in
the order they are received, with the earliest messages at the top of the view.

You can control the appearance of the Chat View, making it look like other IM
clients or create a completely individual look.

3.2.1.2 Chat Members List

Since some IM systems allow you to chat as a group, it is useful to see who is
chatting at the moment. The Chat Members List appears to the left or the right
of the Chat View. You can change this using Settings→ Chat Members List.
The contact context menu is available in the Chat Members List.

3.2.1.3 Input Area

The Input Area is below the Chat View. This is where you type messages before
sending them. You can change the font and color of the message using the
usual tools on the toolbar. If the IM system supports this, your messages will
appear in color when your contacts read them.

By default, the keyboard shortcut to send messages is Enter.

3.2.1.4 Status Bar

The Status Bar contains temporary messages, such as notification that someone
else is typing, as well as the Send button.
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3.2.1.5 Tabbing

Kopete lets you carry on multiple conversations in one window, by putting
each one in its own tab within the window. The tab titles change color to show
when a new message has been received:

Red Someone typed a message.

Green Someone is typing a message.

Blue Someone typed a message containing your nickname.

There are several different ways to control grouping. To configure this behav-
ior, go to the Chat tab of the Behavior page of the Configure Kopete dialog.
You can also move chats between windows using the Tabs menu, and control
the placement of the tabs in the window.

3.2.2 Group Chats in Kopete

You can use Kopete to chat one to one, or in a group, where the IM system
supports this.

To invite others into a chat, drag them from the Contact List into the chat win-
dow, or use Chat→ Invite→ <contact name>.

3.2.3 File Transfers

Some IM systems allow you to send and receive files. You can access this func-
tion from the contact’s context menu. If you’re already chatting, and want to
send a file, simply drag the file from any other part of KDE into the Chat Win-
dow, or select the Chat→ Send File menu.

3.2.4 Keyboard Shortcuts

The following keyboard shortcuts are supported in the Chat window:

Keyboard Shortcut Action

Enter Send the message in the Input
Area.

Ctrl+P Print the contents of the Chat
View.

Ctrl+S Save the contents of the Chat
View.
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Ctrl+W

Close the current Chat View. The
Chat window will close unless
there is more than one tab in the
window.

Ctrl+, Change to the previous tab.
Ctrl+. Change to the next tab.

Ctrl+Shift+B Detach a tabbed chat into a
separate window.

Tab
Complete a partially typed
nickname belonging to someone
you’re chatting with.
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Chapter 4

Configuring Kopete

To configure Kopete, look in the Settings menu.

4.1 Global Shortcuts

Kopete defines some shortcuts which are valid in any KDE application.

Global Keyboard Shortcuts Action

Ctrl+Shift+I

Read Message. This is useful if
you have hidden the Contact List
window and the system tray icon
is animating to tell you you have a
new message.

Ctrl+Shift+C

Show/hide (Dock) the Contact
List window. Warning: If you have
disabled Kopete’s System Tray
icon or don’t have a system tray,
this can make the Contact List
vanish - the only way to restore it
is to repeat this shortcut.
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4.2 The Configure Kopete Dialog

4.2.1 Adding and Editing Accounts

We briefly showed you how to add an account in Getting Started. To change an
account’s settings later, open up the Configure Kopete dialog, with Settings→
Configure.... Much like the KDE Control Center, the configuration is separated
into sections. The icons on the left side of the dialog switch between sections.

On the Accounts page, you can Add, Remove, or Modify accounts. Editing
accounts is much the same as adding them, but note that you cannot change
the UIN, buddy name, or whatever account identifier your IM system uses.
This is intrinsic to the account. If you want to change this, you will have to add
another account with the new account identifier and (optionally) remove the
old account.
You can quickly distinguish between multiple accounts using the same IM sys-
tem by giving a custom color to each account’s status bar entry and contact
icons. To do so, select the account and click the color selector on the right side
of the page.

You can control the priority of accounts using the Up and Down icons on this
page. If you have more than one way to message a contact, this determines the
IM system Kopete will use to communicate them.

4.2.2 Global Identity

Kopete’s Global Identity lets you set your own nickname and photo once for
all your IM accounts. You can read these details from the KDE address book
entry for yourself, from a single one of your contacts, or add a completely new
nickname or photo. If you have an exciting dual life, you can create multiple
identities and switch between them in the Identity section.

4.2.3 Behavior

Behavior covers the way Kopete integrates with your desktop, Away settings,
and chat user interface options.

4.2.3.1 The General tab

Here you can customize Kopete’s desktop integration, and control the way the
contact list is laid out.

Show system tray icon By default, Kopete places an icon in the KDE System
Tray. If you prefer, you can turn this off here.
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Start with hidden main window This causes Kopete to start with the Contact
List window hidden (docked). You can make it visible by clicking the
system tray icon or with the Show Contact List global shortcut.

Open messages instantly New messages open chat windows as soon as they
arrive.

Use message queue The message queue is where Kopete puts messages when
there is no chat window open. This allows you to be notified of new
messages with popup ‘speech bubbles’; or by animating the System Tray
icon. If you choose to disable the message queue, chat windows will open
as soon as you receive a new message.

Use message stack If you use a message stack, Kopete shows recently received
messages starting with the last message received.

4.2.3.1.1 Notifications

Show a bubble on new message This option shows a ‘speech bubble’; com-
ing from the System Tray icon when you receive a new message. You
can start a chat or ignore the message. URLs are extracted from the mes-
sage; if you click a link, your preferred browser will open the link and
the message will be dismissed.

Flash the system tray on new messages This option causes the System Tray
icon to animate when you receive a new message. Clicking the icon will
show the message in a chat window.

Enable events while away If you do not wish to be distracted by these notifi-
cations while you are set Away, uncheck this box.

Configure Sounds & Events Sounds, flashing taskbar entries, passive popups
and more exotic notifications are supported in Kopete using the KDE no-
tification system. Type help:/kcontrol/kcmnotify in Konqueror or se-
lect the Help tab in the System Notifications section of the KDE Control
Center for more information.
To add custom notifications for a contact, right click that contact in the
Contact List and select Properties. This lets you start chats, play a cus-
tom sound effect, or display a message for that contact or group. Other-
wise you can use the ‘Execute a program’ notification to perform custom
notifications. As an example, if you have XOSD (X On-Screen Display)
installed, you can get OSD online notifications by executing the following
command when the ‘User goes online’ event takes place:
echo %s | osd_cat -o 100 -p bottom -A center -f -*-helvetica-*-r-*-*-24-*-*-*-*-*-*-*
-O 2 -c gold

OhReally at the KDE Forum suggests having your online notifications
read out by a speech synthesizer, using MBROLA like so:
echo %s | sed -e ’s/online/onlaain/i’ | /usr/local/bin/mbrdico.dutch.female

The ’sed’ in the middle phoneticises Kopete’s output to so the synthesizer
has a better Dutch pronunciation.
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4.2.3.2 Away Settings

Notify all open chats when I go away Be careful if you enable this item; it will
cause a message to be sent to open chats when you become away, which
some people may find intrusive.

4.2.3.2.1 Auto Away Here you can choose to have Kopete set you away after
a period of inactivity.

4.2.3.2.2 Predefined Away Messages You can define as many custom away
messages as you like here, and choose from them when you go Away using the
Status button on the main toolbar.

4.2.3.3 Chat Settings

Raise window/tab on new messages This causes a chat window to pop up
when it receives a new message.

Show events in chat window Some IM systems can give extra information,
like people joining or leaving chats. This option lets you receive these
messages in your chat window.

Highlight messages containing your nickname This simply emphasizes mes-
sages in a chat that contain your nickname. For more powerful control
over highlighting and other events, see the Highlight plugin.

4.2.3.3.1 Interface Preference Kopete can send messages using either a ‘fire
and forget’ interface that does not wait for a reply, or a chat window where the
conversation is visible as it unfolds. Here you can choose which style to use by
default.

4.2.3.3.2 Chat Window Grouping Policy If you wish to group chats within
tabs in a single window, Kopete lets you choose several ways to determine the
grouping.

• Open all messages in a new chat window

• Group all messages from the same account in the same chat window

• Group all messages in the same chat window

• Group all messages in the same group in the same chat window

• Group all messages from the same metacontact in the same chat window
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4.2.3.3.3 Chat Window Line Limit

Maximum number of chat window lines This limits the number of lines of
text the chat window can display.

4.2.4 Appearance

Appearance governs the style of the Chat window, its colors and fonts, and lets
you choose your preferred emoticons.

4.2.4.1 Emoticons

Emoticons (also known as smileys) are combinations of characters such as
;-)that look like a face, and communicate moods or expressions. Kopete can
optionally use graphical emoticons in place of the characters themselves.

On this tab, you can select which emoticon set you prefer, or turn off graphical
emoticons altogether.

See Specialized Actions for details of how to install extra emoticon sets.

4.2.4.2 Chat Window

4.2.4.2.1 Styles The style of the chat view can be altered to look like other
clients. Installed styles are shown in the list on the left and are previewed in
the main panel. See Chat Window Style guide for a document how to make
your own style.

Third party styles are available at http://kde-look.org. Kopete 0.12 now sup-
ports styles from Adium(an IM program on Mac R© OS X). So you can down-
load styles from Adium here: Adium Xtras and select Message View Styles.

To install a style, click Install.... Select an archive file containing the style. To
delete a style, select a style in the list and click Delete.

Group consecutive messages is a useful option to make your chats more read-
able. If you receive several messages in a row from the same contact, they are
grouped without repeating the sender name.

4.2.4.3 Contact List

Arrange metacontacts by group By disabling this, Kopete’s groups are hid-
den, and contacts are divided only into Online Contacts and Offline Con-
tacts.

Show tree branch lines Usually Kopete displays contacts and groups as a tree,
where group members are indented. For a simpler appearance, you can
disable this, so the contact list becomes a flat list. You can also control
whether branches are indented here.
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Contact Display Mode There are several ways you can present the contact list
here. Of particular interest may be the Use contact photos when available
option, that shows the contact list using photos chosen by your contacts
or the KDE Address Book

Contact List Animations This controls the degree of animation of the contact
list. Turning this off will make Kopete more responsive on slower ma-
chines.

Contact List Auto-Hide By enabling this, the contact list will automatically
disappear a few seconds after the pointer leaves the window.

Change Tooltip Contents... You have a lot of control over how much or how
little detail appears in the tooltips shown on the contact list using this
dialog.

4.2.4.4 Colors and Fonts

4.2.4.4.1 Chat Window Colors Here you can alter the base font and text col-
ors used for chatting.

4.2.4.4.2 Formatting Overrides If your contacts tend to choose fonts and
colors that you dislike, you can tell Kopete to ignore these and use your regular
font.

4.2.4.4.3 Contact List Some IM systems let you see whether contacts are idle
at their computers. This option enables you to change the color used for idle
contacts.

4.2.5 Devices

The Devices section allows you to choose and configure which multimedia de-
vices are used for A/V chatting. Whether this works for you is highly depen-
dent on the hardware you have and how well it is supported by your operating
system.

4.2.5.1 Video

Kopete uses the Video4Linux 2 system for video. This shows a blue square if
no video device is found, or a preview if the camera is working. For up-to-date
information on Kopete webcam support, see the Kopete Webcam Support wiki
page.

4.2.5.2 Audio

Audio support in Kopete is at an experimental stage. If you have an Audio tab,
you are probably using a preview build of Kopete.
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4.3 Loading Plugins

You can customize Kopete with special functions that may be useful or just a
bit of fun. Bring up the Configure Plugins dialog with Settings→ Configure
Plugins....

Plugins can be turned on or off in the list on the left side of the page. Each
plugin may be configured on the right side. See the chapter on plugins for
details on each plugin.
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Chapter 5

Kopete’s Protocols

Kopete calls different IM systems ’Protocols’. When you add an account, it is
specific to a single protocol. Although Kopete tries to make instant messaging
appear the same, no matter what protocol you use, there are some differences
in the level of support for advanced features such as file transfer and multime-
dia.

5.1 Protocols

5.1.1 AIM

AIM supports chatrooms. Use the Join Chat... command on the AIM account
menu to join a chatroom. Contact pictures and custom emoticons are also sup-
ported.

5.1.2 ICQ

ICQ has an Invisibility feature which allows you to hide from selected contacts.
You may also search the ICQ user folder when adding a contact. A wide range
of contact details can be set using the Properties option.

5.1.3 MSN

MSN supports the sending and receiving of webcams, if your camera is sup-
ported by the Video4Linux 2 (v4l2) standard. To view someones webcam, right
click on their MSN butterfly icon and select View Contact’s Webcam. File trans-
fer and multi user chats work. To transfer a file, drag the file from Konqueror
or the desktop into the chat window. To invite someone else into a chat, drag
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them from the Contact List into the chat window. The File menu also contains
these commands. In addition, MSN supports custom emoticons.

To use file transfer or a webcam, make sure port 6891 is forwarded to your
computer.

5.1.4 Yahoo

Yahoo can send and receive webcam video. It also supports Yahoo mail and
the Yahoo address book from the account menu. Conferencing is also possible.

5.1.5 Jabber

Jabber, also known as XMPP, supports file transfer, conferencing and any other
services supplied by the Jabber server. For example, many Jabber servers have
a user directory, and some provide transports to other messaging systems. To
access services, use Services... on the account menu. Jabber file transfer can
work without port forwarding, but enjoys better performance where a direct
connection is possible. By default, port 8010 is used for port forwarding, but
this is configurable in each account’s settings.

5.1.6 Google Talk

Since Google Talk is based upon Jabber, it is well supported in Kopete with the
exception of voice chat, which is worked upon.

To configure Kopete for Google Talk: Use your complete Google Mail address
as the user name. Check Use protocol encryption (SSL), Allow plain-text pass-
word authentication and Override default server information. The server is
‘talk.google.com’ or ‘gmail.com’ and ports 443 or 5223 should be used.

5.1.7 Novell GroupWise

GroupWise Messenger is an enterprise messenging system from Novell Inc.
The full range of features are supported, including privacy, group chat, rich
text and user search.

5.1.8 Gadu-Gadu

Gadu-Gadu is a chat system originating from Poland. At present, Kopete sup-
ports basic chat functions.
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5.1.9 WinPopup

WinPopup is a way to use Kopete to send and receive messages with Win-
dows R© computers on the local network. The WinPopup protocol only sup-
ports single, plain-text messages.

5.1.10 Other protocols

As well as the protocols named above, Kopete has support for several other
protocols. In most cases, this is not enabled by default or an additional plu-
gin must be installed. Meanwhile, SMS, Skype and SILC are provided in this
way. See http://kopete.kde.org for details, however, the Kopete team are not
responsible for these protocols.

22

http://kopete.kde.org


The Kopete Handbook

Chapter 6

Kopete’s Plugins

Kopete offers plugins that provide functions that aren’t essential for messag-
ing, but are useful for some people.

6.1 Plugins

6.1.1 Alias

Alias lets you define your own commands, e.g. /hello, in Kopete that run
scripts and output the result in the chat window. If you know how the alias
Unix command works, this is just the same

6.1.2 Auto Replace

Auto Replace allows you to correct frequently misspelled words or save typing
certain words using abbreviations.

6.1.3 Bookmarks

The Bookmarks plugin creates bookmarks in your KDE bookmarks list from
URLs that are received in IM messages.

6.1.4 Connection Status

Connection Status is useful for modem users or others who don’t have a per-
manent Internet connection. It watches for an active Internet connection and
sets your accounts online when it detects you have dialed up.
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6.1.5 Contact Notes

Contact Notes allows you to note down any useful bits of information on a
metacontact.

6.1.6 Highlight

Highlight works a little like email filters, in that it allows you to make things
happen in response to particular messages. As well as highlighting the text,
you can play sounds.

6.1.7 History

The History plugin, when activated, records conversations using any IM sys-
tem and allows you to view old conversations later. A History item appears in
each Metacontact’s context menu so you can view the message history for that
metacontact.
The following item is added to the Contact List’s menus:

Edit→View History (Enabled when a contact is selected) This displays the
History browser for the selected contact.

The following items are added to the Chat window’s menus:

Tools→History Previous (Alt+Shift+Left Arrow) This enables you to view
the next oldest set of messages from the History in the Chat window.

Tools→History Next (Alt+Shift+Right Arrow) This shows the next newest
set of messages from the History in the Chat window.

Tools→History Last This shows the most recent set of messages from the
History in the Chat window.

6.1.8 OTR

The OTR plugin allows you to encrypt conversations using the Off-The-Record
encryption method. This encryption method basically works like the PGP en-
cryption but it is optimized for instant messaging and handles the key ex-
change on its own. The only thing you have to do, is to make sure that you
really are writing to the person you expect by using one of OTR’s authentica-
tion mechanisms.
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6.1.8.1 Menu items

The following item is added to the Contact List’s menus:

Edit→OTR Policy (Enabled when a contact is selected) You can set the en-
cryption policy for each contact here. Setting this entry to "Default" causes
Kopete to use the default setting in the configure dialog

The following items are added to the Chat window’s menus:

Tools→OTR Settings→ Start OTR session This lets you initiate an OTR en-
crypted session.

Tools→OTR Settings→ End OTR session This lets you end a previously
established OTR session.

Tools→OTR Settings→Authenticate contact Use this menu entry if you
wish to authenticate the contact.

6.1.8.2 The settings dialog

In the setting dialog you have various options to set the modules behaviour
during your chatsessions. The most important of them is the default policy
configuration. Set the policy to "Opportunistic" if you wish Kopete to check if
you contacts support OTR and establish an encrypted session on its own or to
"Manual" if you wish to control each encryption state on your own. The options
"Always" and "Never" are recommended only for experienced users that wish
to set the policy on a per-contact base. In the "Private Keys" Pane you have the
possibility to create you personal keypair for each account. You don’t need to
do this manually. If an account does not have a keypair it will be generated
automatically the first time it is required. In the "Known Fingerprints" tab you
have the possibility to see, verify and delete known public fingerprints of your
contacts.

6.1.8.3 Authentication

You’ve probably received email from people pretending to be banks, credit
agencies, even wealthy Nigerian expatriates. People lie about who they are all
the time on the Internet. Authentication is a way to make sure that nobody can
lie to you about who they are when they use OTR.

6.1.8.3.1 When to authenticate You should authenticate a buddy the very
first time that you talk to them using OTR. If you don’t, then you cannot really
be sure that someone else isn’t impersonating them or trying to listen in on
your conversation. However, once you’ve authenticated your buddy once, you
don’t have to do it again. OTR will automatically do the authentication for all
of your future conversations with that buddy.
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The only exceptions occur when your buddy switches between multiple com-
puters or multiple IM accounts. In this case, you will need to authenticate once
for each computer and account. Once you’ve done this, your buddy can freely
use any of the computers you’ve authenticated them on, and OTR will recog-
nize them automatically. If your buddy uses a new computer or account that
OTR does not recognize, a message will pop up in your conversation window
telling you about it.

6.1.8.3.2 How to authenticate To authenticate someone, open a conversa-
tion with them and click on "Authenticate Contact" on the OTR button. A wiz-
ard will be shown, asking you what authentication method you would like to
use. Please follow the steps in this wizard.
If the authentication was successful, then you know that you are really talking
to your friend. Any imposter should have a hard time guessing what you’re
typing in, so you’ll be able to catch them in the act.

6.1.9 KopeteTeX

KopeteTeX allows scientists and mathematicians to hold conversations using
the LaTeX markup language. Expressions entered within $$ are rendered as a
graphic in the chatwindow, and can be cut and pasted as the original Latex. To
use this plugin you must have LaTeX installed

6.1.10 Motion Auto-Away

In conjunction with a webcam and the Video4Linux package, this lets you de-
tect when you’re no longer at your computer and have Kopete automatically
become Away.
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6.1.11 Now Listening

With the Now Listening plugin, let people you’re chatting with know what
you’re listening to, by typing /media in a chat, or with Tools→ Send Media
Info in the Chat window.

6.1.12 Statistics

This plugin uses a database to gather information about your contacts’ activity
patterns. You can use this to see when a contact is usually online, for example.

6.1.13 Text Effect

Text Effect applies funny effects to your messages before sending them, like
coloring them or changing the case of the words. Just don’t forget you have
activated it - we’ve had bug reports from forgetful Text Effect users!

6.1.14 Translator

The Translator plugin lets you define a preferred language for each Metacon-
tact, and then translates messages to or from them using web based translation
services such as GoogleTM and BabelfishTM. Set your own preferred language
in the Configure Plugins dialog. Each contact’s preferred language can be set
on its context menu.
The following item is added to the Chat window’s menus:

Tools→ Translate (Ctrl+T) If you did not turn on automatic translation, this
translates the current chat.

6.1.15 Web Presence

Web Presence allows you to publicize your IM presence on the Web. Give it the
path to a file on an FTP server (for example), and it will upload a short piece of
HTML to that file, which you can include in your homepage. KDE’s network
transparency makes this simple. Useful for bloggers to make friends with, or
you could use it to use IM in your business.

Example: sftp://username@somehost.org/path/to/homes/user/im.html uses
the SFTP protocol to upload your presence directly onto the webserver.

See the KIO manuals for tips on specific network protocols.

27

help:/kioslave/index.html


The Kopete Handbook

6.1.16 Pipes

Pipes allows you to pipe incoming or outgoing messages through an exter-
nal script or executable. An incoming message will be piped through the ex-
ecutable before it reaches your chat window, while outgoing messages will be
piped through the executable before they are sent over the Internet. Pipes can
receive text in one of three forms:

Plain text body The body of the message, in plain ASCII text

HTML text body The body of the message, in HTML, as it would be if your
chat peer had sent HTML to you, which will be rendered in the chat win-
dow

XML full message An XML document that describes all the characteristics of
the message, including the HTML body.

For most purposes, you probably want to use the plain text body or HTML
text body options. These can be used with programs such as translators or
summarizers. The XML format is only appropriate for use with a program or
script written specifically to work with this plugin. If you would like to write
a program or script that does work with this plugin, see the more detailed
documentation.

6.2 Contributing a plugin

Kopete is designed to make it easy to create plugins that give it extra functions.
So if you’ve got a great idea to make Kopete even better, get in touch!
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Chapter 7

Menu Entries

Each menu item is discussed below. When there is a keyboard shortcut that
performs a menu item function, the default shortcut is listed with the menu
item.

7.1 The Contact List Window’s Menus

7.1.1 File Menu

File→ Set Status→Online Go online with all accounts

File→ Set Status→Away Set all connected accounts away

File→ Set Status→Offline Set all accounts offline

File→Add Contact... This displays the Add Contact Wizard, which allows
you to add a new contact to your list

File→ Create New Group... Prompts you for the new group’s name and adds
it to the contact list.

File→Quit (Ctrl+Q) Disconnects you from all IM systems, closes all the win-
dows and exits the application.

7.1.2 Edit Menu

Edit→Undo (Ctrl+Z) Reverts the last change that was made to the contact
list.

Edit→ Redo (Ctrl+Shift+Z) Reverts the last change that was made to the
contact list by EditUndo
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Edit→ Send Single Message... Opens an email-style message window with
the selected contact, to send a single message.

Edit→ Start Chat... Opens a chat window with the selected contact, to have
a conversation.

Edit→ Send File... If supported by the IM system, this opens a file selector
to choose a file to send to the selected contact.

Edit→Move To (Enabled when a contact is selected) Choose another group
from the sub-menu, and the contact will move to that group.

Edit→ Copy To (Enabled when a contact is selected) Choose a group from
the sub-menu, and the contact will be copied to group. IM systems that
allow contacts to be in more than one group on the server contact list will
be updated accordingly.

Edit→ Remove (Delete) (Enabled when a contact is selected) Removes a con-
tact from the contact list entirely.

Edit→ Rename Contact (Enabled when a contact is selected) Renames the
contact on the contact list. If you do this, the contact list entry will no
longer change if the contact changes their display name remotely. You
can re-enable this using the contact’s Properties dialog.

Edit→Add Contact... (Enabled when a contact is selected) Choose another
account from the submenu, and you can add another way to message
that person using that account.

Edit→Add to Your Contact List... (Enabled when a contact is selected) Some-
times people will message you who aren’t on your contact list already. In
this case, Kopete creates a temporary entry for them, but to keep them on
your contact list, use this function.

Edit→ Properties The Properties dialog lets you choose custom icons for the
selected item, and change its name.
For contacts, you can change the KDE Address Book entry that they are
associated with.

Edit→ Remove Group (Enabled when a group is selected) Removes a group
from the contact list entirely. Any contacts that are only in this group are
moved to the top level.

Edit→ Rename Group (Enabled when a group is selected) Renames the group.

7.1.3 Settings Menu

Settings→ Toolbars Shows/hides the Main Toolbar and the Quick Search
Bar.

Settings→ Show Menubar (Ctrl+M) Shows/hides the menu bar.

Settings→ Show Statusbar Shows/hides the status bar.
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Settings→ Show Offline Users This shows/hides contacts who are currently
offline. They will become visible when they go online again.

Settings→ Show Empty Groups (Ctrl+G) This shows/hides groups which
do not have any members, or where all the members are offline and hid-
den (see above).

Settings→ Configure Toolbars... Displays the KDE standard Configure Tool-
bars dialog, which lets you customize the Contact List’s toolbars.

Configure Notifications... In the dialog displayed by this menu entry, you can
change the notifications (sounds, error messages, etc.) used by Kopete.

Settings→ Configure Global Shortcuts... Displays the KDE standard Con-
figure Global Shortcuts dialog, where you can change keyboard shortcuts
that work all the time under KDE.

Settings→ Configure Shortcuts... Shows the KDE standard Configure Short-
cuts dialog, where you can change keyboard shortcuts that work in the
Contact List’s windows.

Settings→ Configure... Displays the Configure Kopete dialog.

Settings→ Configure Plugins... Displays the Configure Plugins dialog.

7.1.4 Help Menu

These are the KDE standard items for the Help menu:

Help→Kopete Handbook (F1) Invokes the KDE Help system starting at the
Kopete help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within Kopete will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→ Switch Application Language... Opens a dialog where you can edit
the Primary language and Fallback language for this application.

Help→About Kopete This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.
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7.2 The Chat Window’s Menus

7.2.1 Chat Menu

Chat→ Send Message (Ctrl+Enter) Sends a message.

Chat→ Save (Ctrl+S) Saves the content of the chat to a file.

Chat→ Print... (Ctrl+P) Prints off a hard copy of the chat.

Chat→ Contacts This menu lists all the people in the chat. You have access
to the same contact menu you get by right-clicking a contact’s name in
the Contact List, allowing you to perform contact specific actions such as
sending them a file, viewing their user info or blocking them.

Chat→ Close (Ctrl+W) Closes the current chat. If there are chats taking place
in other tabs in this window, the window will stay open.

Chat→Quit (Ctrl+Q) Closes all chats taking place in this window.

7.2.2 Edit Menu

Edit→ Cut (Ctrl+X) Cutting text works as with most editors: the selected
text is removed and put into the clipboard. Note that you can also select
text and drag it to a new position.

Edit→ Copy (Ctrl+C) Copying text works as with most editors: the selected
text is copied to the clipboard. Note that you can also select text while
holding the Ctrl key, and drag it to a new position to copy it.

Edit→ Paste (Ctrl+V) Pasting works the same as with most editors: the text
from the clipboard is pasted at the current cursor position.

7.2.3 Format Menu

Format→Add Smiley This menu contains all the smileys/emoticons that
the current emoticon scheme includes. You can change the scheme in
the Configure Kopete Dialog.

Format→ Text Color... Opens a color selector that modifies the text color.

Format→ Background Color... Opens a color selector that modifies the back-
ground color.

Format→ Font This menu allows you to change the font used in the chat.

Format→ Font Size This menu allows you to change the font size used in the
chat.
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7.2.4 Tabs Menu

Tabs→ Tab Placement This menu allows you to change whether tabs appear
at the top or the bottom of the chat view.

Tabs→Detach Chat (Ctrl+Shift+B) Separates the current chat into its own
window.

Tabs→Move Tab to Window You can move chats between windows using
this menu. Choose the chat window the tab should move to from themenu.

7.2.5 Tools Menu

This menu contains items added by the plugins you have loaded. See the plu-
gins chapter for details.

7.2.6 Settings Menu

Settings→ Show Menubar (Ctrl+M) Separates the current chat into its own
window.

Settings→ Toolbars→Main Toolbar (Kopete) Shows/hides the main tool-
bar.

Settings→ Toolbars→ Status (Kopete) Shows/hides Kopete’s status bar. This
is where buddy pictures appear.

Settings→ Toolbars→ Format Toolbar (Kopete) Shows/hides the text for-
matting toolbar.

Settings→ Show Statusbar Separates the current chat into its own window.

Settings→ Show Chat Members List This menu controls whether the Chat
Members List appears on the left or right of the Chat View, and whether
it is visible at all.

Settings→ Configure Shortcuts... Shows the KDE standard Configure Short-
cuts dialog, where you can change keyboard shortcuts that work in the
chat window.

Settings→ Configure Toolbars... Displays the KDE standard Configure Tool-
bars dialog, which lets you customize the chat window’s toolbars.
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7.2.7 Help Menu

These are the KDE standard items for the Help menu:

Help→Kopete Handbook (F1) Invokes the KDE Help system starting at the
Kopete help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within Kopete will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→ Switch Application Language... Opens a dialog where you can edit
the Primary language and Fallback language for this application.

Help→About Kopete This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.
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Chapter 8

Frequently Asked Questions

1. What does Kopete mean? How do I pronounce it?
Kopete’s name comes from the chilean word Copete, meaning ‘a drink
with your friends’. Duncan, the original author, recorded an audio sam-
ple.

2. When I have more than one messaging service under a user’s name in my contact
list and I click on that user’s name, it will message them on the wrong messaging
service.
You can change the order of accounts Kopete tries to message people
with by using the Up and Down arrows in the bottom right corner of the
account configuration screen. Kopete will try to connect with accounts
starting from the top. However, if one service has a higher status value
than the others for that user, Kopete will use that one. For example, if a
person has three services and two are marked as away and the third is
marked as online, Kopete will always try to message the user using the
online service.

TIP
If you click on the small protocol icon on the right of the menu item, instead
of on the person’s name, you will always try to contact the person using that
service!

3. I need to connect via a SOCKS proxy, but I cannot find any proxy configuration
options in Kopete. How do I set up Kopete to use SOCKS?

• MSNTM, ICQTM, AIMTM, Jabber, and YahooTM use the KDE network
infrastructure. Their SOCKS proxy details are configured with the rest
of KDE, in Control Center, Internet & Network→ Proxy.

4. Is it possible to customize the icons I see in Kopete?
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You can switch between different emoticons using the Emoticons tab
of the Appearance page of the Configure Kopete dialog.To install new
emoticons, first look at KDE-Look.org, where there are a lot of additional
emoticon sets to download.The emoticons are easy to install - you just
place a folder containing the icon files along with an XML file describing
the mapping from text to picture in $KDEDIR/share/apps/kopete/pic-
s/emoticons (or $KDEHOME, for example, in /home/joeuser/.kde/).

(a) Copy the extracted folder to $KDEDIR/share/apps/kopete/pics/e-
moticons or $HOME/.kde/share/apps/kopete/pics/emoticons (or
wherever $KDEHOME is)

(b) Select Configure Kopete from the Settings menu and click on Ap-
pearance in the left panel of the Preferences window and click on
the Emoticons tab

(c) Select the emoticons set you just installed from the list
(d) Now you can use the newly installed emoticons in Kopete

To replace the protocol icons, you’ll have to replace the icons in $KDEDIR/share/app-
s/kopete/icons, or provide replacements to override them in the same
folder under $KDEHOME. At present there aren’t any complete replace-
ment sets that you can simply extract there.
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Chapter 9

Specialized Actions

Command line parameters

Installing emoticon sets
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Chapter 10

Credits and Licenses

Kopete: copyright 2001-2007, Kopete Developers

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.

10.1 Current Development Team

• Duncan Mac-Vicar Prett (duncan at kde org): Original author, developer, and
project leader

• Till Gerken (till at tantalo net): Developer, Jabber maintainer

• Olivier Goffart (ogoffart at tiscalinet be): Lead Developer, MSN Plugin Main-
tainer

• Andy Goossens (andygoossens at telenet be): Developer

• Grzegorz Jaskiewicz (gregj at pointblue com pl): Developer, Gadu-gadu Plu-
gin Maintainer

• Jason Keirstead (jason at keirstead org): Developer

• Matt Rogers (mattr at kde org): Lead Developer, AIM and ICQ plugin main-
tainer

• Richard Smith (lilachaze at hotmail com): Developer, UI maintainer

• Will Stephenson (lists at stevello free-online co uk): Developer, icons, plug-
ins, manual author

• Michel Hermier (michel.hermier at wanadoo fr): IRC Plugin Maintainer

• Andre Duffeck (andre at duffeck de): Developer: Developer, Yahoo plugin
maintainer
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• Michaël Larouche (michael.larouche at kdemail net): Developer, MSN, Chat
Window.

10.2 Former Developers (Kopete Hall Of Fame)

These people have moved on from Kopete, so don’t contact them for Kopete
support. We’re eternally grateful for their contributions.

• Christopher TenHarmsel (tenharmsel at users sourceforge net)Developer, Os-
car hacker

• Ryan Cumming (ryan at kde org): Core developer

• Richard Stellingwerff (remenic at linuxfromscratch org): Developer

• Hendrik vom Lehn (hennevl at hennevl de): Developer

• Stefan Gehn (sgehn at gmx net): Developer

• Robert Gogolok (robertgogolock at gmx de): Developer

• Nick Betcher (nbetcher at kde org): Original author of ICQ, AIM and IRC
plugins

• Daniel Stone (dstone at kde org): Original Jabber plugin author

• James Grant (topace at lightbox org): Developer, importer Plugin author

• Zack Rusin (zack at kde org): Developer, old Gadu-gadu Plugin author

• Gav Wood (gav at kde org): WinPopup Plugin author

• Martijn Klingens (klingens at kde org): Developer, MSN hacker

10.3 Documentation

Documentation copyright 2003,2004,2005 Will Stephenson (lists at stevello free-
online co uk), copyright 2005 Matt Rogers (mattr at kde org), copyright 2005,2006
Michaël Larouche (michael.larouche at kdemail net).
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Appendix A

Installation

A.1 How to obtain Kopete

Kopete is part of the KDE project http://www.kde.org/ .

Kopete can be found in the kdenetwork package on ftp://ftp.kde.org/pub/-
kde/ , the main FTP site of the KDE project.

Development versions may be downloaded at http://kopete.kde.org.

A.2 Required Libraries

If you installed Kopete as part of your distribution, you probably have these
installed already.

The Gadu-gadu plugin requires the libgadu package, see this page for details.

The Now Listening plugin needs libxmms if you want to access what xmms is
currently playing; this should be available in your distribution but is available
as part of the xmms package at the xmms homepage.

A.3 Compilation and Installation

For detailed information on how to compile and install KDE applications see
Building KDE4 From Source

Since KDE uses cmake you should have no trouble compiling it. Should you
run into problems please report them to the KDE mailing lists.
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Appendix B

Kopete Chat Window Style
Guide

B.1 Kopete Chat Window Style reference.

Beginning with Kopete 0.12, we are now using Adium format for our Chat
Window style. The theme format is based on HTML templates and CSS. They
are easier to make and develop, only a knowledge of HTML and CSS is needed.
Also, styles can have variants (defined as CSS file) which add more customiza-
tion value :).

B.1.1 Reference guide.

Adium format consist of a directory structure, HTML templates, CSS files and
keywords that are replaced each time the template is processed. The final con-
versation is a XHTML page where messages are added with DOM operations.
The central element is a div element named Chat. Before and after this div ele-
ment goes the Header and Footer template. Messages are children of the Chat
div element.

B.1.1.1 Directory Structure

A style must respect this directory structure. Code in Kopete are thinking
around this directory structure. When archiving the style, archive the styl-
eName directory. The directory structure is a structure of a Mac OS X bundle
for those familiar with that operating system. Also you must respect the case
displayed here, because a UNIX system is case-sensitive.
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styleName\ (can have .adiumMessageStyle as suffix , because in ←↩
Mac OS X it is a bundle)

Contents\
Info.plist
Resources\

main.css
Header.html
Footer.html
Status.html
Incoming\ (and Outgoing\)

Content.html
NextContent.html (for ←↩

consecutive messages)
Context.html (for message ←↩

history)
NextContext.html
Action.html

Variants\
*.css

B.1.1.2 About <div id="insert"></div>

This is a special div element used internally. It is a placeholder to indicate
where to insert the next message. If it is a new message, it is removed and the
new message take place. But if it is a consecutive message, the div element is
replaced with the content of new message. This special div element is required
in Content,Context,NextContent,NextContext templates. Though it not harm
to put it also in Action and Status template.

B.1.1.3 HTML templates.

TEMPLATE DESCRIPTION.

Header.html (Required) Use the Header template to display a nice header
to the conversation. This template is inserted before Chat div element. If
you don’t use it, just put an empty file.

Footer.html (Required) This is mostly the same as Header but it is for the
footer of a conversation. This template is inserted after Chat div element.
If you don’t use it, just put an empty file.

Status.html (Required) This template is used to display an internal mes-
sage. Internal messages such as status change, message from Kopete
(e.g. Incoming File Transfer). When the style do not supply an Action
template, it is used to display Action message.
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Incoming/Content.html, Outgoing/Content.html (Required) The con-
tent template is the message core. Think it as a block that will hold mes-
sages. Make sure it is ready to receive consecutive messages, don’t design
it to only display one message. Consecutive messages will be inserted at
the div insert element.

Incoming/NextContent.html, Outgoing/NextContent.html (Required)
The NextContent template is a message fragment for consecutive mes-
sages. It will be inserted into the main message block. The HTML tem-
plate should contain the bare minimum to display a message.

Incoming/Action.html, Outgoing/Action.html (Optional) (Kopete Extension)
This template is a Kopete extension to the Adium format. It is available
for Incoming and Outgoing direction. Action messages are special mes-
sage to tell we are doing an action. Example: "/me is installing Kopete"
would be displayed as "DarkShock is installing Kopete".

Incoming/Context.html, Incoming/NextContext.html, Outgoing/Context.html, Outgoing/NextContext.html (Optional)
These templates are not used in Kopete. In Adium, they are used to dis-
play history. It is mostly the same thing as Content and NextContent but
with some differences to distinguish from normal messages.

B.1.1.4 About CSS styles and Variants

HTML template are used to describe how the structure is made. But all the
style is described in CSS files. main.css is the main style, where variants are
just alterations of the main style. Examples of variants are different colors,
no display of user photo. Both main.css and variants and imported in final
XHTML page.

B.1.1.4.1 -main.css This is the main CSS file which is common for all vari-
ants. This file should contain all the main description of the style.

B.1.1.4.2 -Variants Variants are CSS files located in Variants/ directory. Each
variant is a single CSS file that include the main.css and do alteration to the
main style.

B.1.1.5 Debugging styles

Here is two tips for testing a style while creating it.

B.1.1.5.1 -Save a sample conversation. In Chat Window, you can save a
conversation. This is a copy of the internal XHTML page displayed. Use it
in Konqueror to test your CSS files.
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B.1.1.5.2 -Disable style cache. A little configuration switch exist to disable
the style cache. When enabled, it reload the HTML templates each time the
style is asked. Add the following lines to your kopeterc. Very useful when
testing a style in Kopete

[KopeteStyleDebug]
disableStyleCache=true

B.1.2 Keywords reference

Keywords are likes holes to fill with details. On each new message, they are
replaced with the correct value corresponding to their context. To fully support
all features of Kopete, we added some keywords extensions to the Adium. Also
some keywords are only available in certain context.

KEYWORDS LIST FOR HEADER AND FOOTER TEMPLATES.

%chatName% This is the name of the current chat session. For a typical ses-
sion, it display the name of the contact and his status. For IRC, it display
the topic of a channel.

%sourceName%, %destinationName% These are the name of the contacts
for a chatsession. %sourceName% is your name. %destinationName% is the
name of the contact you are chatting with. Prefer %chatName% over those,
because they could be confusing for groupchat and IRC.

%incomingIconPath%, %outgoingIconPath% These are the image/pho-
to/avatar of the contacts for a chatsession. Incoming represent the con-
tact photo and Outgoing represent your own photo. If they are no photo
available, it use buddy_icon.png image which is located in Incoming or
Outgoing directory.

%timeOpened%, %timeOpened{X}% It is the time when the chat session be-
gin. %timeOpened% use the default time format for the current locale. If
you want to use a specific time format, use %timeOpened{X}% where X is
a string containing the time format. The time parameters are the same as
the glibc function strftime. Do man strftime to get the list of available
parameters.

KEYWORDS LIST FOR CONTENT, NEXTCONTENT, CONTEXT, NEXTCONTEXT,
ACTION TEMPLATE

%userIconPath% This is the image/photo/avatar of the contact associated
with the message. If they are no photo available, it use buddy_icon.png
image which is located in Incoming and Outgoing directory depending of
the message direction.

%senderScreenName% This is the contact ID of the contact associated with
the message. Examples: me@hotmail.com, 45566576, JohnSmith.
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%sender% This is the name of the contact associated with the message. It use
MetaContact display name as a source.

%service% Display the name of the service associated with the message. Ex-
amples: Jabber, Yahoo, MSN.

%textbackgroundcolor{X}% In Kopete, this keyword is used to represent
the highlight background color. Ignore parameter in the braces and only
use it as %textbackgroundcolor{}.

%senderStatusIcon% (Kopete extension) Display the status icon of the con-
tact associated with the message. It’s a file path.

%senderColor%, %senderColor{N}% (Kopete extension) Generate a color
from the sender contact id. Can be used to display a different color for
contact nickname.
%senderColor{N}% where N is a positive number. If N is greater than 100,
it represent a lighter color than the contact’s color. If N equal 150 it is a
color which is 50% brighter. If N is less than 100 then it is a darker color.
Useful for having a background colored differently for each contact.
If you want to use theses colors in a variant, but not in the main style,
you have to workaround.

<div style="color:%senderColor%;border:none;border -color ←↩
:%senderColor{40}%;"><p class="message">...</p></div ←↩
>

you can apply color to the p.message element in your main.css file, and
in your variant put something like

p.message { color:inherit; border -color:inherit; }

KEYWORD LIST COMMON FOR MESSAGES AND STATUS.HTML

%message% The message itself. This is a HTML fragment.

%time%, %time{X}% The time when the message was received. %time% use
the default time format for the current locale. If you want to use a spe-
cific time format, use %time{X}% where X is a string containing the time
format. The time parameters are the same as the glibc function strftime.
Do man strftime to get the list of available parameters.

%messageDirection% (Kopete Extension) Represent the message direction,
if the message must be displayed right-to-left or left-to-right. The values
are either "rtl" or "ltr". Read Message Direction guideline to see how to
use this keyword properly.
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B.2 Kopete Chat Window Style Guideline

The Kopete Chat Window Style Guideline is a set of things that your Chat
Window style must support to be compliant with Kopete.

B.2.1 Support highlight

Your style must show highlight. In Kopete and Adium, the %textbackgr-
oundcolor{}% is replaced with the highlight color. Add this style attribute:
background-color: %textbackgroundcolor{}% to the HTML element that dis-
play the message.

B.2.2 Consecutive message templates are required.

This guideline is for people rewriting old XSL styles to the new format. All
styles must supply a template for consecutive messages. It is now a default
feature.

B.2.3 Use UTF-8 encoding.

The title said it all. You must save your files to UTF-8.

B.2.4 Supply Contents/Info.plist for interopability with
Adium

The Contents/Info.plist file is not used in Kopete yet. But if you want your
style to be compatible with Adium, you must supply that file. Here a basic
example file. Strings to replace are enclosed with "$".

<?xml version ="1.0" encoding="UTF -8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" ←↩

"http://www.apple.com/DTDs/PropertyList -1.0.dtd">
<plist version="1.0">
<dict >

<key >CFBundleDevelopmentRegion </key >
<string >English </string >
<key >CFBundleGetInfoString </key >
<string >$Your style full name$ </string >
<key >CFBundleIdentifier </key >
<string >$Your style ID in the form: com.adiumx.smooth. ←↩

operator.style$ </string >
<key >CFBundleInfoDictionaryVersion </key >
<string >1.0</string >
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<key >CFBundleName </key >
<string >$Your style name here$ </string >
<key >CFBundlePackageType </key >
<string >AdIM </string >
<key >MessageViewVersion </key >
<integer >3</integer >

</dict >
</plist >

B.2.5 Supply buddy_icon.png

You must place a file named buddy_icon.png in the Incoming and Outgoing.
These images will be used when the contact have no photo.

B.2.6 Support right-to-left languages with %messageDirec-
tion% keyword.

%messageDirection% keyword is present for languages in the world that write
right-to-left. It define the message direction, if it is "rtl" (right-to-left) or "ltr"
(left-to-right). Add this style attribute to the HTML element that display the
message: direction: %messageDirection%. Style preview in appearance con-
fig include a right-to-left to check if your style display it correctly. It should
begin the string from the right.
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Appendix C

Kopete Pipes Plugin
Implementation Guide

Beginning with Kopete 1.0, Kopete ships with a plugin called Pipes. Pipes al-
lows you to pipe incoming or outgoing messages through an external script or
executable. An incoming message will be piped through the executable before
it reaches your chat window, while outgoing messages will be piped through
the executable before they are sent over the internet. Pipes can receive text in
one of three forms:

Plain text body The body of the message, in plain ASCII text

HTML text body The body of the message, in HTML, as it would be if your
chat peer had sent HTML to you, which will be rendered in the chat win-
dow

XML full message An XML document that describes all the characteristics of
the message, including the HTML body.

This document describes the specifics of the XML format, and how to write a
program that can handle it.

C.1 XML Output

Here’s an example of what a program will receive in its standard input stream:

<?xml version="1.0" encoding="ISO-8859-1"?>
<message subject=""
route="outbound"
importance="1"
formattedTimestamp="11:06:46 am"
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timestamp="Sat Dec 1 11:06:46 2007"
type="normal"
mainContactId="spacemonkey1234"
time="11:06 am" >
<from>
<contact contactId="tdurden"
protocolIcon="aim_protocol"
userPhoto="/home/kde-devel/.kde4/share/apps/kopete/oscarpictures/tdurden.jpg" >
<contactDisplayName dir="ltr" text="tdurden" />
<metaContactDisplayName dir="ltr"
text="Tyler" />
</contact>
</from>
<to>
<contact contactId="spacemonkey1234"
protocolIcon="aim_protocol"
userPhoto="/home/kde-devel/.kde4/share/apps/kopete/avatars/User/7e542903e0ac7519a7496e85f5a5b99d.png" >
<contactDisplayName dir="ltr" text="spacemonkey1234" />
<metaContactDisplayName dir="ltr" text="Robert Paulson" />
</contact>
</to>
<body dir="ltr"
bgcolor="#000000"
color="#000000" >
&lt;span style=" color:#000000;">hey&lt;/span></body>
</message>

This XML is loosely based on the XSD used for chatstyles found at the Kopete
website. This code represents one message. There are a few things to note:

• The "timestamp" attribute in the "message" element is in ISO 8601 standard
format.

• The "protocolIcon" attribute in the "contact" element is chosen like this:

1. If the Contact object has the photo property set, that path is used.
2. If not, the Contact’s MetaContact is asked for a picture path, and that is

used regardless of being null or not.

• The "color" and "bgcolor" attributes in the "body" element are empty strings
if they are not set in Kopete. They are in web color format.

• The content inside the "body" element has "<" escaped, so it is not confused
with the actual XML structure. Obviously, to correctly interpret the body as
HTML, one would have to convert the "&lt;"s to "<"s.

C.2 XML Input

Your program will receive XML in its standard input stream, it will have the
opportunity to modify it, and then it must hand it back to Kopete by way of its
standard output stream. If your program modifies the following elements, the
internal knowledge that Kopete has of the message will be modified to reflect
your changes.
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• "message" attribute "timestamp" but not other time attributes

• "message" attribute "subject"

• "message" attribute "type"

• "message" attribute "importance"

• "body" attribute "color". This is usually set to a web color number, but can
be set to a name. The names defined by SVG are accepted by QColor in Qt
4, so they are the only names that may be used.

• "body" attribute "bgcolor" — same behaviour as "color"

• content of element "body"

If you modify elements or their attributes not mentioned above, your changes
to those elements will have no effect.

C.3 Acceptable Values

Some attributes have certain acceptable values. The Pipes plugin’s output will
always have legal values. If your program chooses to change these attributes,
they must remain legal. If not, Kopete’s behavior is undefined.

Attribute "route" in element "message" Must be "inbound", "outbound", or "in-
ternal"

Attribute "type" in element "message" Must be "action" or "normal"

Attribute "importance" in element "message" Must be "0" for low, "1" for nor-
mal, and "2" for high

Attribute "dir" in many elements Must be "ltr" for left-to-right or "rtl" for right-
to-left
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