Chapter 8. Command Reference

Menus and shortcut keys

The File Menu

FileOpen... (Ctrl+O)

Opens a map file.

FileOpen Recent

This is a shortcut to open recently opened maps. Clicking on this item opens a list to the side of the menu with several of the most recently opened files. Clicking on a specific file will open it in Marble - if the file still resides at the same location.

FileDownload Maps... (Ctrl+N)

Displays the Get Hot New Stuff! dialog to download additional maps for Marble, among others maps for Mars and Venus.

FileCreate a New Map...

Displays the Marble Map Theme Creation Wizard dialog to create a new map using Web Map Service data, your own image file or Open Street Map indexed tiles.

FileDownload Region...

Displays the Download Region dialog to download map data in different zoom levels for offline usage. See Download Map Regions for details.

FileExport Map... (Ctrl+S)

Exports a screenshot of Marble's map to an image file.

FilePrint... (Ctrl+P)

Prints a screenshot of Marble's map.

FilePrint Preview

Opens a window that shows a preview of the printed map.

FileWork Offline

If this option is selected Marble will no longer download map data from the Internet. The search feature gets restricted to the local database. New routes cannot be retrieved.

FileQuit (Ctrl+Q)

Quits Marble

The Edit Menu

EditCopy Map (Ctrl+C)

Copies a screenshot of Marble's map to the global clipboard.

EditCopy Coordinates

Copies the current coordinates to the global clipboard.

EditEdit Map (Ctrl+E)

Allows you to open the current map in the external map editor. The current version supports Potlatch (in a web browser), Merkaartor and JOSM map editors.

The View Menu

ViewCurrent Location

Toggle the display of the location page in the left panel. If a GPS device is connected with your computer, Marble displays longitude and latitude of your current location.

ViewCrosshairs

Toggle the display of a simple crosshair in the center of the map.

ViewRedisplay (F5)

The currently visible part of the map is downloaded again and refreshed on the screen.

ViewInfo Boxes

In this submenu you can to lock the position of the infoboxes and show or hide the plugins you have enabled in the Plugins page of Marbles configuration dialog.

ViewOnline Services

The Wikipedia plugin displays georeferenced Wikipedia articles as an icon on the map. A click onto the icon launches a browser window that displays the referenced site. The data is provided through a webservice via GeoNames.org. Likewise a Photos plugin currently provides photos via the FlickR photo sharing site

ViewClouds

Show real-time cloud cover. A real-time cloud map that gets updated every 3 hours. It uses GOES, METEOSAT, and GMS satellite imagery downloaded from the Geostationary Satellite Imagery page at Dundee University. Credits: Hari Nair, Xplanet Project

ViewAtmosphere

Show the diffuse reflection of the atmosphere around the Earth.

ViewStars

Show the star map as seen from the Solar System.

ViewSun Control...

Displays the Sun Control where you can set the Sun Shading and center the map on subsolar point position.

ViewTime Control...

Displays the Time Control dialog where you can set date and time and the simulation time speed.

ViewEclipses in year

Displays the list of the eclipses for the year chosen using ViewBrowse Eclipses... menu item.

This menu item will be shown only when Eclipses plugin is enabled

ViewBrowse Eclipses...

Displays the Eclipse Browser dialog where you can set the year to show eclipses for, open plugin settings dialog, view data on eclipse start, end, type and magnitude. Choose some eclipse item from the list and click on Go To Selected Eclipse to view the location of the eclipse on the globe.

This menu item will be shown only when Eclipses plugin is enabled

The Settings Menu

SettingsShow Toolbar

Toggle the display of the toolbar.

SettingsShow Statusbar

Toggle the display of the status bar.

SettingsPanels

Toggle the display of the Marble panels.

Tip

You can make Marble hide all panels or show them by selecting the SettingsPanelsHide All Panels/Show All Panels menu item or pressing F9 key on your keyboard.

SettingsView Size

Switches between various sizes of Marble map area. You can choose one of the sizes that are suitable for capturing frames for screencast or keep Marble map area resizable (Default (resizable) menu item).

SettingsFull Screen Mode (Ctrl+Shift+F)

Switches between normal view and full screen view. In full screen view, the titlebar is hidden and the actual application window is resized to the entire screen.

SettingsConfigure Marble Desktop Globe...

Display the Marble configuration dialog.

The Help Menu

HelpMarble Handbook (F1)

Invokes the KDE Help system starting at the Marble help pages. (this document).

HelpWhat's This? (Shift+F1)

Changes the mouse cursor to a combination arrow and question mark. Clicking on items within Marble will open a help window (if one exists for the particular item) explaining the item's function.

HelpReport Bug...

Opens the Bug report dialog where you can report a bug or request a wishlist feature.

HelpSwitch Application Language...

Opens a dialog where you can edit the Primary language and Fallback language for this application.

HelpAbout Marble

This will display version and author information.

HelpAbout KDE

This displays the KDE version and other basic information.