Chapter 4. Command Reference

Menu Commands

File Menu

FileOpen FITS... (Ctrl+O)

Open a FITS image in the FITS Viewer tool

FileSave Sky Image... (Ctrl+I)

Create image on disk from current display

FileRun Script... (Ctrl+R)

Run the specified KStars script

FilePrinting Wizard

Starts a wizard to configure capturing sky objects images using telescope and printing the results as a good looking printout for further use or catalogization.

FilePrint... (Ctrl+P)

Send the current sky map to the printer (or to a PostScript/PDF file)

FileQuit (Ctrl+Q)

Quit KStars

Time Menu

TimeSet Time to Now (Ctrl+E)

Sync time to system clock

TimeSet Time... (Ctrl+S)

Set time and date

TimeAdvance one step backward in time (<)

Advance one step backward in time in the KStars simulation of the sky chart. The duration of the time step can be configured after pressing the little > button on the KStars toolbar.

TimeStop Clock

Toggle whether time passes

TimeAdvance one step forward in time (>)

Advance one step forward in time in the KStars simulation of the sky chart. The duration of the time step can be configured after pressing the little > button on the KStars toolbar.

Pointing Menu

PointingZenith (Z)

Center the display at the Zenith point (straight up)

PointingNorth (N)

Center the display above the North point on the horizon

PointingEast (E)

Center the display above the East point on the horizon

PointingSouth (S)

Center the display above the South point on the horizon

PointingWest (W)

Center the display above the West point on the horizon

PointingSet Coordinates Manually... (Ctrl+M)

Center the display on specific sky coordinates

PointingFind Object (Ctrl+F)

Locate an object by name using the Find Object Window

PointingStop Tracking (Ctrl+T)

Toggle tracking on/off. While tracking, the display will remain centered on the current position or object.

View Menu

ViewZoom in (Ctrl++)

Zooms view in

ViewZoom out (Ctrl+-)

Zooms view out

ViewDefault Zoom (Ctrl+Z)

Restore the default Zoom setting

ViewZoom to Angular Size... (Ctrl+Shift+Z)

Zoom to specified field-of-view angle

ViewFull Screen Mode (Ctrl+Shift+F)

Toggle full-screen mode

ViewSwitch to star globe view / Switch to horizontal view (Space)

Toggle between the Horizontal and Equatorial Coordinate Systems

ViewProjectionLambert Azimuthal Equal-area (F5)

Switch sky chart view to the Lambert azimuthal equal-area projection.

ViewProjectionAzimuthal Equidistant (F6)

Switch sky chart view to the azimuthal equidistant projection.

ViewProjectionOrthographic (F7)

Switch sky chart view to the orthographic projection.

ViewProjectionEquirectangular (F8)

Switch sky chart view to the equirectangular projection.

ViewProjectionStereographic (F9)

Switch sky chart view to the stereographic projection.

ViewProjectionGnomonic (F10)

Switch sky chart view to the gnomonic projection.

Tools Menu

ToolsCalculator... (Ctrl+C)

Opens the AstroCalculator Tool, which provides full access to many of the mathematical functions used by KStars.

ToolsDevicesTelescope Wizard...

Opens the Telescope Wizard, which provides a step-by-step guide to help you connect to your telescope and control it with KStars.

ToolsDevicesDevice Manager...

Opens up the device manager, which allows you to start/shutdown device drivers and connect to remote INDI servers.

ToolsDevicesINDI Control Panel...

Opens up INDI Control Panel, which allows you to control all the features supported by a device.

ToolsSky Calendar

Opens the Sky Calendar Tool, which allows you to plan observations of Solar System planets by giving graphical data on sets and rises of these objects.

ToolsMoon Phase Calendar

Opens the Moon Phase Calendar Tool with graphical representation of Moon phases with convenient calendar to choose the month and year.

ToolsAltitude vs. Time... (Ctrl+A)

Opens the Altitude vs. Time Tool, which can plot curves representing the altitude of any object as a function of time. This is useful for planning observing sessions.

ToolsWhat's Up Tonight... (Ctrl+U)

Opens the What's Up Tonight Tool, which presents a summary of the objects which are observable from your location on a given date.

ToolsWhat's Interesting... (Ctrl+W)

Opens the What's Interesting Tool, which allows you to be informed about the most interesting observations that can be made from your current location using the given equipment.

ToolsScript Builder... (Ctrl+B)

Opens the Script Builder Tool, which provides a GUI interface for building KStars D-Bus scripts.

ToolsSolar System... (Ctrl+Y)

Opens the Solar System Viewer, which displays an overhead view of the solar system on the current simulation date.

ToolsEkos

Opens the powerful Ekos Tool, which is software guider for your telescope. Alignment capabilities of Ekos are powered by astrometry.net libraries.

ToolsJupiter's Moons... (Ctrl+J)

Opens the Jupiter Moons Tool, which displays the positions of Jupiter's four brightest moons as a function of time.

ToolsFlags

Opens the Flag manager Tool, which can be used to assign color labels and icons to the given positions on the sky chart.

Data Menu

DataDownload New Data... (Ctrl+D)

Open the Get Hot New Stuff dialog to download additional data for KStars.

DataUpdates

This submenu can be used to update various object data, namely asteroid and comet orbit elements as well as recent supernovae data from internet. The data will be downloaded for the current user account only. If you use KStars from different account you should download them for every account separately.

KStars tries to download recent supernovae list automatically by default. You can switch the download off using Supernovae page of KStars Settings window.

Observation Menu

ObservationObservation Planner (Ctrl+L)

Open the Observation Planner tool

ObservationExecute the session Plan (Ctrl+2)

Opens session plan wizard or execute the planned session.

Settings Menu

SettingsInfo BoxesShow Info Boxes

Toggle display of all three Info Boxes

SettingsInfo BoxesShow Time Box

Toggle display of the Time Info Box

SettingsInfo BoxesShow Focus Box

Toggle display of the Focus Info Box

SettingsInfo BoxesShow Location Box

Toggle display of the Location Info Box

SettingsToolbars Shown

Toggle display of the Main and View Toolbar

SettingsStatusbarShow Statusbar

Toggle display of the Statusbar

SettingsStatusbarShow Az/Alt Field

Toggle display of the mouse cursor's horizontal coordinates in the statusbar

SettingsStatusbarShow RA/Dec Field

Toggle display of the mouse cursor's horizontal coordinates in the statusbar

SettingsColor Schemes

This submenu contains all of the defined color schemes, including your custom schemes. Select any item to set that color scheme.

SettingsFOV Symbols

This submenu lists the available field-of-view (FOV) Symbols. The FOV Symbol is drawn at the center of the display. You may choose from the list of predefined symbols (No symbol, 7x35 Binoculars, One degree, or HST WFPC2), or you may define your own symbols (or modify existing symbols) using the Edit FOV Symbols... item.

SettingsSwitch to OpenGL/QPainter backend

KStars has an experimental OpenGL support. The corresponding backend works much faster on machines with hardware acceleration. Switch back to QPainter backend (default) if you experience troubles with OpenGL backend.

Important

In the current version, infoboxes do not work correctly when using OpenGL backend. So they will be disabled.

SettingsDefine Equipment... (Ctrl+0)

Allows you to define equipment (telescope, eyepiece, lens and filter) characteristics for observation logs.

SettingsAdd Observer... (Ctrl+1)

Can be used to add a new observer item for your observation logs.

SettingsGeographic... (Ctrl+G)

Select a new geographic location

SettingsConfigure KStars...

Modify configuration options

Additionally KStars has the common KDE Settings and Help menu items, for more information read the sections about the Settings Menu and Help Menu of the KDE Fundamentals.

Help Menu

HelpKStars Handbook (F1)

Invokes the KDE Help system starting at the KStars help pages. (this document).

HelpWhat's This? (Shift+F1)

Changes the mouse cursor to a combination arrow and question mark. Clicking on items within KStars will open a help window (if one exists for the particular item) explaining the item's function.

HelpReport Bug...

Opens the Bug report dialog where you can report a bug or request a wishlist feature.

HelpSwitch Application Language...

Opens a dialog where you can edit the Primary language and Fallback language for this application.

HelpAbout KStars

This will display version and author information.

HelpAbout KDE

This displays the KDE version and other basic information.

Popup Menu

The right click popup menu is context-sensitive, meaning its content varies depending on what kind of object you click on. We list all possible popup menu items here, with the relevant object type [in brackets].

[All]

Identification and type: The top one to three lines are devoted to the name(s) of the object, and its type. For stars, the Spectral Type is also shown here.

[All]

Rise, Transit, and Set times for the object on the current simulation date are shown on the next three lines.

[All]

Center & Track: Center the display on this location, and engage tracking. Equivalent to double-clicking.

[All]

Angular Distance To...: Enter "angular distance mode". In this mode, a dotted line is drawn from the first target object to the current mouse position. When you click with the right mouse button on a second object, this will display the angular distance between the two objects near the second object. You can press the Esc key to exit angular distance mode without measuring an angle.

[All]

Details: Open the Object Details window for this object.

[All]

Attach Label: Attach a permanent name label to the object. If the object already has a label attached, this item will read Remove Label.

[All]

Show ... Image: download an image of the object from the internet, and display it in the Image Viewer tool. The "..." text is replaced by a short description of the image's source. An object may have multiple image links available in its popup menu.

[All]

... Page: Display a webpage about the object in your default web browser. The "..." text is replaced by a short description of the page. An object may have multiple web links available in its popup menu.