Chapter 6. Command Reference

Menu Items

Apart from the common KDE menus described in the Menu chapter of the KDE Fundamentals documentation KmPlot has these application specific menu entries:

The File Menu

FileExport...

Exports the plotted graphs to an image file in all formats supported by KDE.

The Edit Menu

EditConstants...

Displays the Constants dialog box. See the section called “Constants Configuration”.

The View Menu

The first three items in the menu are related to zooming.

ViewZoom In (Ctrl+1)

This tool can be operator in two different manners. To zoom in on a point on the graph, click on it. To zoom in on a specific section of the graph, hold and drag the mouse to form a rectangle, which will be the new axes ranges when the mouse button is released.

ViewZoom Out (Ctrl+2)

The tool can also be used in two different manners. To zoom out and center on a point, click on that point. To fit the existing view into a rectangle, hold and drag the mouse to form that rectangle.

ViewFit Widget to Trigonometric Functions

The scale will be adapted to trigonometric functions. This works both for radians and degrees.

ViewReset View

Resets the view.

ViewCoordinate System...

Displays the Coordinate System dialog box. See the section called “Coordinate System Configuration”.

ViewShow Sliders

Toggles the visibility of the slider dialog. In the dialog move a slider to change the parameter of the function plot connected to it.

Enable this on the Function tab and select one of the sliders to change the parameter value dynamically. The values vary from 0 (left) to 10 (right) by default, but can be changed in the slider dialog.

For a small tutorial see Using Sliders.

The Tools Menu

This menu contains some tools for the functions that can be useful:

ToolsCalculator

Opens the Calculator dialog.

ToolsPlot Area...

Select a graph and the values of the horizontal axis in the new dialog that appears. Calculates the integral and draws the area between the graph and the horizontal axis in the range of the selected values in the color of the graph.

ToolsFind Minimum...

Find the minimum value of the graph in a specified range.

ToolsFind Maximum...

Find the maximum value of the graph in a specified range.

The Help Menu

KmPlot has a standard KDE Help with one addition:

HelpPredefined Math Functions...

Opens this handbook with a list of the predefined function names and constants that KmPlot knows.