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Abstract

KPackage is a GUI interface to the RPM, Debian and Slackware package man-
agers, it used the SMART package manager.
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Chapter 1

Introduction

KPackage is a GUI interface to the SMART package manager. KPackage is part
of the K Desktop Environment and, as a result, it is designed to integrate with
the KDE file manager.
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Chapter 2

Onscreen Fundamentals

KPackage has two panels. The left panel displays a tree of the installed and
available packages, the right panel displays information on the packages.

2.1 The Main Window - Package Tree

When KPackage is started normally (that is it has not been invoked via drag
and drop and has not been given any parameters) it displays two panels with
the package tree on the left, this tree shows installed and available packages.
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Left Panel - Package Tree

The left panel displays the list of packages

The Search: line filters the package tree so that only those packages whose
name or summary contains the search string are displayed. The columns that
are searched can be changed by a menu that can be brought up by clicking the
right mouse button on the search line.

Next to the search line is a pull down menu that filters the displayed packages
based on status:

• Installed Packages - Show packages that have been installed

• New Packages - Show uninstalled packages that are new or have been up-
dated

• Updated Packages - Show installed packages for which newer versions are
available

• Available Packages - Show uninstalled packages

• All Packages - All packages

The package tree is based on the sections of the distribution and shows sum-
mary information about the packages:

• Package - Name of the package

• Mark - Shows a tick if the package has been marked. Marking allows multi-
ple packages to be installed or uninstalled at once using the buttons located
below the package tree.
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• Summary - A short description of the package.

• Size - The package size

• Version - The package version

• Old Version - If the package updates an installed package, the version of the
old package

The packages have graphical labels to indicate their state, an image represent-
ing the package type means an installed package, a N indicates an available
package and a U means a package that can upgrade an installed package.

A single package is selected by clicking on the name. Clicking on the dot in the
Mark column marks the package with a tick, a second click unmarks it, while
Shift+left click can be used to mark a range of packages and Ctrl+left click can
be used to add and remove marks on packages.

Selecting a package from the tree displays information about it in the right
panel.

2.2 The Main Window - Package Information Panel

The right panel has tabs for displaying four different types of information
about selected packages
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•

The Properties tab which displays information on the selected package.
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•

The Dependencies List tab shows the Dependencies and Provides for the
package.
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•

The File List tab shows the files in the package and for installed packages
(provided the information is available) shows the state of the files. Files that
exist are marked with a tick, those that are missing are marked with a cross.
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•

The Change Log tab shows the change log for the package.

2.3 Installing Packages

To install a package you can

• locate the package you wish to install in Konqueror, drag it onto a running
copy of KPackage

• click on a package file in Konqueror and start a new copy of KPackage

• use on the Open menu items in KPackage

• selecting an available package in the package tree

For a selected package, use the Install button pops up the installation window.

For marked packages, use the Install Marked button on the left panel, which
pops up the install window.
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Install Dialog

The Install dialog lists the packages to be selected to be installed in a panel
in the top left as well the packages needed to satisfy any dependencies. The
selected packages have check boxes that allows their installation to be disabled.

The Install button will start the actual install. Normally the install window will
be deleted after a successful install but if the Keep this window check box is
selected the window will stay around.

The panel on the right is an integrated terminal window in which the installa-
tion programs are run, for interactive installation programs the interaction is
done in this window.

2.4 Uninstalling Packages

A selected package can be uninstalled by using the Uninstall button in the right
panel, the Uninstall Marked in the left panel can be used to uninstall marked
packages. The buttons bring up the Uninstall dialog.
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Uninstall Dialog

The Uninstall button in the window causes the packages to be uninstalled, and
the right panel provides an integrated terminal window for the uninstall pro-
gram.

2.5 Searching

2.5.1 Package Search Line

Search Line
The Search line filters the package tree so that only those packages whose name
or summary contains the search string are displayed.
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2.5.2 Find Package

Find Package

The Find Package dialog searches the names of the packages in the package
tree and moves to the next matching package. If Sub string is not set then it
will find only exact matches against packages names. If Wrap search is not set
the search doesn’t wrap around the end of the package tree.
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2.5.3 Find File

Find File
The Find File dialog searches for files the names of which contain the search
string. The columns in the display are:

• Installed - Ticked if it is an installed package.

• Type - The type of the package.

• Package - The name of the package

• File Name - The name of the matched file

Only the files in installed packages are shown unless Also search uninstalled
packages is set, this will only work if the apt-file command is installed. The
database used by the apt-file command is updated by the Apt-File Update
menu item.

2.6 Misc

2.6.1 Root Access

KPackage requires root access for installing/uninstalling packages, this can be
can be done by running KPackage as root, say by using KDE su.

Alternatively, if KPackage is running as a normal user it will try to run the in-
stall/uninstall programs as root by logging in to a pseudo terminal, it will use
either su, sudo or ssh to do this and if needed it will pop up a prompt window
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where the root password or ssh key can be typed. For this to work the root
prompt has to end in # . The Remember password option causes KPackage to
remember the password that is entered.

Password prompt

2.6.2 Drag and Drop

KPackage makes use of the KDE Drag and Drop protocol. This means that you
can drag and drop packages onto KPackage to open them. Dropping a file onto
the Find File dialog will find the package that contains the file.
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Chapter 3

Menus

This describes the KPackage menus.

3.1 File Menu

The items in the File menu are:

File→Open... (Ctrl+O) Brings up file selector for local and FTP files

File→Open Recent A list of the most recently open package files

File→ Remote Host... Starts another copy of KPackage to manage another sys-
tem remotely using ssh

File→ Recent Remote Hosts A list of the most recently accessed remote sys-
tems

File→Update Update apt indexes from package repositories.

File→Upgrade Upgrade the Debian installation to the latest versions of all
the packages.

File→ Fixup Attempt to fixup dependency problems

File→ Reload (F5) Reread the package data and rebuild the package tree

File→Quit (Ctrl+Q) Quit KPackage

3.2 Edit Menu

The items in the Edit menu are:
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Edit→ Find Package... (Ctrl+F) Search the installed package list for a pack-
age, the name of which contains the entered string

Edit→ Find File... Produces a list of packages that contain the entered file
name, selecting a line will display the information on that package. It
behaves slightly differently for RPM (where you have to enter the exact
file name) and DEB (where you can enter a regular expression).

Edit→Apt-File Update Searching for uninstall files uses the apt-file command,
this updates the database that apt-file uses.

3.3 Packages Menu

The items in the Packages menu are:

Packages→ Back (Alt+Left) Back button for navigation using the links in Prop-
erties entries in the right panel.

Packages→ Forward (Alt+Right) Forward button for navigation using the links
in Properties entries in the right panel.

Packages→ Expand Tree Fully expands the packages tree

Packages→ Collapse Tree Collapses the package tree so that only the tree struc-
ture is shown

Packages→ Clear Marked Unmarks all packages

Packages→Mark All Marks all packages that are members of the selected
view

Package→ Install Install the currently selected package

Package→ Install Marked Install all marked packages

Package→Uninstall Uninstall the currently selected package

Package→Uninstall Marked Uninstall all marked packages

3.4 Settings Menu

The items in the Settings menu are:

Settings→ Show Toolbar Toggle displaying the toolbar

Settings→ Save Settings Save options immediately

Settings→ Configure Shortcuts... The standard KDE dialog for setting short-
cut keys
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Settings→ Configure Toolbars... The standard KDE dialog for configuring tool
bars

Settings→ Configure KPackage...

The configuration dialog of KPackage has two pages:
Command

How to Execute Privileged Commands Use su, sudo or ssh to
run privileged commands for such things as installing and
uninstalling packages, The default is su but some systems
such as UbuntuTM requires the sudo. For running privi-
leged commands on remote hosts ssh is always used.

Misc
Verify List of Files If set the list of files in the package is checked

to see if they are actually installed

3.5 Help Menu

The items in the Help menu are:

Help→KPackage Handbook (F1) Invokes the KDE Help system starting at
the KPackage help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within KPackage will open
a help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→ Switch Application Language... Opens a dialog where you can edit
the Primary language and Fallback language for this application.

Help→About KPackage This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.

3.6 Toolbar

• Open

• Back

• Forward

• Expand Tree
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• Collapse Tree

• Find Package

• Find File

• Update

• Upgrade

• Reload
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Chapter 4

Credits and Licenses

KPackage

Documentation copyright 2005 Toivo Pedaste toivo@ucs.uwa.edu.au

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Installation

A.1 How to obtain KPackage

KPackage is part of the KDE project http://www.kde.org/ .

KPackage can be found in the kdeadmin package on ftp://ftp.kde.org/pub/-
kde/ , the main FTP site of the KDE project.

For information on how to obtain and compile it see http://techbase.kde.org/-
Getting_Started

There is more information on compilation at http://techbase.kde.org/Getting_Started/-
Build/FAQ

There is a web page at http://www.general.uwa.edu.au/u/toivo/kpackage

A.2 Requirements

For installing KPackage you need:

• QtTM 4 and KDE 4

• SMART package manager

For listing Debian packages no other software is needed but to install and unin-
stall the packages you need:

• the dpkg package manager or

• apt-get and apt-cache

For BSD packages you need the package management programs:
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• pkg_info

• pkg_add

• pkg_delete

For Slackware packages you need:

• installpkg

• removepkg

For dealing with Redhat packages you need:

• rpm

For KPackage to work correctly with RPM packages the RPM database must be
initialized. If typing rpm -qa gives an error about unable to open.... then
try rpm --rebuilddb.
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