Work Space

The work space is organized as worksheets. Select New Tab... from the File menu to create a new worksheet. A dialog will appear where you can set the name, the dimension and the update interval of the worksheet. To remove a worksheet again, select Close Tab from the File menu. Any modifications will be saved to the worksheet file. If a worksheet has never been saved, you will be asked for a file name. Worksheets consist of cells organized as a grid.

Each cell can be filled with a display for one or more sensors. You can fill a cell by dragging a sensor from the sensor browser and dropping it over the cell. If there is more than one type of display available for that type of sensor, a popup menu will appear. You can then select which display you prefer to use. Certain types of displays can display more than one sensor. Add more sensors to a display by dragging them over from the sensor browser and dropping them over the already existing display.

Worksheets can be configured by clicking Tab Properties at the View menu. In the appearing dialog you can set the dimension and the update interval.

Displays can be configured by clicking with the right mouse button on them. A popup menu appear where you can select whether you want to change the properties of that display or remove it from the worksheet.

Sensor Browser

The sensor browser exposes System Monitor's advanced functionality. To use it, you must first go to the File menu and create a new worksheet. It is shown whenever a custom worksheet is selected.

The sensor browser displays the registered hosts and their sensors in a tree form. Click on the tree handles to open or close a branch. Each sensor monitors a certain system value.

Tip

After you have configured your custom worksheet use the splitter and move it to the right edge of the window to hide the sensor browser.

If the sensor browser does not appear on a custom worksheet, it is probably hidden. To unhide it, select the right edge of the window and drag it to the left.

Line Graph

The line graph prints samples of one or more sensors over time. If, several sensors are displayed, the values are piled in different colors. If the display is large enough a grid will be displayed to show the range of the plotted samples. By default, the automatic range mode is active so the minimum and maximum values will be set automatically. Sometimes you want fixed minimum and maximum values. In that case, you can deactivate automatic range mode and set the values in the properties dialog.

Digital Display

The multimeter displays the sensor values as a digital meter. In the properties dialog you can specify a lower and upper limit. If the range is exceeded, the display is colored in the alarm color.

Bar Graph

The bar graph displays the sensor values as dancing bars. In the properties dialog you can specify minimum and maximum values of range and a lower and upper limit. If the range is exceeded, the display is colored in the alarm color.

Log to a File

The sensor logger does not display any values, but logs them in a file with additional date and time information. For each sensor you can specify a lower and upper limit in the properties dialog. If the range is exceeded, the entry of the sensor table is colored in the alarm color.

Partition Table

The Partition Usage has a special table sensor showing information about all mounted partitions

Connecting to other hosts

To connect to a new host use Monitor Remote Machine... from the File menu. A dialog box will appear and allows you to enter the name of the host you want to connect to. Below the name you can choose the connection method. The default is ssh, the secure shell. Alternatively the rsh, the remote shell, the daemon mode or a custom command can be used. Click OK to establish the connection. Shortly afterwards the new host will appear in the sensor browser and you can browse the list of sensors.

To establish a connection, a program called ksysguardd, that can be started in the following two modes, must be installed on the new host.

daemon mode

You can start ksysguardd at boot time in Daemon mode by adding -d as the argument. In this case, you have to select daemon mode at the connection dialog of ksysguard. A disadvantage of this connection type is that you won't be able to kill or renice a process in the Process Table and the data exchange over network won't be encrypted. As a result, daemon mode is not recommended.

shell mode

In this mode ksysguardd is started at connecting time by ksysguard. To make that possible, its location needs to be included in your PATH. Unfortunately the ssh does not source your .profile file, so your regular PATH setting will not be available. Instead it uses a default PATH like /bin:/usr/bin. Since it is very likely that KDE is not installed in these folders you need to create or update a file in your home folder. The file is called environment and needs to be in a hidden folder called .ssh. See the manual page for ssh for more details. The file needs to contain a line similar to:

PATH=/bin:/usr/bin:/opt/kde/bin

assuming that ksysguardd can be found under /opt/kde/bin/ksysguardd.

Tip

When using ssh you should make sure that you have your identity.pub installed on the remote machine and the host key of the remote machine is already registered on your machine. If you don't set up identity.pub correctly, you will be asked for your password every time you start ksysguard. The easiest way to make sure that everything is working is to run ssh remotehost ksysguardd in a shell. If you are greeted by ksysguardd, then everything is working correctly and you can type quit to exit ksysguardd.

Note

For experts: ksysguardd is a very small program that is only linked against the libc. So it can also be used on machines that do not have a full blown KDE installed, such as servers. Many major distributions provide a separate ksysguardd package for your convenience. If you choose the custom command option in the host connector you need to specify the complete command to start ksysguardd.