Chapter 5. Command Reference

The main Krecipes window

The File Menu

FileNew Recipe (Ctrl+N)

Creates a new recipe - see Entering and Editing Recipes for details.

FileSave (Ctrl+S)

Saves the recipe.

FilePrint (Ctrl+P)

Prints the current recipe – See the section Printing Your Recipe for instructions.

FileImport from File... (Ctrl+I)

Imports recipes from a file – See the section Importing from a File for instructions.

FileImport from Database...

Imports recipes from one of 3 database choices

See the corresponding sections on importing from a Database – SQLite, MySQL, or PostgreSQL.

FileExport... (Ctrl+O)

Exports either a single recipe or all recipes to a file – Exporting Recipes to Other Formats.

FileBackup

Backs up your Krecipes database file   refer to the section Backing Up Your Krecipes Database.

FileRestore

Restores your Krecipes database file   refer to the section Restoring Your Krecipes Database.

FileQuit (Ctrl+Q)

Quits Krecipes.

The Edit Menu

EditEdit Recipe (Ctrl+E)

Accesses the Krecipes Edit mode - see Entering and Editing Recipes for details.

EditCopy to Clipboard (Ctrl+C)

Will make a text copy of a selected recipe and place it on the Clipboard in order to paste into another application, for example an email.

The View Menu

ViewReload (F5)

Reloads the currently active recipe.

ViewShow Recipe(s) (Ctrl+L)

Displays the currently active recipe.

The Tools Menu

ToolsMeasurement Converter (Ctrl+M)

Accesses the Krecipes Measurement Converter tool - see the Using the Measurement Converter section for instruction.

The Settings Menu

SettingsPage Setup...

Accesses the Krecipes Page Setup interface for defining the page layout – see the section on Page Setup for further details.

SettingsPrint Setup...

Accesses the Krecipes Print Setup interface – this interface is identical to the Page Setup, but is used to define a setup that can be different and separate from the page layout for viewing your recipes.

See the section on Print Setup for further details.

SettingsShow Statusbar

Turns display of Statusbar on and off.

SettingsConfigure Shortcuts...

Opens the Configure Shortcuts - Krecipes window from which Shortcuts can be defined.

For complete instructions on configuring shortcuts, see the section Creating Shortcuts.

SettingsConfigure Toolbars...

Opens the Configure Toolbars - Krecipes window from which Toolbars can be configured.

See the section Customizing the Toolbar for details.

SettingsConfigure Krecipes...

Opens the Configure - Krecipes window from which a number of preferences can be defined.

See the section Configure Krecipes for specific configuration instructions.

The Help Menu

Krecipes has the common KDE Help menu items, for more information read the section about the Help Menu of the KDE Fundamentals.