Appendix A. Installation

Jack H. Ostroff

Revision 4.6 (2011-07-20)

This appendix primarily addresses the installation of KMyMoney under the Linux® operating system. The final section addresses other operating systems.

How to obtain KMyMoney

Although KMyMoney has existed for a number of years, we are still working on full integration into KDE. Early stable versions (1.0.x) required libraries from KDE 3, and so were not available in many Linux distributions, which had already migrated to KDE 4. However, with the release of version 4.5 in August 2010, KMyMoney could be easily compiled and installed on any version of KDE 4.3 or higher. The current version, 4.6, requires KDE 4.3, specifically kdelibs and kdepimlibs.

The rest of this section will describe installing KMyMoney using the standard software installation process for your Linux distribution. The following section will discuss compiling from source.

Official Distribution Packages

The best way to install KMyMoney is to use the package manager of your distribution, such as apt-get, yum, portage, or pacman. This will take care of all the dependencies and required libraries. Although it takes some time after the release a new version of KMyMoney for all the distributions to add it to their official repositories, please check there first.

Unsupported Repositories

Many Linux distributions have users who provide unsupported repositories that offer more up-to-date packages than the distributions' official repositories. A list of these may be found at the KMyMoney home page.