Kapitel 6. Befehlsreferenz

Menüeinträge

Außer den bekannten KDE-Menüeinträgen, die im Kapitel Menüs der KDE-Grundlagen beschrieben werden, gibt es folgende spezielle Menüeinträge für KmPlot:

Das Menü Datei

DateiExportieren ...

Exportiert den gezeichneten Graphen in eine Bilddatei in allen von KDE unterstützten Grafikformaten.

Das Menu Bearbeiten

BearbeitenKonstanten ...

Öffnet den Dialog Konstanten. Siehe „Einstellung der Konstanten“.

Das Menü Ansicht

Die ersten drei Einträge in diesem Menü ändern den Zoom-Modus.

AnsichtVergrößern (Strg+1)

Mit diesem Menüeintrag können Sie die Zeichnung auf zwei Arten vergrößern. Klicken Sie auf einen Punkt in der Zeichnung, um sie mit diesem Punkt als Mittelpunkt zu der vergrößern. Um einen bestimmten Bereich der Zeichnung zu vergrößern, ziehen Sie mit gedrückter Maustaste ein Rechteck für den neuen Bereich der Achsenwerte und lassen Sie dann die Maustaste los.

AnsichtVerkleinern (Strg+2)

Mit diesem Menüeintrag können Sie die Zeichnung auf zwei Arten verkleinern. Klicken Sie auf einen Punkt in der Zeichnung, um sie mit diesem Punkt als Mittelpunkt zu der verkleinern. Um einen bestimmten Bereich der Zeichnung zu verkleinern, ziehen Sie mit gedrückter Maustaste ein Rechteck für den neuen Bereich der Achsenwerte und lassen Sie dann die Maustaste los.

AnsichtFläche an trigonometrische Funktionen anpassen

Die Vergrößerung wird an trigonometrische Funktionen angepasst. Dies funktioniert für Bogenmaß und Grad.

AnsichtAnsicht zurücksetzen

Setzt die Ansicht auf die ursprüngliche Vergrößerung zurück.

AnsichtKoordinatensystem ...

Öffnet den Dialog Koordinatensystem. Siehe „Einstellung des Koordinatensystem“.

AnsichtSchieberegler anzeigen

Blendet den Dialog Schieberegler ein oder aus. Verschieben Sie in diesem Dialog einen Regler, um den Parameter der damit verbundenen Funktion zu ändern.

Aktivieren Sie den Schieberegler auf der Karteikarte Funktion und wählen Sie einen Regler für die dynamische Änderung eines Parameterwertes. In der Voreinstellung geht der Wertebereich von 0 (links) bis 10 (rechts), das kann jedoch im Dialog Schieberegler geändert werden.

Eine kurze Anleitung finden Sie auf der KDE-Userbase im Artikel Schieberegler verwenden.

Das Menü Extras

Diese Menü enthält einige nützliche Hilfsmittel für die Funktionen:

ExtrasRechner

Öffnet den Dialog Rechner.

ExtrasFläche zeichnen ...

Wählen Sie im Dialog einen Graphen und die waagerechten Werte für den Graphen. Dann wird das Integral berechnet und die Fläche zwischen dem Graphen und der waagerechten Achse im gewählten Intervall wird in der Farbe des Graphen gezeichnet.

ExtrasMinimumpunkt suchen...

Sucht den minimalen Wert des Graphen im vorgegebenen Bereich.

ExtrasMaximumpunkt suchen ...

Sucht den maximalen Wert des Graphen im vorgegebenen Bereich.

Das Menü Hilfe

KmPlot hat die normale KDE-Hilfe mit einem zusätzlichen Eintrag:

HilfeVordefinierte mathematische Funktionen

Öffnet dieses Handbuch mit einer Liste vordefinierter Funktionsnamen und Konstanten, die KmPlot kennt.