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Abstract

This Handbook describes KEdit, a simple text editor for KDE
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Chapter 1

Introduction

KEdit is a text editor for the KDE Desktop. It is a small editor which can be used
with Konqueror for text and configuration file browsing. KEdit also serves well
for creating small plain text documents. It is not meant to be a programmers
editor, in particular it is not meant to replace any of the more powerful editors
such as Kate, XEmacs or Emacs. KEdit’s functionality will intentionally remain
rather limited to ensure a reasonably fast start.
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Chapter 2

Some Fundamentals

KEdit is very simple to use. Anyone that has used a text editor should have no
problems.

2.1 Drag and Drop

KEdit uses the KDE Drag and Drop protocol. Files may be dragged and dropped
onto KEdit from the Desktop, Konqueror, or some remote FTP site opened in
one of Konqueror’s windows.

2.2 Command Line Options

Though KEdit may most often be started from the KDE program menu, or a
desktop icon, it can also be opened at the command line prompt of a terminal
window. There are a few useful options that are available when doing this.

2.2.1 Specify a File

By specifying the path and name of a particular file the user can have KEdit
open (or create) that file immediately upon startup.This option might look
something like the following:

%kedit /home/myhome/docs/myfile.txt
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2.2.2 Specify a file on the Internet

The above-mentioned method could even be used to open files on the internet
(if the user has an active connection at the time.) An example of this might look
like the following:

%kedit ftp://ftp.kde.org/pub/kde/Welcome.msg

2.2.3 Other Command Line Options

The following command line help options are available

kedit --help This lists the most basic options available at the command line.

kedit --help-qt This lists the options available for changing the way KEdit
interacts with QtTM.

kedit --help-kde This lists the options available for changing the way KEdit
interacts with KDE.

kedit --help-all This lists all of the command line options.

kedit --author Lists KEdit’s authors in the terminal window

kedit --version Lists version information for QtTM, KDE, and KEdit. Also
available through kedit -V

2.3 Key Bindings

Many of the key bindings (shortcuts) are configurable by way of the Settings
menu. By default KEdit honors the following key bindings.

Key Binding Action

Left Arrow Move the cursor one character
leftwards.

Right Arrow Move the cursor one character
rightwards.

Up Arrow Move the cursor one line upwards

Down Arrow Move the cursor one line
downwards.

Page Up Move the cursor one page
upwards.

Page Down Move the cursor one page
downwards.
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Backspace Delete the character to the left of
the cursor.

Home Move the cursor to the beginning
of the line.

End Move the cursor to the end of the
line.

Delete Delete the character to the right of
the cursor.

Shift+Left Arrow Mark text one character leftwards.

Shift+Right Arrow Mark text one character
rightwards.

Ctrl+A Select all the text in the document.

Ctrl+B Move the cursor one character
leftwards.

Ctrl+C Copy the marked text to the
clipboard.

Ctrl+D Delete the character to the right of
the cursor.

Ctrl+E Move the cursor to the end of the
line.

Ctrl+F Search for text in the document.
Ctrl+G Go to line.

Ctrl+H Delete the character to the left of
the cursor.

Ctrl+K Create a new document

Ctrl+N Move the cursor one line
downwards.

Ctrl+P Print.

Ctrl+V
Paste the clipboard text into the
document at the text cursor
position.

Ctrl+X Cut the marked text, copying it to
the clipboard.

Ctrl+Y

Yank (paste) the content of the
kill-buffer (clipboard) into the
document, at the current cursor
position.
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Chapter 3

The Menu Entries

3.1 The File Menu

File→New (Ctrl+N) This starts a new Document in a new instance of the
editor.

File→Open... (Ctrl+O) This command opens a file. It does this by means of
a dialog box which allows the user to navigate the file system.
The dialog operates like a small file manager. Clicking on folders dis-
played in the central window directs the dialog to enter that folder - dis-
playing its contents. There is an entry/drop down box which can be used
to directly type in the location and name of the file or by clicking the ar-
row at the side choose from a drop down list of recently used locations.
Below this is a filter which similarly may have data entered directly or
chosen from a drop down list of recent filter types. The filter facility lets
only files that meet its specifications be displayed in the central window.
If the filter contained text such as *.txt then only files with the txt exten-
sion would be visible in the selection window.
The toolbar has left and right arrow buttons that let the user move back
and forth through previously selected folders as well as an up arrow
button for moving up the folder tree. The button with the little house
takes the user to his or her home folder, and the one with the two arrows
curved in on each other updates the view of the current folder. The flag
button lets the user set a new bookmark at the current folder or go to one
that was previously set. The icon of the folder with the sparkle on it, al-
lows you to create a new folder. Finally there is drop down box on the
toolbar with a list of some commonly frequented folders.

File→Open Recent This is a shortcut to open recently saved documents.
Clicking on this item opens a list to the side of the menu with a list of
several of the most recently saved files. Clicking on a specific file will
open it in KEdit - if the file still resides at the same location.
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File→ Save (Ctrl+S) This saves the current document. If there has already
been a save of the document then this will overwrite the previously saved
file without asking for the user’s consent.

NOTE
The editor can be configured to make a backup.

If it is the first save of a new document the save as dialog (described
below) will be invoked.

File→ Save As... This allows a document to be saved with a new file name.
This is done by means of the file dialog box described above in the Open
section of this help file.

File→ Print... (Ctrl+P) This opens a simple print dialog allowing the user to
specify what, where, and how to print. The user can choose between the
standard lpr or a custom command as well as whether to print the whole
document or a selected section.

File→Mail... This is used to email the current document. It calls a mail dialog
whereby the user can enter the address and subject for the message.
You may set your preferred mail client in KControl

File→ Close (Ctrl+W) This will close the editor window, if you have more
than one instance of KEdit running, those instances will not be closed.

File→Quit (Ctrl+Q) This closes the editor.

3.2 The Edit Menu

Edit→Undo (Ctrl+Z) This is used to eliminate or reverse the most recent
user action or operation.

Edit→ Redo (Ctrl+Shift+Z) This will reverse the most recent change (if any)
made using Undo.

Edit→ Cut (Ctrl+X) This command deletes the current selection and places it
on the clipboard. The clipboard is a feature of KDE that works invisibly
to provide a way to transfer data between applications.

Edit→ Copy (Ctrl+C) This copies the currently selected text to the clipboard
so that it may be pasted elsewhere. The clipboard is a feature of KDE that
works invisibly to provide a way to transfer data between applications.

Edit→ Paste (Ctrl+V) This will insert the contents of the clipboard at the cur-
sor position. The clipboard is feature of KDE that works invisibly to pro-
vide a way to transfer data between applications.

Edit→ Select All (Ctrl+A) This will select the entire document. This could be
very useful for copying the entire file to another application.
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Edit→ Find... (Ctrl+F) This opens the find dialog which is used to specify
the text to Find in the document. There is small text box for entering the
search pattern. Two other options are included to make the search more
efficient. Selecting Case sensitive will limit finds to entries that match the
case (upper or lower) of each of the characters in the search pattern. Find
backwards directs the search to proceed in an upwardly direction.

Edit→ Find Next (F3) This repeats the last find operation, if any, without call-
ing the find dialog box.

Edit→ Replace... (Ctrl+R) This command opens the replace dialog box. The
replace dialog is similar to the above-mentioned find dialog but with the
addition of a Replace with: text box. Using this dialog the user can spec-
ify both the text to be found and text with which to replace it. This di-
alog also contains two additional buttons. The Replace button allows
the user to make one replacement at a time which is useful when not all
instances of the searched for text should be replaced. The Replace All
button should be used with caution as it will immediately replace every
instance of the specified text.

Edit→ Insert File... This opens the FileOpen dialog box whereby the user can
insert a complete file in the open document. The file will be entered at the
position of the blinking text cursor.

Edit→ Insert Date This will enter the current date at the position of the blink-
ing text cursor.

Edit→ Clean Spaces Choosing this item will remove from any selected text
any extra spaces and all carriage returns (the code for the end of a para-
graph brought about by pressing the Enter key.) In other words, any
occurrences of two or more spaces will be reduced to one space; and all
paragraphs and blank lines will be reduced to one single paragraph.

3.3 The Go Menu

Go→Go to Line... (Ctrl+G) This opens the goto line dialog box which is used
to have the cursor jump to a particular line (specified by number) in the
document. The line number may be entered directly into the text box or
graphically by clicking on the up or down arrow spin controls at the side
of the text box. The little up arrow will increase the line number and the
down arrow decrease it.

3.4 The Tools Menu

Tools→ Spelling... This initiates the spell checking program - a program de-
signed to help the user catch and correct any spelling errors. Clicking
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on this entry will start the checker and bring up the speller dialog box
through which the user can control the process. There are three text boxes
lined up vertically just to the left of center with their corresponding labels
further to the left. Starting at the top they are:

Misspelled word: Here, the spell checker indicates the word currently
under consideration. This happens when the checker encounters a
word not in its dictionary - a file containing a list of correctly spelled
words against which it compares each word in the editor.

Replacement: If the checker has any similar words in its dictionary the
first one will be listed here. The user can accept the suggestion, type
in his or her own correction, or choose a different suggestion from
the next box.

Suggestions: The checker may list here a number of possible replace-
ments for the word under consideration. Clicking on any one of the
suggestions will cause that word to be entered in the Replacement:
box, above.

On dialog box are 8 buttons that allow the user to control the spell check
process. They are:

Replace This button has the checker replace the word under considera-
tion in the document with the word in the Replacement: box.

Replace All This button causes the checker to replace not only the cur-
rent Misspelled Word: but to automatically make the same substitu-
tion for any other occurrences of this Misspelled Word: in the docu-
ment.

Ignore Activating this button will have the checker move on without
making any changes.

Ignore All This button tells the checker to do nothing with the current
Misspelled Word: and to pass over any other instances of the same
word.

NOTE
This only applies to the current spell check run. If the checker is run
again later it will stop on this same word.

Add Pressing this button adds the word in the Misspelled Word: box to
the checker’s dictionary. This means that in the future the checker
will always consider this word to be correctly spelled.

Help This invokes the KDE help system starting at the KEdit help pages
(this document).

Stop This button stops the spell check process.
Cancel This button cancels the spell check process.

Located horizontally along the bottom of the spell check dialog is a progress
bar. As the checking process proceeds the bar will fill from left to right
providing a graphical representation of how far along in the document
the process has reached.
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NOTE
A numerical display of the spell check process is simultaneously displayed in
the status bar of the editor. The status bar is the horizontal strip at the bottom
of the editor just outside of the text entry area.

3.5 The Settings Menu

Settings→ Show Toolbar When checked, this displays a movable toolbar con-
taining buttons used to initiate frequently used commands. The toolbar
is most commonly located at the top of the editor just under the menu.
When unchecked the toolbar is hidden. Clicking on the striated grip will
hide or unhide the bar. Clicking and dragging on this grip allows the
user to move the bar.

Settings→ Show Statusbar When checked, this displays a small bar at the
bottom of the editor containing information about the status of the cur-
rent document. When unchecked the status bar is hidden.

Settings→ Save Settings This saves the current editor settings to be used for
future documents.

Settings→ Configure Shortcuts... This command opens a dialog box whereby
the key bindings may be changed. A display window at the top of the di-
alog box shows the list of commands available. Below the display are
three radio buttons. The user may choose a modifier key from None,
Default, and Custom.

NOTE
Note that a set of radio buttons only allows the selection of one of the of-
fered items - in the way that buttons on a car radio only offer the selection of
one preset station. Also, the Default Key selection is only available for those
commands that actually have a ‘default’ shortcut.)

Selecting the Custom key option activates the three check boxes and key
button at the bottom of the dialog. The user may then select a combina-
tion of keys for the command in question by means of the check boxes
and key button. For example, with the About KDE command selected
in the display window, the user could select Ctrl and Alt, click on the
key button, and then press the K key on the keyboard. This would mean
that anytime he or she held down the Ctrl and Alt buttons and pressed
K (while using KEdit) the About KDE display box would be called.

Settings→ Configure Toolbars... This will open the dialog whereby the tool-
bar configuration may be changed. The user can choose which shortcut
buttons should appear on the toolbar, as well as whether and where any
text should appear with the buttons. Other choices include button (icon)
size and toolbar location (top, left, right, floating, or flat.) Flat causes the
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toolbar to be retracted. A click on the striated grip icon will extend it
for use and another click retract it again. A display window on the left
lists the commands available to be placed on the toolbar. A display on
the right lists those commands already on the toolbar. A set of four ar-
row buttons between the two displays manipulates the selections. The
right pointing arrow places any command selected in the left pane onto
the right pane, i.e., it is added to the toolbar. The left arrow does just
the opposite, removing any action selected in the right window from the
toolbar. The up and down pointing arrows change the position of an ac-
tion selected in the right window which changes the position of its button
in the toolbar.

Settings→ Configure KEdit... This menu item opens a dialog whereby sev-
eral different settings may be adjusted.

3.6 The Help Menu

Help→KEdit Handbook (F1) Invokes the KDE Help system starting at the
KEdit help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within KEdit will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→About KEdit This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.
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Chapter 4

The Preferences Dialog

Selecting Settings→Configure KEdit from the menu brings up the preferences
dialog box. This dialog can be used to alter a number of different settings.
The settings available for change vary according to which category the user
chooses from a vertical list on the left side of the dialog. By means of a row of
five buttons along the bottom of the box the user can control the process. She or
he may invoke the Help system, set the options to their Default values, accept
the current settings and close the dialog by means of the OK button, Apply
the current choices to the document without closing the dialog, or Cancel the
process. The categories Font, Color, Spelling, and Miscellaneous are detailed
below.

4.1 Font

The preferences dialog opens with this, the first category, chosen. Here the user
can change four settings and see the effects of any changes in the text sample
displayed in the rectangle at the bottom or the box. The settings are:

Font: This scroll box allows the user to select by name from among the various
fonts available. The appearance of any selected font may be seen in the
sample text displayed in the rectangle at the bottom of the dialog.

Font style: This, the center, selection box is used to choose between the four
basic styles of Regular, Italic, Bold, and Bold Italic. The appearance of the
selected style may be seen in the sample text displayed in the rectangle
at the bottom of the dialog.

Size: This, the rightmost scroll/selection box allows the user to change font
size. The larger the number chosen the larger the font size will be. The
sample text displayed in the rectangle at the bottom of the dialog will
reflect the choice of size.
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4.2 Color

This section provides access to two different color settings, described below.
Each of these settings may be changed by clicking on its corresponding button.
These are special wide buttons that are the color of the current setting. Clicking
on one of the buttons calls a special color dialog box used to change the setting.
The color dialog box provides a convenient and graphical way to select a color.
In the upper left of the box is a rectangular display of a spectrum of colors. To
the immediate right of this, is a vertical bar displaying a range of intensity from
the most dark at the bottom to the most light at the top. The user may select and
adjust a color by clicking in these two boxes. Clicking in the rectangular display
selects a particular mix of red, green, and blue colors and in the vertical bar
selects a level of intensity (value). The various color attributes are displayed in
numerical form in small text boxes located directly below the spectral rectangle
and the user can see them change as the color is adjusted. These attributes
include the mix of the basic color components (red, green, and blue) as well as
hue and saturation levels. Alternatively the user can enter figures directly in
these boxes. There is also a square at the bottom center of the dialog box which
displays the color which is under consideration at any time. To the right of this
display is another text box labeled HTML: This shows the user the color code
that would be used to specify the particular displayed color in HTML code
which is widely used for web pages.
In addition to the above, the color dialog allows the capture of any color cur-
rently displayed on the desktop or in another program. Clicking on the button
with the dropper icon (located on the right side of the dialog box) changes the
shape of the mouse cursor to a set of cross hairs. Clicking again will pick up
the color attributes of whatever color is displayed under the cross hairs.
Furthermore the user has the option of adding any color to a personal palette
of Use custom colors by clicking on the wide button labeled Add to Custom
Colors (which is located above the display square.) This adds the current color
to the custom color palette. This palette and any other available palettes can be
displayed using the drop down selection box located directly above the palette
display at the top right of the dialog box. Besides the custom colors, the user
can access a number of pre-prepared palettes.

Use custom colors By default KEdit will use your system color scheme. If this
is enabled, you may choose a Foreground and background color below.

Foreground color: Here the user can specify a color for the text used in KEdit.

Background color: Here the user can specify a color for the general background
of KEdit.

4.3 Spelling

A spell checker is a program designed to help the user catch and correct any
spelling errors. This section of the preferences dialog allows certain key set-
tings to be adjusted in this regard.
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Create root/affix combinations not in dictionary Selecting this option allows
the spell checker to register as ‘correct’ combinations of root words with
suffixes or prefixes even if the particular combination is not listed in its
dictionary database of words.

Consider run-together words as spelling errors Selecting this will cause the
spell checker to register as ‘misspelled’ two or more correctly spelled
words that are ‘run-together’, i.e., that do not have spaces separating
them.

Dictionary: Depending on the user’s installation, one or more different lan-
guage spelling dictionaries may be available. This drop down box allows
the user to choose which language the spell checker should use.

Encoding: There are different coding systems used to associate particular codes
with particular characters and symbols. If the user knows which code he
or she is using this drop down box allows this code to be specified so that
the spell checker can do its job correctly.

Client: Since KEdit does not contain its own spell checker, an external one
must be chosen. This is where the user may specify which spell check
program to use.

4.4 Miscellaneous

This category deals with three different properties detailed below.

Word wrap: Word wrap is a feature that causes the editor to automatically
start a new line of text and move (wrap) the cursor to the beginning of
that new line. The drop down box at the top of the dialog provides the
following three word wrap choices:

Disable Wrapping Choosing this will keep the editor from doing any
wrapping. The user will have to start new lines manually (with the
Enter key.)

Soft wrapping This choice has the editor automatically adjust the line
lengths to fit its current width. In other words, the wider the user
makes the editor the longer the lines will be; and the narrower the
editor, the shorter the lines will be. These line breaks are not saved
in the file.

At specified column Choosing this activates a text box immediately be-
low, labeled Wrap column:. Here the user may specify the maximum
number of characters in a line of text.

NOTE
Each character including spaces fills one column.
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Make backup when saving a file This check box tells the editor to rename the
last saved version of the current document before carrying out a save
command. The editor does this by adding a tilde ( ) at the end of the
name of the original file. In this way the user has a chance to recover a
document if she or he had mistakenly saved something over it.
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Chapter 5

Credits and Licenses

KEdit Copyright 2000 by Bernd Johannes Wuebben wuebben@math.cornell.edu

Documentation Copyright 2000 by Thad McGinnis ctmcginnis@compuserve.com.

This version of the KEdit Handbook is based on the original by: Bernd Jo-
hannes Wuebben wuebben@math.cornell.edu
This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Installation

KEdit is part of the KDE project http://www.kde.org/ .

KEdit can be found in the kdeutils package on ftp://ftp.kde.org/pub/kde/ ,
the main FTP site of the KDE project.

In order to compile and install KEdit on your system, type the following in the
base directory of the KEdit distribution:

% ./configure
% make
% make install

Since KEdit uses autoconf and automake you should have no trouble compil-
ing it. Should you run into problems please report them to the KDE mailing
lists.
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