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Abstract

Ark is an archive manager for KDE.
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Chapter 1

Introduction

Ark is a program for managing various archive formats within the KDE envi-
ronment. Archives can be viewed, extracted, created and modified from within
Ark. The program can handle various formats such as tar, gzip, bzip2, zip, rar
and lha (if appropriate command-line programs are installed). Ark can work
closely with Konqueror in the KDE environment to handle archives, if you in-
stall the Konqueror Integration plugin available in the kdeaddons package.
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Chapter 2

Using Ark

2.1 Opening Archives

To open an archive in Ark, choose Open from the File menu. You can also open
archive files by dragging and dropping from Konqueror. Archive files should
be associated with Ark, so you can also right click a file in Konqueror and select
Ark to open it.

2.2 Working with Files

Once an archive has been opened, you can perform various operations on the
files inside the archive. By right clicking on a file within the archive, or selecting
a file and using the Action menu, you can choose what you want to do:

Extract will extract the file to a location you specify on disk.
Delete will remove the currently selected file(s) from the archive.

View will open the file in the integrated viewer, or in the default viewer pro-
gram in case the integrated viewer cannot view the file, or you have disabled
it in the Configuration Window.

Open With... allows you to open the file in a program you choose.

Edit With... will open the file a program you choose. The difference between
this and Open With... is that any changes you make will be saved to the file
in the archive.
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2.3 Extracting Archives

Once an archive has been opened in Ark, it can be extracted. To extract files
from an archive, you can either select Extract... from the Action menu or right
click on the file. The Extract dialog allows you to select where you will extract
files to. You can also select which files to extract:

e Current extracts the most recently selected file. If multiple files are selected,
only the most recently selected one will be extracted.

e All extracts the entire contents of the archive.
e Selected Files extracts all the files which have been selected.

e Pattern allows you to specify which files will be extracted, corresponding to
certain patterns, e.g. *.txt or *. jpg. Note that you can only use one pattern
at a time.

You can specify the folder to extract files to in the Extract to: text box. The
default location is the folder the archive is in. You may also choose to have the
folder that you extract into open in Konqueror once the extraction is complete.

2.4 Creating Archives and Adding Files

To create a new archive in Ark, choose New from the File menu.

You can then type the name of the archive, with the appropriate extension (t-
ar.gz, zip, bz2 etc.). To add files to the archive, choose Add File... from the
Action menu. If you want to add an entire folder to an archive, choose Add
Folder... from the Action menu.

An alternative way to add files to the archive is to drag a file from Konqueror
or the desktop into the main Ark window, and it will be added to the current
archive.
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Chapter 3

Configuring Ark

3.1 General Settings

Use integrated viewer Use the integrated viewer to view files, if possible.
Enable Konqueror integration Enable the plugin for extracting or adding files
to archives through Konqueror context menus.

This option only works if the Konqueror integration plugin from kdead-
dons is installed on your system.

3.2 File Addition Settings

Many of these options are only configurable for specific archive formats. Other
formats may behave either way and are not configurable.

Replace old files only with newer files If you add filenames that already exist
in an archive, only replace them if the added files are newer than the ones
already present in the archive.

Force MS-DOS short filenames (Zip) Force names to the DOS 8.3 format.
Affects only zip files

Translate LF to DOS CRLF (Zip) Convert the line endings in text files to DOS

format from UNIX format.
Affects only zip files

Store symlinks as links (Zip, Rar) Save links inside the archive, instead of fol-
lowing them and including the files being linked to.
Affects zip and rar archives.

Recursively add subfolders (Zip, Rar) If you add a folder to an archive, also
add any subfolders inside. Affects zip and rar archives
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3.3 Extraction Settings

Many of these options are only configurable for specific archive formats. Other
formats may behave either way and are not configurable.

Overwrite files (Zip, Tar, Zoo, Rar) Overwrite any files that have matching names
on disk with the one from the archive.

Preserve permissions (Tar) Save the user, group, and permission settings on
files. Use with care, as this may result in files being extracted that do not
belong to any valid user on your computer.

Ignore folder names (Zip) Extract all the files into the extraction folder, ignor-
ing any folder structure in the archive.

Convert filenames to lowercase (Zip, Rar), Convert filenames to uppercase (Rar)
Extract all files with all lowercase (or uppercase) names.

3.4 Folders

Folders This shows the Folders dialog box, so you can choose the default fold-
ers. You can configure a Common folder that will be used for all options,
use the last used folder, or a custom folder.
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Chapter 4

Command Reference

4.1 The File Menu

File — New (Ctrl+N) Creates a new archive

File — Open (Ctrl+O) Opens an archive

File — Open Recent Shows a list of recent archives to choose from
File — New Window Opens a new Ark window

File — Reload (F5) Loads the current archive again from disk. This will re-
fresh Ark’s view if another program has made changes to the archive.

File — Save As Allows you to save the current archive under a new file name

File — Close (Ctrl+W) Closes the current archive
File — Quit (Ctrl+Q) Closes Ark

4.2 The Edit Menu

Edit — Select... Lets you select files according to their filename. For example,
you could use *.txt to select all text files. Note that you can’t use more
than one filter at a time.

Edit — Select All (Ctrl+A) Selects all the files in the archive
Edit — Deselect All Unselects all the files in the archive

Edit — Invert Selection Reverses which files are selected. Selected files be-
come unselected, and unselected files are selected.

Edit — View Shell Output Displays the Shell Output box, which shows you
the output of the most recent command(s) run by Ark. This is sometimes
useful if you are having problems and want to troubleshoot.
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4.3 The Action Menu

Action — Add File... Shows the Select Files to Add dialog box, where you can
select files. Hold down Ctrl and click to select multiple files. To go up a
folder, right click the folder box, and you can choose Up (this will proba-
bly be improved soon). The Advanced tab has options which are specific
to the type or archive you are working with.

Action — Add Folder... Shows the Add Folder... dialog box, where you can
choose a folder to add. Just choose a folder and choose Open.

Action — Delete Removes the currently selected files from the archive.

Action — Extract Shows the Extract dialog box, which allows you to select
where you will extract files to. You can also select which files to extract:

o Current extracts the most recently selected file. If multiple files are
selected, only the most recently selected one will be extracted.

o All extracts the entire contents of the archive.

o Selected Files extracts all the files which have been selected.

o Pattern allows you to specify which files will be extracted, correspond-
ing to certain patterns, e.g. *.txt or *. jpg Note that you can only use
one pattern at a time.

You can specify the folder to extract files to in the Extract to: text box.
The default location is the folder the archive is in. You may also choose
to have the folder that you extract into open in Konqueror once the ex-
traction is complete.

Action — View Opens the currently selected file in the associated viewer pro-
gram.

Action — Open With... Opens the currently selected file in a program you choose.
The Open With... dialog box lets you choose which program to use.

Action — Edit With... Opens the currently selected file in a program you choose.
Any changes you make in the editor program will be reflected in the
archive, as it will be updated.

4.4 The Settings Menu

Settings — Show/Hide Toolbar Toggles whether the toolbar is displayed.
Settings — Show/Hide Statusbar Toggles whether the status bar is displayed.
Settings — Show/Hide Search Bar Toggles whether the search bar is displayed.
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Settings — Configure Shortcuts... Displays the Configure Shortcuts dialog box.
This lets you choose shortcut keys for various menu items. To change a
shortcut, select an action from the list, and then choose which keystroke
to use. Clicking on the bottom right hand Key button lets you choose
which specific key to use. Just press the new key.

Settings — Configure Toolbars... Displays a KDE standard dialog where you
can configure the toolbar icons.

Settings — Configure Ark... This opens the Ark configuration dialog. The di-
alog contains four modules (General, Addition, Extraction and Folders).
Configuring Ark is covered in the section Configuration

4.5 The Help Menu

Help — Ark Handbook (F1) Invokes the KDE Help system starting at the
Ark help pages. (this document).

Help — What's This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within Ark will open a help
window (if one exists for the particular item) explaining the item’s func-
tion.

Help — Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help — About Ark This will display version and author information.

Help — About KDE This displays the KDE version and other basic informa-
tion.
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Chapter 5

Credits and License

Ark is Copyright (c) 1997-2004, The Various Ark Developers
AUTHORS:

e Helio Chissini de Castro helio@conectiva.com.br
Georg Robbers Georg.Robbers@urz.uni-hd.de

Henrique Pinto henrique.pinto@kdemail .net

Roberto Selbach Teixeira maragato@kde.org

Robert Palmbos palm9744@kettering.edu
e Francois-Xavier Duranceau duranceau@kde.org

e Corel Corporation (author: Emily Ezust) emilye@corel.com

Documentation Copyright (c) 2000 Matt Johnston mattj@flashmail.com
Documentation updated for KDE 3.3 by Henrique Pinto henrique.pinto@kdemail.net.

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.

This program is licensed under the terms of the GNU General Public License.
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Appendix A

Installation

A.1 How to obtain Ark

Ark is part of the KDE project http:/ /www.kde.org/ .

Ark can be found in the kdeutils package on ftp:/ /ftp.kde.org/pub/kde/ , the
main FTP site of the KDE project.

A.2 Requirements

In order to successfully use Ark, you need KDE 3.3. GNU Tar v1.12 and a
recent gzip are also needed if you want Ark to handle tar archives. To handle
other file formats, you need the appropriate command line programs, such as
zip, unzip, ar, rar and lha.

A.3 Compilation and Installation

In order to compile and install Ark on your system, type the following in the
base directory of the Ark distribution:

% ./configure
% make
% make install

Since Ark uses autoconf and automake you should have no trouble compiling
it. Should you run into problems please report them to the KDE mailing lists.
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