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Abstract

KView is an image viewing program. It is small and fast and has some simple
image processing commands. You can work with many different graphic file
formats and convert your images to them. KView is not a fully-fledged image
processor but it is sufficient for many of your everyday tasks.
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Chapter 1

Introduction

KView is an image viewer for the KDE desktop. You can view graphics of
many different formats such as PostScript R©, TIFF etc. By saving your files
in a different format than the original you can easily convert images to other
graphics formats. In addition, KView provides some nice little features for do-
ing simple image processing, like stretching/shrinking, rotation and applying
effects. You can arrange your images in a little slideshow.
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Chapter 2

Menu Reference

When you start KView you see the typical application layout: a workspace con-
taining your documents (images in this case), a menubar that provides access
to the various commands, a toolbar with shortcut buttons for some of them
and a status bar at the bottom to display status messages. When you have the
loaded an image into KView, there is also an additional context menu available
which is displayed by clicking your right mouse button over the image. Below,
all menu entries are explained in the order that they appear in the menubar.

2.1 The File Menu

File→Open... (Ctrl+O) Opens a new image in KView. The size of the KView
main window and the image after loading are determined by your set-
tings. If you open several images, only the last one is shown, but all of
them can be accessed using the image list.

File→Open Recent Displays a list of recently opened images. Selecting one
from this list reopens the image.

File→ Save (Ctrl+S) Save the current image.

File→ Save As Saves the image under a different name. By choosing a new
file format you can convert the image to a different graphics type.

File→ Print... (Ctrl+P) Prints the image. In the standard KDE print dialog
click the Options » button, go to the tab Image Settings. Select Fit image
to page size or Center image on page.

File→ Close (Ctrl-W) Closes the currently displayed image.

File→Quit (Ctrl+Q) Quits KView. If you have several KView images open,
all of them are closed.
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2.2 The Edit Menu

Edit→ Copy (Ctrl+C) Copies the entire image or the selection to the clip-
board.

Edit→ Paste (Ctrl+V) Paste the contents of the clipboard as a new image (only
available, if the clipboard contains a valid image).

Edit→ Crop (C) If you have selected any part of the image (by drawing a box
around it using your mouse) you can cut off all the rest around it by using
this option. Your image is effectively reduced to your selection.

Edit→ Reload (F5) Reloads the image to its original state (right after opening
it).

Edit→Delete (Shift+Delete) Deletes the image.

Edit→ Flip→Vertical (V) Flips the image along the vertical. Mathematically,
this does a reflection along the image’s horizontal center line.

Edit→ Flip→Horizontal (H) Flips the image along the horizontal. Mathe-
matically, this does a reflection along the image’s vertical center line.

Edit→ Rotate Counter-Clockwise Rotates the image by 90◦ in the counter-
clockwise direction.

Edit→ Rotate Clockwise Rotates the image by 90◦ in the clockwise direction.

2.3 The Effects Menu

KView provides some functions for simple image processing:

This menu item is only displayed in the menubar, if you choose the application
plugin effects in KViews configure dialog

Effects→Gamma Correction... Adjusts the gamma factor.

Effects→ Blend Color... Blends the image to selected color and opacity

Effects→ Change Intensity (Brightness)... Changes the brightness of the im-
age. Enter the new brightness in percent (with respect to the initial value).

2.4 The View Menu

View→ Zoom In (Ctrl++) Enlarges the image by ten percent. Notice that this
refers to the current size of the picture.

View→ Zoom... Opens a list to choose the zoom factor. This value is given in
percent and always refers to the initial size of the picture.
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View→ Zoom Out (Ctrl+-) Reduces the image size by ten percent. Again this
refers to the current size of the image.

View→ Fit Image to Window Maximizes the image size. The image is scaled
to the window size, keeping the aspect ratio.

2.5 The Go Menu

This item is only displayed in the menubar, if you choose the application plugin
presenter in KViews configure dialog

Go→ Image List... Displays a list of the currently loaded images. You can
flip through the images by either double-clicking on them or using the
Previous and Next buttons. Shuffle rearranges the images in a random
order. Pressing Start Slideshow will start the slideshow with the current
settings for the interval. In addition, you can save and load your image
list using the corresponding buttons. Slideshow interval: Here you can
change the interval between the different slides for the slideshow.

Go→ Start/Stop Slideshow (S) Starts or stops the slideshow.

Go→ Previous Image in List (Alt+Left Arrow) Switches to the previous im-
age in the list.

Go→Next Image in List (Alt+Right Arrow) Switches to the next item in the
list.

2.6 The Tools Menu

Tools→ Scan Image... Opens images from your scanner into KView. This menu
item is only displayed in the menubar, if you choose the application plu-
gin scanner in KViews configure dialog

Tools→ Back (Shift+Left Arrow) Switches to the previous image in the cur-
rent folder.

Tools→ Forward (Shift+Right Arrow) Switches to the next image in the cur-
rent folder.

2.7 The Settings Menu

This menu provides options for configuring KView, changing its appearance,
shortcuts and standard behavior.

Settings→ Show/Hide Menubar (Ctrl+M) Toggles the menubar on/off.
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Settings→ Toolbars→Main Toolbar (KView), Settings→ Toolbars→ Extra Toolbar (KView)
Toggles the main toolbar and the extra toolbar on and off respectively

Settings→ Show/Hide Statusbar Toggles the status bar on/off.

Settings→ Show/Hide Scrollbars Toggles the Scrollbars on/off.

Settings→ Fullscreen Mode (Ctrl+Shift+F) This option maximizes the KView
window and the currently shown image so you can have a closer look at
it. Even the window decorations (titlebar etc.) are temporarily removed.
Selecting this option once again switches back to normal mode.

Settings→ Configure Shortcuts... Opens a dialog for changing the key bind-
ings. Using this option you can change the standard key shortcut for
KView’s commands or create new ones.

Settings→ Configure Toolbars... Opens a dialog for configuring the toolbar.
You can add and remove toolbuttons for KView’s commands with this
option.

Settings→ Configure KView... Opens a dialog for changing some options as
described in the section chapter 4

2.8 The Help Menu

Help→KView Handbook (F1) Invokes the KDE Help system starting at the
KView help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within KView will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→About KView This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.
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Chapter 3

Command Line Options

KView can be started directly from a terminal like Konsole or xterm. Several
command line options are available.

kview --help Lists the command line options (see below).

kview --help-qt Shows the options specific to QtTM (the GUI library that
KDE is based on).

kview --help-kde Shows the KDE-specific options.

kview --help-all Displays all command line options.

kview --author You want to send your warm wishes and euphoric cheers
to someone? Here they are!

kview -v, --version Displays the version number of KView (and that of
QtTM/KDE).

kview --license Shows under which licenses KView is being published.
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Chapter 4

KView Options

4.1 Viewer

This is the configuration for the part of KView that can be reused by other
applications (meaning that the settings will also affect the KView part that gets
embedded into Konqueror or other applications).

GENERAL CONFIGURATION OPTIONS FOR KVIEWCANVAS
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Use smooth scaling (high quality but slower) As the option suggests, use a
very high quality but relatively slow method of scaling images.

Keep aspect ratio If this is checked KView will always try to keep the aspect
ratio. That means if the width is scaled with a factor x, the height is scaled
with the same factor.

Center image If checked, the opened image will be displayed centered to the
KView window.

Background Color Opens a normal KDE color picker dialog, where you can
choose the background color for the image

Minimum width: The width of the image shown will not get smaller than the
size you enter here. A value of 10 would cause a 1x1 image to be stretched
horizontally by a factor of 10.

Maximum width: The width of the image shown will not get bigger than the
size you enter here. A value of 100 would cause a 1000x1000 image to be
compressed horizontally by a factor of 0.1.

Minimum height: The height of the image shown will not get smaller than
the size you enter here. A value of 10 would cause a 1x1 image to be
stretched vertically by a factor of 10.

Maximum height: The height of the image shown will not get bigger than the
size you enter here. A value of 100 would cause a 1000x1000 image to be
compressed vertically by a factor of 0.1.

Choose which blend effects should be used: Every effect selected may be used
to create a transition effect between the images. If you select multiple ef-
fects they will be chosen randomly.

CHOOOSE AND CONFIGURE YOUR PLUGINS

Browser Here you can enable/disable use of the browser KView plugin, which
enables you to browse through all the images in the current folder.

4.2 Application

Here you can set options that are special for the KView application when run-
ning stand-alone. What you change in here will not affect other applications.
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APPLICATION

Resizing This option determines if the window and/or the image will be re-
sized after loading a new picture into KView. With Only resize window
enabled, the KView window will be resized so that it snuggly fits around
the loaded image. Notice that this can reduce the main window almost to
a vertical arrangement of menu entries if you load a small button pixmap
(you can resize the window afterwards in the usual way, of course). If
your image is pretty large (in terms of pixels), sometimes the KView win-
dow is resized in such a way that the caption bar completely moves off
your screen. Similarly, Resize image to fit window resizes the image to
fit into the KView workspace (keeping its aspect ratio intact). And with
Don’t resize anything as your choice, both KView and your image keep
their size. With Best fit KView will resize the window to fit the image.
The image will never be scaled up but if it is too large for the screen the
image will be scaled down.

PLUGINS

Effects Provides some image effects (and adds an Effects to the menubar to
give you access to them).

Presenter Creates an image list and enables you to create a slideshow.

Scanner Adds Scan Image... to the Tools menu to open images from your scan-
ner into KView.
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Chapter 5

Credits and License

KView
Program copyright 1997-2001 Sirtaj S. Kang taj@kde.org

KParts integration by Simon Hausmann shaus@neuro2.med.uni-magdeburg.de

Maintainer: Matthias Kretz kretz@kde.org

Documentation copyright 2001 Hauke Hildebrandt hauke.hildebrandt@iup.uni-
heidelberg.de

Documentation substantially updated by Burkhard Lück lueck@hube-lueck.de
in 2005 for KDE 3.5
This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Installation

A.1 How to obtain KView

KView is part of the KDE project http://www.kde.org/ .

KView can be found in the kdegraphics package on ftp://ftp.kde.org/pub/-
kde/ , the main FTP site of the KDE project.

In order to compile and install KView on your system, type the following in
the base directory of the KView distribution:

% ./configure
% make
% make install

Since KView uses autoconf and automake you should have no trouble compil-
ing it. Should you run into problems please report them to the KDE mailing
lists.

A.2 Requirements

Since KView is part of the KDE desktop you need a working KDE installation
to use it. However, some additional libraries are needed by KView to use the
various graphics file formats. For example, to handle the PNG format KView
needs the corresponding library libpng. KView uses the libraries that are reg-
istered by kdelibs/kimgio.
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