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Abstract

KPDF is a KDE PDF viewer based on xpdf code.
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Chapter 1

Introduction

KPDF is a KDE PDF (Portable Document Format) viewer based on the code
of the xpdf application. Although being based on xpdf code, KPDF has some
unique features such as continuous mode and presentation support.

The PDF format is widely used for publishing documents that are mostly not
meant to be edited again. KPDF is only a viewer for these files and therefore it
doesn’t provide any functionality to edit or create PDF documents.
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Chapter 2

Using KPDF

2.1 Opening Files

To view a PDF file in KPDF, select File→ Open... , choose a PDF or PS file in
the dialogue and click Open. Your file should now be displayed in the main
window.
If you have already opened files in KPDF before, you can quickly access them
by selecting them in the File→Open Recent menu.

After having a file opened you probably want to read it and therefore navigate
through it. Click Next to learn more about this.

2.2 Navigating

This section describes how you can navigate through a document in KPDF.

There are multiple ways of scrolling the viewing area. One is to use the Up Ar-
row and Down Arrow keys. You may also use the scrollbar, your mousewheel
or the Page Up and Page Down keys.

Another way is to hold the left mouse button down at any place on the docu-
ment while dragging the mouse in the opposite direction of where you want
to move. This procedure only works if the Browse Tool is enabled, which you
can select by choosing Tools→ Browse Tool .

The navigation panel on the left side of the screen enables two more ways of
navigating through a document:

• If you click on a page thumbnail the viewing area will be brought to that
page.
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• If the document has a table of contents, clicking on a table of contents item
will bring the document to to the page linked to that item.

Some documents have links. In this case you can click on them and the view
will change to the page it links to. If the link is to a web page the default
browser will be invoked.
Additionally, you may use the following functionality to quickly move to spe-
cific places in the document:

• You can go to the first page of the document using Ctrl+Home or using Go
→ First Page.

• You can go to the last page of the document using Ctrl+End or using Go
→ Last Page.

• You can go to the next page of the document using Space, the Next Page
Toolbar button or using Go→Next Page.

• You can go to the previous page of the document using Backspace, the Pre-
vious Page Toolbar button or using Go→ Previous Page.

2.3 Presentation Mode

The Presentation mode represents another way to view PDF documents in
KPDF. It can be enabled in View→ Presentation. It shows the document on
a page per page basis. The pages are shown with zoom to page, that means all
the page is visible.

NOTE
PDF documents can even specify that they are always opened in presentation
mode.

To navigate between pages you may use the left mouse button (next page) and
the right mouse button (previous page), the mouse wheel, the arrow icons that
appear as soon as you move the mouse cursor to the top of the screen, or the
keys specified in the Navigating section.

You can exit presentation mode at any time by pressing the ESC key or clicking
the Quit icon appearing if you move the mouse cursor to the top of the screen.

Presentation mode has some configuration options, you can find their descrip-
tion at Configuring KPDF.
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Chapter 3

The Menubar

3.1 The File Menu

File→Open... (Ctrl+O) Open a PDF or PS file. If there is already an opened
file it will be closed. For more information, see the section about Opening
Files.

File→Open Recent Open a file which was used previously from a submenu.
If a file is currently being displayed it will be closed. For more informa-
tion, see the section about Opening Files.

File→ Save As... Save the currently open file under a different name.

File→ Print... (Ctrl+P) Print the currently displayed document.

File→ Print Preview... Show a preview of how the currently displayed doc-
ument would be printed with the default options.

File→ Properties Display some basic information about the document, such
as title, author, creation date, and details about the fonts used.

File→Quit (Ctrl+Q) Close KPDF.

3.2 The Edit Menu

Edit→ Find... (Ctrl+F) Open a dialogue that allows you to search for a string
in the document.

Edit→ Find Next (F3) Try to find the previous searched string again in the
document.
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3.3 The View Menu

View→ Presentation (Ctrl+Shift+P) Activates the Presentation Mode. For
more information, see the section about Presentation Mode.

View→ Zoom In (Ctrl++) Increase the magnification of the document view.

View→ Zoom Out (Ctrl+-) Decrease the magnification of the document view.

View→ Fit to Page Width Change the magnification of the document view
to a value that makes the pages’ width equal to the document view’s
width.

View→ Fit to Page Change the magnification of the document view to a value
that makes at least one whole page visible.

View→ Continuous Enable the continuous page mode. In continuous mode,
all pages of the document are shown, and you can scroll through them
without having to use the Go→ Previous Page and Go→Next Page op-
tions.

View→ Two Pages Enable the two page mode, which shows two pages of
the document next to each other..

3.4 The Go Menu

Go→ Previous Page (Backspace) View the previous page of the document.

Go→Next Page (Space) View the next page of the document.

Go→ First Page (Ctrl+Home) Go to the first page of the document.

Go→ Last Page (Ctrl+End) Go to the last page of the document.

Go→ Back (Alt+Left) Go back to the previous view of the document.

Go→ Forward (Alt+Right) Move forward to the next view of the document.
This only works if you have already moved back before.

Go→Go to Page (Ctrl+G) Open a dialog which allows you to go to any page
of the document.

3.5 The Tools Menu

Tools→ Browse Tool The mouse will have its normal behaviour, left mouse
button for dragging the document and following links and right mouse
button for adding bookmarks and fit to width.
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Tools→ Zoom Tool The mouse will work as a zoom tool. Clicking left mouse
button and dragging will zoom the view to the selected area, clicking
right mouse button will bring the document back to the previous zoom.

Tools→ Select Tool The mouse will work as a select tool. In that mode click-
ing left mouse button and dragging will give the option of copying the
text/image of current the selected area to the clipboard, speak a text or to
save an image to a file.

3.6 The Settings Menu

Settings→ Show/Hide Menubar (Ctrl+M) Toggle the Menubar display on
and off. Once hidden it can be made visible using the right mouse button
menu.

Settings→ Show/Hide Toolbar Toggle the Toolbar display on and off.

Settings→ Show/Hide Navigation Panel (Ctrl+L) Toggle the navigation panel
on and off.

Settings→ Full Screen Mode (Ctrl+Shift+F) Enables the full screen mode.
Note that full screen mode is different from presentation mode insofar
as the only peculiarity of full screen mode is that it hides the window
decorations, the menubar and the toolbar.

Settings→ Configure Shortcuts... Opens a window that lets you configure
the keyboard shortcuts for many menu commands.

Settings→ Configure Toolbars... Opens a window that lets you choose which
icons are visible in the toolbar.

Settings→ Configure KPDF... Opens the Configure window.

3.7 The Help Menu

Help→KPDF Handbook (F1) Invokes the KDE Help system starting at the
KPDF help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within KPDF will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→About KPDF This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.
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Chapter 4

Configuring KPDF

4.1 Overview

You can configure KPDF by choosing Settings→ Configure KPDF.... The con-
figuration dialogue is split into four sections. This chapter describes the avail-
able options in detail.

• General

• Accessibility

• Performance

• Presentation

7



The KPDF Handbook

4.2 General

Show search bar in thumbnails list Whether to the show a search bar in the
thumbnails view or not. That search bar is useful for filtering pages that
contain a given string.

Link thumbnails list with the page Whether the thumbnails view should al-
ways display the current page or not.

Show scrollbars Whether to show scrollbars for the document view.

Show hints and info messages Whether to show some informative messages
on startup, file load, etc.

Obey DRM limitations Whether KPDF should obey DRM (Digital Rights Man-
agement) restrictions. DRM limitations are used to make it impossible to
perform certain actions with PDF documents, such as copying content to
the clipboard. Note that in some configurations of KPDF, this option is
not available.

Watch file Whether opened files should be automatically checked for changes
and updated, if necessary.
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4.3 Accessibility

Draw border around images Whether to draw a border around images.

Draw border around links Whether to draw a border around links.

Change colors Enables the color changing options.

Invert colors Inverts colors on the view, i.e. black objects will be shown white.

Change paper color Changes the paper’s color, i.e. the document’s background.

Change dark and light colors Changes the dark and light color to your pref-
erence, that means black will not be rendered as black but as the selected
dark color and white will not be rendered as white but as the selected
light color.

Convert to black and white Converts the document to black and white. You
can set the threshold and the contrast. Setting the threshold to a higher
value will result in darker grays used.

4.4 Performance

Enable transparency effects Draw selections and other special graphics using
transparency effects. Disable the option to draw them using outline or
opaque fill styles and increase speed on selections.

Enable background generation Use a background thread to generate the pages.
By disabling this option the user interface will become less reactive (will
be blocked if necessary), but pages will be displayed a bit faster.

Memory usage profiles KPDF can achieve best performance by tuning the mem-
ory usage, based on your system and your tastes. The more memory
you let it to use, the faster the program will behave. The Default profile
is good for every system, but you can prevent KPDF from using more
memory than necessary by selecting the Low profile, or let it get the most
out of your system using Aggressive.

4.5 Presentation

Advance every Enables automatic advancing of pages given a time period.

Loop after last page When navigating on presentation mode and going past
the last page the first page will appear.

Background color The color that will fill the part of the screen not covered by
the page when on presentation mode.
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Default transition The transition effect between page and page if the docu-
ment does not specify one. Set this to Random Transition to make KPDF
randomly choose one of the available effects.

Mouse cursor Whether the mouse should be always hidden, always shown or
hidden after a small time of inactivity.

Show progress indicator Whether to show a progress circle that shows the
current page and the total number of pages on the upper right corner
of the presentation screen everytime you change the page.

Show summary page Whether to show a summary page at the beginning of
the presentation with the title, author and number of pages of the docu-
ment.
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Chapter 5

Credits and License

PROGRAM COPYRIGHT:

• Albert Astals Cidtsdgeos@yahoo.es Current maintainer

• Christophe Devrieseoelewapperke@ulyssis.org

• Wilco Greven greven@kde.org Original author

• Enrico Roseros.kde@email.it Refactoring for 3.4

• Laurent Montelmontel@kde.org

DOCUMENTATION COPYRIGHT:

• Albert Astals Cidtsdgeos@yahoo.es Author

• Titus Laskatitus.laska@gmx.de Some updates and additions

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Installation

A.1 How to obtain KPDF

KPDF is part of the KDE project http://www.kde.org/ .

KPDF can be found in the kdegraphics package on ftp://ftp.kde.org/pub/-
kde/ , the main FTP site of the KDE project.

A.2 Compilation and Installation

NOTE
If you are reading this help in the KHelpCenter, KPDF has already been installed
on this system and you do not need install it anymore.

In order to compile and install KPDF on your system, type the following in the
base directory of the KPDF distribution:

% ./configure
% make
% make install

Since KPDF uses autoconf and automake you should have no trouble compil-
ing it. Should you run into problems please report them to the KDE mailing
lists.
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