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Abstract

KMines is the KDE version of the classic minesweeper game.
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Chapter 1

Introduction

KMines is the classic Minesweeper game. You must uncover all the empty
squares without blowing up a mine.

When you uncover a square, a number appears: it indicates how many mines
surround this square. If there is no number the neighboring squares are au-
tomatically uncovered. When you find a square that you are sure contains a
mine, it is very useful to put a flag on it (by right-clicking).
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Chapter 2

How to Play

You have to use the mouse and its three buttons to uncover or to flag the
squares (with two-buttoned mice, clicking the middle button is generally achieved
by simultaneously pressing the left and the right buttons). Here are the details:

• The left button will uncover a square. If there is a bomb below that square,
the bomb will explode, and the game will be over.
If there is not a bomb under the square, a number will appear. That is the
number of neighboring squares that contain bombs. ‘Which ones?’ you ask:
That’s the point of the game.
For each square (excluding edge and corner squares), there are 8 neighboring
squares.
If none of the neighboring squares has a bomb, then a blank will be shown
under the square, and all neighboring squares will be automatically uncov-
ered.

NOTE
Left clicking a flagged square is safe and does nothing.

• The right button will mark a square as containing a mine (by drawing a red
flag on it) or, if the option is set, as being uncertain (by drawing a question
mark on it). The uncertain tag can be useful when you are puzzled about the
positions of mines.

• The middle button will clear the surrounding squares if the right number
of squares is already flagged. It is very useful since it is much quicker than
uncovering all individual squares.

WARNING
If your flags are not properly positioned, you will explode a bomb.
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• Pressing the yellow smiley will start a new game.

NOTE
These are the default settings. The mouse buttons can be reprogrammed. For
more information, see the section entitled Game Options.
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2.1 The KMines Screen

The KMines screen consists of:

• A Box showing you the number of mines still left to be marked. Every time
you flag a bomb site, this number will decrease by one.
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NOTE
This box does not determine if you are right or wrong, but only how many mines
you need to theoretically mark before you are done with this game.

In this example, there are 40 mines to be marked.

• A Yellow Smiley Face. Clicking this will start a new game. If you lose the
game, it will become a frown.

• The box on the right shows how much time this round has taken. The short-
est time for each level is listed as the high score.

• The playing area. This will vary in size depending on the difficulty level of
the game. In this example, it consists of 256 squares. This is where you play
the game.
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Chapter 3

Game Options

The options to KMines are set by selecting Settings→ Configure KMines from
the menubar. This will bring up a dialog box.

6



The KMines Handbook

This dialog box is divided into three sections.

Game The first option, labeled Enable ? mark, determines whether you can
mark squares as ‘questionable’. If this option is checked, then right click-
ing the mouse will first cause a square to be flagged. If you right click
again on the same square, the flag will change to a ?, to indicate you
don’t know if there is a bomb there or not. If you click again, the square
will change back to blank.
If there is not a mark in front of this option, the first right mouse click
will change the square to a red flag. The second will make it blank again,
thus skipping the ? symbol.
The next option down, labeled Enable keyboard, determines if the key-
board shortcuts will work while playing the game. The default keyboard
shortcuts are given in Section 4.6, and can be changed by selecting Set-
tings→ Configure Shortcuts....
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NOTE
The only keyboard shortcuts affected are those responsible for playing the
game. Keyboard commands such as New Game and Quit, still work, regard-
less of this option.

The Pause if windows loses focus option will automatically pause the
game if the KMines window loses focus. When the game is paused, the
gameboard disappears, so you cannot use pausing the game as a way to
cheat!
The "Magic" reveal option switches on ‘Magic reveal’ mode. In this mode,
KMines does most of the gameplay for you: If you have uncovered enough
squares to be able to tell with certainty that a square contains a mine,
KMines will automatically mark it as a mine, and perform an autoreveal
on squares for which it has marked the correct number of mines. Note
that when you have this mode switched on, your scores do not count as
highscores.
The last section of this tab allows you to change the action of each of the
three mouse buttons. Your options are:

Reveal This will reveal the contents of the square. If there is no bomb,
then a number will appear. If there is a bomb under that square,
then the bomb will explode, and the game will be over.

Autoreveal Clicking on a square with this button will automatically re-
veal all neighboring squares that are not marked with red flags. If
one of those neighboring squares has a bomb under it, the bomb will
explode, and the game will be over.

Toggle Flag Clicking with this button on a square will cycle through
blank, red flag, and question mark.

Toggle ? Flag Clicking with this button on a square will mark/unmark
with a question mark.

Appearance The top three color buttons determine the Flag Color, Explosion
Color and Error Color.
The rest of this page is concerned with mines colors. To adjust, simply
click the color button beside each description, and select the new color.

Custom Game Finally, if you are not finding the existing configurations chal-
lenging enough, you can set up a custom game here. Use the sliders to
change the Width, Height, and the percentage of the board covered with
Mines. The default game has 15 percent of the board covered, so there is
plenty of room to make the game harder.

Saving your changes Once your changes are complete, click OK to make them
permanent.
If you want to abandon your changes, click Cancel to abort the changes.
If you click on Defaults, the default settings will be restored. Click OK to
make these default changes permanent, or edit the settings some more.
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Chapter 4

Commands/Keyboard
Shortcuts

The following sections briefly describe each menubar option.

4.1 Game Menu

The Game menu consists of 4 options.

Game→New (Ctrl+N) Starts a new game.

Game→ Pause (P) Pauses or resumes the game. This will hide the board (no
cheating), and give you a button to press when you want to continue this
game.

Game→ Show Highscores (Ctrl+H) This shows you the high score (the short-
est time) for each difficulty level.

Game→Quit (Ctrl+Q) Quits KMines

4.2 Move Menu

Move→Hint (H) If you use this item, you will get a hint about where you
should click next. If you do that your score will not be added to the high-
scores.

Move→ Solve This item tries to solve the current game.

Move→ Solving Rate... This item shows a dialog that calculates the solving
rate for the current game type.
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Move→View Log This item shows a dialog with the log of the last game.

Move→ Replay Log This item replays the current log.

Move→ Save Log... This item shows a dialog to save the current log.

Move→ Load Log... This item shows a dialog to load a log.

4.3 View Menu

View→ Zoom In (Ctrl++) Increase the size of the gameplay canvas.

View→ Zoom Out (Ctrl+-) Decrease the size of the gameplay canvas.

4.4 Settings Menu

Settings→ Show Menubar If there is a check in front of this option, then the
menubar will be visible. Selecting this option, hides the menubar.

NOTE
To restore a hidden menubar, click outside the game play area, with the right
mouse button. This will bring up a small sub-menu. Simply select Show
Menubar from this sub-menu, and the menubar will be visible again.

Settings→ Choose Game Type Lets you set the difficulty level from a sub-
menu.
There are three default levels of difficulty: Easy (64 squares, 10 mines),
Normal (256 squares, 40 mines), and Expert (480 squares, 99 mines). There
is also a Custom... level settings.
If you select Custom..., then the settings you have configured in the Con-
figure KMines dialog will be used.

Settings→ Configure Shortcuts... This item lets you change the keyboard short-
cuts used by KMines.

Settings→ Configure Notifications... This item displays a standard KDE no-
tifications configuration dialog, where you can change the notifications
(sounds, visible messages, etc.) used by KMines.

Settings→ Configure Highscores... On the Main tab you can change your Nick-
name and add a cute Comment about yourself, to show in the high score
table. You can also activate the World-wide highscores enabled checkbox,
and share your skill at KMines across the world with an online high-
score server. If you are connected to the Internet, KMines will send your
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score automatically at the end of the game to the highscore web server
(kmines.sf.net).
The Advanced tab displays your Registration Data on kmines.sf.net: Your
Nickname: from the Main tab and the Key:. This key was generated when
you registered on kmines.sf.net by selecting World-wide highscores en-
abled the first time. The registration key is used in conjunction with the
nickname to identify uniquely users, but users cannot have the same
nickname. Click on the Remove button to delete you from the world
highscores list.

Settings→ Configure KMines... Allows you to adjust game options. For more
detailed information, see the section entitled Game Options.

4.5 Help Menu

Help→KMines Handbook (F1) Invokes the KDE Help system starting at
the KMines help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within KMines will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→About KMines This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.

4.6 Default Keyboard Shortcuts

The following table shows you the default keyboard shortcuts.

These shortcuts can be changed by selecting Settings→ Configure Shortcuts...
from the menubar.
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Key Combo Action
Arrows Move cursor in playing area.
PageDown Move to bottom edge
PageUp Move to top edge
Home Move to left edge
End Move to right edge
Space Reveal square.
W Mark square as mine

Return
Automatically reveal all
surrounding squares not marked
by a flag.

Ctrl+N New Game
P Pause Game
Ctrl+Q Quit KMines
F1 KMines Handbook
Shift+F1 What’s This Help
Ctrl+H Show Highscores
Ctrl+M Show Menubar
Ctrl++ Zoom In
Ctrl+- Zoom Out

Table 4.2: Keyboard Shortcuts
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Chapter 5

Credits and License

KMines
Program copyright 1996-2000 Nicolas Hadacek hadacek@kde.org

Documentation copyright 2000 Nicolas Hadacek hadacek@kde.org

Documentation updated for KDE 2.0 by Mike McBride mpmcbride7@yahoo.com

Some changes for KDE 3.2 by Philip Rodrigues phil@kde.org

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Installation

A.1 How to obtain KMines

KMines is part of the KDE project http://www.kde.org/ .

KMines can be found in the kdegames package on ftp://ftp.kde.org/pub/-
kde/ , the main FTP site of the KDE project.

A.2 Compilation and Installation

In order to compile and install KMines on your system, type the following in
the base directory of the KMines distribution:

% ./configure
% make
% make install

Since KMines uses autoconf and automake you should have no trouble com-
piling it. Should you run into problems please report them to the KDE mailing
lists.
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