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Abstract

KLatin is a KDE application to help revise/teach Latin.
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Chapter 1

Introduction

KLatin is a program to help revise Latin. There are three ‘sections’ in which
different aspects of the language can be revised. These are the vocabulary,
grammar, and verb testing sections. In addition there is a set of revision notes
that can be used for self-guided revision.

In the vocabulary section an XML file is loaded containing various words and
their local language translations. KLatin asks you what each of these words
translate into. The questions take place in a multiple-choice environment.

In the grammar and verb sections KLatin asks for a particular part of a noun
or a verb, such as the ‘ablative singular’, or the ‘1st person indicative passive
plural’, and is not multiple choice.
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Chapter 2

Using KLatin

When you start KLatin, you are greeted by four options that you can choose
from.

The first one, Vocabulary, is a multiple-choice vocabulary tester.
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After you finish your test, a results screen is displayed.

The second, Grammar tests you on grammatical parts of nouns.
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Verbs is almost the same as the Grammar section, except that it tests you on
verb forms.

The fourth section, Revision notes, loads Konqueror into the KLatin revision
notes section.
In addition to the options, you can also launch these sections via the menubar,
in the Section.
The configuration dialog for KLatin can be accessed by choosing Settings→
Configure KLatin... from the menu. In the Vocabulary page, you can set whether
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you want the test to take place from your language into Latin, or vice versa.
You can also choose the default file which you want to use to test your vo-
cabulary on, and you can also set how many questions you want to be tested
on.
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Chapter 3

The KLatin Main Window

The KLatin main window consists of four option buttons to choose which sec-
tion to enter, and a menubar.

Choose from the Revision Sections list a section and click Start to start the cho-
sen section.
When you are finished with that section, click Back to return to KLatin’s main
menu.
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Chapter 4

Command Reference

4.1 The File Menu

File→Quit (Ctrl+Q) Quits KLatin

4.2 The Section Menu

Section→ Load Vocabulary Loads the vocabulary section

Section→ Load Grammar Loads the grammar section

Section→ Load Verbs Loads the verbs section

Section→ Load Revision Loads the revision section

4.3 The Settings Menu

Settings→ Configure Shortcuts... Configure the keyboard keys you use to ac-
cess the different actions.

Settings→ Configure Toolbars... Not implemented yet.

Settings→ Configure KLatin... Display the KLatin settings dialog
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4.4 The Help Menu

Help→KLatin Handbook (F1) Invokes the KDE Help system starting at the
KLatin help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within KLatin will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→About KLatin This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.
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Chapter 5

Translation Guide to KLatin

Only the vocabulary files have to be translated in your language. The vocabu-
lary files use the KVTML format, which is the same as other programs such as
KWordQuiz use. KWordQuiz is very useful as you can create the vocabulary
files in that and load them directly into KLatin.

Below is explained how you can translate KLatin vocabulary files. At the mo-
ment, the files are only in English, German and Polish.

5.1 How To Translate KLatin vocabulary files

1. Get the latest KLatin code from CVS or a latest release. The words are
stored in source_dir_of_kdeedu/klatin/klatin/data/vocab/en/ in files
like A.kvtml for Latin words beginning with A, BC.kvtml for Latin words
beginning with B and C and so on.

2. Create a new subdirectory in data/vocab/ named as your language code
(for example, fr for French, ja for Japanese). Copy all the English vo-
cabulary files there as well as the Makefile.am. Edit the Makefile.am and
replace ‘en’ with your language code.

3. In data/vocab/your_language_code, edit all the files and translate the
English words, i.e. those that are between the <t> and </t> tags.

4. Please send them to George gwright@users.sourceforge.net.
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Chapter 6

Developer’s Guide to KLatin

6.1 Create new vocabulary files

The KLatin vocabulary database system is very easy to extend. Just look at the
files and you’ll understand! It uses the KVTML format, which is the same as
other programs such as KWordQuiz use. So you can open KWordQuiz and use
it to create the vocabulary files.

You can save your new files in the corresponding folder depending on what
language they refer to in .kde/share/apps/klatin/data/vocab/language_c-
ode/. For example, English KVTML files are kept in a folder called en, German
files in de, and so on. You can also send me your files so I can add them in the
next KLatin release.
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Chapter 7

Credits and License

KLatin
Program copyright 2001-2004 George Wright gwright@users.sourceforge.net

Contributors:

• Neil Stevens neil@qualityassistant.com

• Anne-Marie Mahfouf annma@kde.org

• Mark Westcott mark@houseoffish.org

Documentation copyright 2001-2004 George Wright gwright@users.sourceforge.net

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Chapter 8

KLatin notes

Welcome to the KLatin notes section. This is aimed to help you in your revision
and covers the English GCSE syllabus (England).

Here are the different sections you can get help for:

• Latin numbers

• Latin verbs

• Latin nouns

• Latin adjectives

• Latin pronouns

8.1 KLatin Notes - Numbers

The Romans had a particular set of numerals and had names for each of their
numbers. In this section are listed some numbers and their corresponding sym-
bol.

8.2 KLatin Notes - Verbs

All languages have verbs. Latin verbs are divided into four categories, called
conjugations. These conjugations are divisions of verbs that, generally, use the
same stem formation and have the same endings.

The stem of a verb is the basic part of the verb that does not change. For exam-
ple, the stem of moneo is mone. To get the stem of the verb, take the first person
singular of the verb, and take off the -o ending. The verb ‘sum’ (I am) is totally
irregular, and does not have a consistent stem.
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1 I unus
2 II duo
3 III tres
4 IV quattuor
5 V quinque
6 VI sex
7 VII septem
8 VIII octo
9 IX novem
10 X decem
11 XI undecim
12 XII duodecim
13 XIII tredecim
14 XIV quattuordecim
15 XV quindecim
16 XVI sedecim
17 XVII septendecim
18 XVIII duodeviginti
19 XIX undeviginti
20 XX viginti
21 XXI vigintiunus
22 XXII vigintiduo
30 XXX triginta
40 XL quadraginta
50 L quinquaginta
60 LX sexaginta
70 LXX septuaginta
80 LXXX octoginta
90 XC nonaginta
100 C centum
200 CC ducenti
300 CCC trecenti
400 CD quadrigenti
500 D quingenti
600 DC sescenti
700 DCC septigenti
800 DCCC octigenti
900 CM nongenti
1000 M mille
2000 MM duo milia

Table 8.2: Numbers
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TENSE 1st 2nd 3rd 4th SUM - I

PRESEN-
T am-o mone-o reg-o audi-o sum

ama-s mone-s regi-s audi-s es
I love, am
loving ama-t mone-t regi-t audi-t est

ama-mus mone-m-
us regi-mus audi-mus sumus

ama-tis mone-tis regi-tis audi-tis estis
ama-nt mone-nt regu-nt audi-unt sunt

FUTURE ama-bo mone-bo reg-am audi-am ero
ama-bis mone-bis reg-es audi-es eris

I will
love ama-bit mone-bit reg-et audi-et erit

ama-bim-
us

mone-bi-
mus reg-emus audi-em-

us erimus

ama-bitis mone-bit-
is reg-etis audi-etis eritis

ama-bunt mone-bu-
nt reg-ent audi-ent erunt

IMPERF-
ECT ama-bam mone-ba-

m rege-bam audi-bam eram

ama-bas mone-bas rege-bas audi-bas eras
I was
loving ama-bat mone-bat rege-bat audi-bat erat

I used to
love

ama-ba-
mus

mone-ba-
mus

rege-ba-
mus

audi-ba-
mus eramus

I began
to love ama-batis mone-ba-

tis rege-batis audi-bati-
s eratis

ama-bant mone-ba-
nt rege-bant audi-bant erant

PERFEC-
T amav-i monu-i rex-i audiv-i fu-i

amav-isti monu-isti rex-isti audiv-isti fu-isti
I have
loved amav-it monu-it rex-it audiv-it fu-it

amav-im-
us

monu-i-
mus rex-imus audiv-i-

mus fu-imus

amav-ist-
is

monu-ist-
is rex-istis audiv-ist-

is fu-istis

amav-er-
unt

monu-er-
unt rex-erunt audiv-er-

unt fu-erunt

FUTURE
PERFEC-
T

amav-ero monu-er-
o rex-ero audiv-ero fu-ero

amav-eri-
s

monu-er-
is rex-eris audiv-er-

is fu-eris

I will
have
loved

amav-erit monu-er-
it rex-erit audiv-er-

it fu-erit

amav-eri-
mus

monu-er-
imus

rex-erim-
us

audiv-er-
imus fu-erimus

amav-eri-
tis

monu-er-
itis rex-eritis audiv-er-

itis fu-eritis

amav-eri-
nt

monu-er-
int rex-erint audiv-er-

int fu-erint

PLUPER-
FECT

amav-er-
am

monu-er-
am rex-eram audiv-er-

am fu-eram

amav-er-
as

monu-er-
as rex-eras audiv-er-

as fu-eras

I had
loved

amav-er-
at

monu-er-
at rex-erat audiv-er-

at fu-erat

amav-er-
amus

monu-er-
amus

rex-eram-
us

audiv-er-
amus

fu-eram-
us

amav-er-
atis

monu-er-
atis rex-eratis audiv-er-

atis fu-eratis

amav-er-
ant

monu-er-
ant rex-erant audiv-er-

ant fu-erant

Table 8.4: Verb listings - Indicative Active
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TENSE 1st 2nd 3rd 4th SUM - I

PRESEN-
T ame-m monea-m rega-m audi-o sim

ame-s monea-s rega-s audi-s sis
ame-t monea-t rega-t audi-t sit

ame-mus monea--
mus rega-mus audi-mus simus

ame-tis monea-ti-
s rega-tis audi-tis sitis

ame-nt monea-nt rega-nt audi-unt sint

IMPERF-
ECT ama-rem mone-re-

m rege-rem audi-rem essem

ama-res mone-res rege-res audi-res esset
ama-ret mone-ret rege-ret audi-ret esset
ama-rem-
us

mone-re-
mus

rege-rem-
us

audi-re-
mus essemus

ama-retis mone-re-
tis rege-retis audi-retis essetis

ama-rent mone-re-
nt rege-rent audi-rent essent

PERFEC-
T

amav-eri-
m

monu-er-
im rex-erim audiv-er-

im fu-erim

amav-eri-
s

monu-er-
is rex-eris audiv-er-

is fu-eris

amav-erit monu-er-
it rex-erit audiv-er-

it fu-erit

amav-eri-
mus

monu-er-
imus

rex-erim-
us

audiv-er-
imus fu-erimus

amav-eri-
tis

monu-er-
itis rex-eritis audiv-er-

itis fu-eritis

amav-eri-
nt

monu-er-
int rex-erint audiv-er-

int fu-erint

PLUPER-
FECT

amav-iss-
em

monu-is-
sem rex-issem audiv-is-

sem fu-issem

amav-iss-
es

monu-is-
ses rex-isses audiv-is-

ses fu-isses

amav-iss-
et

monu-is-
set rex-isset audiv-is-

set fu-isset

amav-iss-
emus

monu-is-
semus

rex-isse-
mus

audiv-is-
semus

fu-issem-
us

amav-iss-
etis

monu-is-
setis

rex-isseti-
s

audiv-is-
setis fu-issetis

amav-iss-
ent

monu-is-
sent rex-issent audiv-is-

sent fu-issent

Table 8.6: Verb listings - Subjunctive Active
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TENSE 1st 2nd 3rd 4th SUM - I

PRESEN-
T am-a mon-e reg-e aud-i es

am-ate mon-ete reg-ite aud-ite este

FUTURE am-ato mon-eto reg-ito aud-ito esto
am-ato mon-eto reg-ito aud-ito esto

am-atote mon-eto-
te reg-itote aud-itote estote

am-anto mon-ento reg-unto aud-iunt-
o sunto

Table 8.8: Verb listings - Imperative Active

1st 2nd 3rd 4th

Accusative (ad)
am-andum

(ad) mon-e-
ndum

(ad)
reg-endum

(ad) aud-ie-
ndum

Genitive am-andi mon-endi reg-endi aud-iendi
Dative am-ando mon-endo reg-endo aud-iendo
Ablative am-ando mon-endo reg-endo aud-iendo

Table 8.10: Verb listings - Gerund Active

TENSE 1st 2nd 3rd 4th SUM - I

PRESEN-
T am-are mon-ere reg-ere aud-ire esse

PERFEC-
T

amav-iss-
e

monu-is-
se rex-isse audiv-is-

se fu-isse

Table 8.12: Verb listings - Infinitive Active

16



The KLatin Handbook

TENSE 1st 2nd 3rd 4th SUM - I

PRESEN-
T

am-ans,--
antis

mon-ens-
,-entis

reg-ens,--
entis

aud-iens-
,-ientis

FUTURE amat-ur-
us,-a,-um

monit-ur-
us,-a,-um

rect-urus-
,-a,-um

audit-ur-
us,-a,-um

futurus,--
a,-um

Table 8.14: Verb listings - Participle Active

8.3 KLatin Notes - Nouns

Nouns, like verbs, are divided into groups, called declensions. There are five
declensions and three genders: masculine, feminine, and neuter.

The stem of a noun is the basic part of the noun that does not change. To get the
stem of a noun, take the genitive singular of the noun, and take off its ending.
For example: the stem of puella is puell; while the stem of rex is reg, because its
genitive is reg-is.

8.3.1 Latin Nouns

8.4 KLatin Notes - Adjectives

Adjectives are words to describe nouns, and so they agree with the nouns.
Agreeing means that they match the noun they refer to in three ways: gender,
number, and case.

8.5 KLatin Notes - Pronouns

Here are some pronouns.
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TENSE 1st 2nd 3rd 4th

PRESENT am-or mone-or reg-or audi-or
ama-ris mone-ris reg-eris audi-eris

I am loved ama-tur mone-tur regi-tur audi-tur
ama-mur mone-mur regi-mur audi-mur
ama-mini mone-mini regi-mini audi-mini
ama-ntur mone-ntur regu-ntur audiu-unt

FUTURE ama-bor mone-bor reg-ar audi-ar
ama-beris mone-beris reg-eris audi-eris

I will be
loved ama-bitur mone-bitur reg-etur audi-etur

ama-bimur mone-bim-
ur reg-emur audi-emur

ama-bimini mone-bimi-
ni reg-emini audi-emini

ama-buntur mone-bunt-
ur reg-entur audi-entur

IMPERFEC-
T ama-bar mone-bar rege-bar audie-bar

ama-baris mone-baris rege-baris audie-baris
I was loved ama-batur mone-batur rege-batur audie-batur

ama-bamur mone-bam-
ur rege-bamur audie-bam-

ur

ama-bamini mone-bami-
ni rege-bamini audie-bami-

ni

ama-bantur mone-bant-
ur rege-bantur audie-bant-

ur

PERFECT amatus sum monitus
sum rectus sum auditus

sum
amatus es monitus es rectus es auditus es

I have been
loved amatus est monitus est rectus est auditus est

amati
sumus

moniti
sumus recti sumus auditi

sumus
amati estis moniti estis recti estis auditi estis
amati sunt moniti sunt recti sunt auditi sunt

FUTURE
PERFECT amatus ero monitus ero rectus ero auditus ero

amatus eris monitus
eris rectus eris auditus eris

I will have
been loved amatus erit monitus erit rectus erit auditus erit

amati
erimus

moniti
erimus recti erimus auditi

erimus
amati eritis moniti eritis recti eritis auditi eritis

amati erunt moniti
erunt recti erunt auditi erunt

PLUPERFE-
CT

amatus
eram

monitus
eram rectus eram auditus

eram

amatus eras monitus
eras rectus eras auditus eras

I had been
loved amatus erat monitus

erat rectus erat auditus erat

amati
eramus

moniti
eramus recti eramus auditi

eramus

amati eratis moniti
eratis recti eratis auditi eratis

amati erant moniti erant recti erant auditi erant

Table 8.16: Verb listings - Indicative Passive
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1st 2nd 3rd 4th

am-andus,-a,-u-
m

mon-endus,-a,--
um

reg-endus,-a,-u-
m

aud-iendus,-a,--
um

Table 8.18: Verb listings - Gerundive Passive

TENSE 1st 2nd 3rd 4th

PRESENT am-ari mon-eri reg-i aud-iri

PERFECT
amat-um,-a-
m,-um
esse

monit-um,--
am,-um
esse

rect-um,-a-
m,-um
esse

audit-um,--
am,-um
esse

amat-os,-as-
,-a
esse

monit-os,-a-
s,-a
esse

rect-os,-as,--
a
esse

audit-os,-a-
s,-a
esse

FUTURE amat-um iri monit-um
iri rect-um iri audit-um iri

Table 8.20: Verb listings - Infinitive Passive
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SIN-
GUL-
AR

1st
Fem-
inine

2nd
Mas-
culi-
ne

2nd
Neu-
ter

3rd
Mas-
c/Fe-
m

3rd
Neu-
ter

4th
Mas-
culi-
ne

4th
Neu-
ter

5th
Fem-
inine

No-
min-
ative

puel-
l-a

serv-
us

bell--
um rex opus grad-

us genu res

Voc-
ative

puel-
l-a

serv-
e

bell--
um rex opus grad-

us genu res

Acc-
usati-
ve

puel-
l-am

serv-
um

bell--
um

reg--
em opus grad-

um genu re-m

Geni-
tive

puel-
l-ae

serv-
i bell-i reg-is oper-

is
grad-
us

gen--
u re-i

Dati-
ve

puel-
l-ae

serv-
o bell-o reg-i oper-

i
grad-
ui

gen--
u re-i

Abla-
tive

puel-
l-a

serv-
o bell-o reg-e oper-

e
grad-
u

gen--
u re

PLU-
RAL
No-
min-
ative

puel-
l-ae

serv-
i bell-a reg--

es
oper-
a

grad-
us

gen--
ua res

Voc-
ative

puel-
l-ae

serv-
i bell-a reg--

es
oper-
a

grad-
us

gen--
ua res

Acc-
usati-
ve

puel-
l-as

serv-
os bell-a reg--

es
oper-
a

grad-
us

gen--
ua res

Geni-
tive

puel-
l-aru-
m

serv-
orum

bell--
orum

reg--
um

oper-
um

grad-
uum

gen--
uum

re-r-
um

Dati-
ve

puel-
l-is

serv-
is

bell--
is

reg-i-
bus

oper-
ibus

grad-
ibus

gen--
ibus

re-b-
us

Abla-
tive

puel-
l-is

serv-
is

bell--
is

reg-i-
bus

oper-
ibus

grad-
ibus

gen--
ibus

re-b-
us

Table 8.22: Noun listings
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SINGULAR Like Servus Like Puella Like Bellum

Nominative bon-us bon-a bon-um
Vocative bon-e bon-a bon-um
Accusative bon-um bon-am bon-um
Genitive bon-i bon-ae bon-i
Dative bon-o bon-ae bon-o
Ablative bon-o bon-a bon-o

PLURAL
Nominative bon-i bon-ae bon-a
Vocative bon-i bon-ae bon-a
Accusative bon-os bon-as bon-a
Genitive bon-orum bon-arum bon-orum
Dative bon-is bon-is bon-is
Ablative bon-is bon-is bon-is

Table 8.24: 1st and 2nd Declension Adjectives (212)

SINGULAR Like Rex Like Rex Like Opus

Nominative trist-is trist-is trist-e
Vocative trist-is trist-is trist-e
Accusative trist-em trist-em trist-e
Genitive trist-i trist-i trist-is
Dative trist-is trist-is trist-i
Ablative trist-i trist-i trist-i

PLURAL
Nominative trist-es trist-es trist-ia
Vocative trist-es trist-es trist-ia
Accusative trist-es trist-es trist-ia
Genitive trist-ium trist-ium trist-ium
Dative trist-ibus trist-ibus trist-ibus
Ablative trist-ibus trist-ibus trist-ibus

Table 8.26: 3rd Declension Adjectives (333)
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Positive Comparative Superlative Notes

Normal form of
Adjective Stem + ior,-ius Stem +

issimus,-a,-um

Stem +
rimus,-a,-um

For adjectives
which end with
-er. For
example: acer--
rimus,-a,-um

Stem +
limus,-a,-um

For adjectives
which end with
-ilis. For
example: facil-l-
imus,-a,-um

Per/Prae +
Adjective

Table 8.28: Comparison of Adjectives

Me You
ego tu
me te
mei tui
mihi tibi
me te

We You (Pl)
nos vos
nos vos
nostri/nostrum vestri/vestrum
nobis vobis
nobis vobis

Table 8.30: Personal Pronouns
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He, She, It
SINGULAR is ea id

eum eum id
eius eius eius
ei ei ei
eo ea eo

PLURAL ei eae ea
eos eas ea
eorum earum eorum
eis eis eis
eis eis eis

Table 8.32: 3rd Person Personal Pronouns

This
SINGULAR hic haec hoc

hunc hanc hoc
huius huius huius
huic huic huic
hoc hac hoc

PLURAL hi hae haec
hos has heac
horum harum horum
his his his
his his his

That
SINGULAR ille illa illud

illum illam illud
illius illius illius
illi illi illi
illo illa illo

PLURAL illi illae illa
illos illas illa
illorum illarum illorum
illis illis illis
illis illis illis

Table 8.34: Demonstrative Pronouns
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Noone Nothing
nemo nihil
neminem nihil/nil
nullius/neminis nullius rei
nemini/nulli nulli rei
nullo/nemine nulla re

Table 8.36: Negative Pronouns
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Appendix A

Installation

A.1 How to obtain KLatin

KLatin is part of the KDE project http://www.kde.org/ .

KLatin can be found in the kdeedu package on ftp://ftp.kde.org/pub/kde/ ,
the main FTP site of the KDE project.

A.2 Compilation and Installation

In order to compile and install KLatin on your system, type the following in
the base directory of the KLatin distribution:

% ./configure
% make
% make install

Since KLatin uses autoconf and automake you should have no trouble com-
piling it. Should you run into problems please report them to the KDE mailing
lists.
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