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Abstract

KDE is a powerful graphical desktop environment for UNIX R© workstations.
A KDE desktop combines ease of use, contemporary functionality and out-
standing graphical design with the technological superiority of the UNIX R©
operating system.
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Chapter 1

Welcome to KDE

2002-01-18 3.00.00
The KDE team welcomes you to user-friendly UNIX R© computing.

1.1 Welcome to the K Desktop Environment

1.1.1 Information about KDE

KDE is a powerful graphical desktop environment for UNIX R© workstations.
A KDE desktop combines ease of use, contemporary functionality and out-
standing graphical design with the technological superiority of the UNIX R©
operating system.

What is the K Desktop Environment?

Contacting the KDE Project

Supporting the KDE Project

Useful links

1.1.2 Getting the most out of KDE

1.1.2.1 General documentation

A Quick Start Guide to the Desktop

KDE User’s guide

Frequently asked questions
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1.1.2.2 Basic applications

Desktop Panel

Control Center
File Manager
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Chapter 2

KDE Help System User
Manual

2002-02-03 0.08.00

2.1 KDE Help System

The KDE help system is designed to make accessing the common UNIX R©
help systems (man and info) simple, as well as the native KDE documentation
(XML).

All base KDE applications come fully documented, thanks to the efforts of the
Documentation team. If you would like to help, please write to the Documenta-
tion coordinator, Lauri Watts, at lauri@kde.org for information. No experience
is required, just enthusiasm and patience.

If you would like to help translating KDE documentation to your native lan-
guage, the Translation coordinator is Thomas Diehl, thd@kde.org, and he would
also welcome the help. More information, including the coordinators for each
language team, can be found on the Internationalization web site, and in the
Contact section of this document.

2.1.1 Installation

KHelpCenter is an integral part of the KDE Base installation, and is installed
with every copy of KDE. It can be found in the kdebase package, and is avail-
able from the ftp://ftp.kde.org/pub/kde/ , or will be found in your operating
system kdebase package.
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2.2 Invoking Help

KHelpCenter can be called in several ways:

From the Help menu The most common will probably be from within an ap-
plication. Choose Help→Contents to open that application’s help file, at
the contents page.

From the K menu Choose the big K in your panel, and select Help to open
KHelpCenter, starting at the default welcome page.

From the panel By default, the Kicker panel contains an icon to call KHelp-
Center. Again, the default welcome page is displayed.

From the command line KHelpCenter may be started using a URL to display
a file. URLs have been added for info and man pages also. You can use
them as follows:

An application help file khelpcenter help:/kedit
Opens the KEdit help file, at the contents page.

A local URL khelpcenter file:/ usr/local/src/qt/html/index.ht-
ml

A Man page khelpcenter man:/strcpy
An Info page khelpcenter info:/gcc

Invoking khelpcenter with no parameters opens the default welcome
page.

2.3 The KHelpCenter interface

The KHelpCenter interface consists of two panes of information.

The toolbar and menus are explained further in Section 2.3.4.

Documents contain their own navigation tools, enabling you to move either
sequentially through a document, using Next, Previous, and Home links, or to
move around in a less structured manner, using hyperlinks.

Links can take you to other parts of the same document, or to a different doc-
ument, and you can use the Back (Left pointing arrow) or Forward (Right
pointing arrow) icons on the toolbar to move through the documents you have
viewed in this session.
The two panes display the contents of the help system, and the help files them-
selves, on the left and right respectively.
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2.3.1 The Contents pane

The Contents pane in KHelpCenter is displayed on the left hand side of the
window. As you might expect, you can move the splitter bar, to make sure you
can comfortably read the contents of either pane.

The Contents pane is further divided into two tabs, one containing a menu
showing all the help information KHelpCenter is aware of, and the other con-
tains the KDE glossary of terms.

2.3.1.1 The Contents Menu

The Contents contains the following default entries:

Introduction Welcome to KDE - an introduction to the K Desktop Environ-
ment.

Introduction to KDE The KDE Quickstart guide. Contains a tour of the KDE
Interface and specific help and tips on how to work smarter with KDE.

KDE User’s manual The KDE User’s manual is an in-depth exploration of
KDE, including installation, configuration and customization, and use.

Application manuals Native KDE application documentation. All KDE ap-
plications have documentation in XML format, which are converted to
HTML when you view them. This section lists all the KDE applications
with a brief description and a link to the full application documentation.
The applications are displayed in a tree structure that echoes the default
structure of the K menu, making it easy to find the application you are
looking for.

UNIX R©manual pages UNIX R© man pages are the traditional on-line docu-
mentation format for UNIX R© systems. Most programs on your system
will have a man page. In addition, man pages exist for programming
functions and file formats.

Browse info pages TeXinfo documentation is used by many GNU applications,
including gcc (the C/C++ compiler), emacs, and many others.

Tutorials Short, task based or informational tutorials.

The KDE FAQ Frequently asked questions about KDE, and their answers.

KDE on the web Links to KDE on the web, both the official KDE website, and
other useful sites.

Contact Information Information on how to contact KDE developers, and how
to join the KDE mailing lists.

Supporting KDE How to help, and how to get involved.
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2.3.2 The Man and Info sections

Man pages are the standard UNIX R© manual pages, and have been in use for
many years on many operating systems. They are extremely thorough, and
are the very best place to get information about most UNIX R© commands and
applications. When people say ‘RTFM’, the Manual they are referring to is very
often the man page.

The man pages are not perfect. They tend to be in depth, but also extremely
technical, often written by developers, and for developers. In some cases this
makes them somewhat unfriendly, if not downright impossible for many users
to understand. They are, however, the best source of solid information on most
command line applications, and very often the only source.

If you’ve ever wondered what the number is when people write things like
man(1) it means which section of the manual the item is in. You will see KHelp-
Center uses the numbers to divide the very many man pages into their own
sections, making it easier for you to find the information you’re looking for, if
you’re just browsing.

Also available are the Info pages, intended to be a replacement for the man
pages. The maintainer of some applications no longer update the man pages,
so if there is both a man page and an info page available, the info page is prob-
ably the most recent. Most applications have one or the other though. If the
application you are looking for help on is a GNU utility, you will most likely
find it has an info page, not a man page.

2.3.2.1 Navigating inside the Info pages

Info documents are arranged hierarchically with each page called a node. All
info documents have a Top node, i.e. the opening page. You can return to the
Top of an info document by pressing Top.

Prev & Next are used to move to the previous/next page at the current level of
the hierarchy.

Clicking on a menu item within a document moves you to a lower level in the
hierarchy. You may move up the hierarchy by pressing Up.

Man is treated similarly to info, with the section index being the Top node and
each man page on the level below. Man entries are one page long.

2.3.3 The KDE glossary

The glossary provides a quick reference point, where you can look up the defi-
nitions of words that may be unfamiliar to you. These range from KDE specific
applications and technologies, through to general UNIX R© computing terms.

In the left hand pane you will see a tree view, with two choices: Alphabetically
or By topic. Both contain the same entries, sorted differently, to allow you to
quickly find the item of interest.
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Navigate down the tree views to the left, and items you select will be displayed
on the right.

2.3.4 The menus and toolbar

KHelpCenter has a very minimal interface, allowing you to concentrate on get-
ting help rather than learning how to use the help browser.

The icons available to you in the toolbar are as follows:

TOOLBAR ICONS

Back Go to the previous page you viewed.

Forward Go forward one page. This icon is only active if you have already
used the Back icon.

Print Print the contents of the currently visible page.

Find Find a word or words within the currently visible page.

Increase Font Increase the size of the text in the viewer pane.

Decrease Font Decrease the size of the text in the viewer pane. This icon is
only enabled if you have previously enlarged the text.

The menus contain the following entries:

File
File→ Print... Print the contents of the currently visible page.
File→Quit (Ctrl+Q) Close and exit KHelpCenter

Edit
Edit→ Select All (Ctrl+A) Select all the text in the current page.
Edit→ Find... (Ctrl+F) Find a word or words in the currently visible

page.

View
View→View Document Source View the HTML source of the page you

are currently viewing.
View→ Set Encoding Change the encoding of the current page. Nor-

mally, the default setting of Auto should be sufficient, but if you
are having problems viewing pages written in languages other than
English, you may need to choose a specific encoding in this menu.

Go→ Back Go back to the previous page you were viewing.

Go→ Forward If you have previously moved back with the back icon or menu
entry, you can work your way forward again with this menu entry.

Go→ ... At the bottom of the Go menu, you will find a history list, of the last
few pages you have looked at. Selecting one will take you directly back
to that page.
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2.4 Credits and Licenses

KHelpCenter

Originally developed by Matthias Elter elter@kde.org

The current maintainer is Cornelius Schumacher schumacher@kde.org

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Chapter 3

What is KDE?

2002-01-18 3.00.00

3.1 What is KDE?

KDE is a desktop environment. In other words, KDE is a collection of pro-
grams, technologies and documentation that attempt to make life easier for
computer users. KDE is targeted at UNIX R© workstations. It features network
transparency and a contemporary work philosophy.

The creators of the K Desktop Environment are a world-wide group of soft-
ware engineers. This group’s major goal in free software development is to
provide high quality software that empowers the user with easy control of his
computer’s resources.

KDE seeks to fill the need for an easy to use desktop for UNIX R©workstations,
similar to the desktop environments found under Mac R© OS or Windows R©
95/NT. KDE meets the requirement of users for an easy to use work environ-
ment. Tools used to reach this end are: enhanced inter-application commu-
nication, component reuse, generalized drag and drop, uniform look and feel
and many more. Thus, KDE offers much more than the traditional UNIX R©
window managers.

Stability, scaleability and openness are qualities which have made UNIX R© the
undisputed choice for the information technology professional for many years.
KDE builds on top of this excellent base framework and brings new, much
needed qualities: usability, user friendliness and beauty! KDE was the first,
and stays the forefront player in bringing these qualities to UNIX R©, which
constituted for years, the premier platform for server computers and scientific
institutions, but wasn’t very attractive for desktop users.

Without UNIX R© the Internet would not exist, or at least would have a vastly
different form. UNIX R© has not, until now, addressed the needs of the average

9



The KHelpCenter

computer user. This fact is particularly unfortunate, since a number of imple-
mentations of UNIX R© (Linux, FreeBSD, NetBSD, etc.) are freely available on
the Internet, all of which are of exceptional quality and stability.

3.2 KDE The Desktop Environment

In combination with a free implementation of UNIX R©, KDE provides to the
world an open and completely free desktop computing platform either at home
or at work.
This platform is available to anyone free of charge including its source code for
anyone to modify.

While there will always be room for improvement we believe we have now de-
livered a viable alternative to some of the more commonly found and commer-
cial operating systems/desktops combinations available today. It is our hope
that the combination of UNIX R© and KDE will finally bring the same open, re-
liable, stable, and monopoly free computing to the average computer user that
scientists and computing professionals world-wide have enjoyed for years.

3.3 KDE The Application Development Framework

KDE focuses on the user’s needs, but it’s obvious that this focus is more eas-
ily achieved by also giving developers the best tools. KDE code contains, and
comes with, some of the best development technologies of the modern com-
puting age.

Authoring applications under UNIX R©/X11 used to be an extremely tedious
and labor intensive process. KDE recognizes the fact that a computing platform
is only as good as the number of first class applications available to the users
of that particular platform.

KDE defines new technologies in DCOP and KParts, created to offer a com-
ponent document model and technology. Together with the complete KDE
libraries programming interface, DCOP/KParts are set in direct competition
with other similar technologies like Microsoft R©MFC/COM/ActiveX technolo-
gies. The excellent quality and the high level of refinement of KDE’s applica-
tion programming interface (API) enables developers to focus on original and
interesting issues and avoid reinventing the wheel.

3.4 KDE The Office Application Suite

In its current form, KDE provides, apart from the essential desktop component
applications, a suite of powerful office programs known to the world by the
name KOffice.
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KOffice is based on the KDE DCOP/KParts technologies. It currently contains:
a word processor with desktop publishing capabilities (KWord), a spreadsheet
application (KSpread) and accompanying charting program (KChart), a pre-
sentation program (KPresenter) and a vector drawing program (Kontour). Ty-
ing things together is the KOffice Workspace, an integrated shell to ease the use
of the KOffice components in conjunction with each other. Additional compo-
nents include an email client, a news reader, and a powerful PIM (Personal
Information Manager - an organizer).

While some of those components are still in alpha development, others are
already extremely powerful. For example, KPresenter, KDE’s presentation ap-
plication, was successfully used at the 5th International Linux R© Congress in
Cologne, Germany to deliver a KDE presentation.

We would like to invite you to learn more about KDE and KOffice.
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Chapter 4

Contact the KDE team

2002-10-29 3.5.5

4.1 Mailing lists

KDE has several mailing lists up. See below for some of the most useful. Older
articles can be found in the mailing list archive.

kde For general discussion, users helping each other.

kde-announce Announcements of new KDE applications

kde-devel For developers.

kde-artists Creating icons and other artwork

kde-doc-english For people interested in writing documentation for KDE.

kde-i18n-doc Internationalization and documentation issues

http://l10n.kde.org/teams/ For localized information, which may include user
email lists and websites, check the translation teams page at the above
URL.

4.2 Contacting the KDE developers

On this page, you can find links to KDE related web sites.

The K Desktop Environment is developed by a large group of people around
the world. Our main communication channel is the Internet. For general ques-
tions, you will be best served by asking on the mailing lists mentioned in the
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previous section, and contact addresses for individual developers can be found
in the documentation of their individual application.

Please visit our Official Representatives page for official enquiries regarding
KDE (e.g. interviews).

More information about KDE is available at http://www.kde.org/ .

Other KDE websites include:

www.kde.org KDE’s official website

developer.kde.org The KDE developers center

websvn.kde.org A web interface to the KDE Subversion repository

l10n.kde.org KDE’s internationalization and documentation server

ftp.kde.org The main KDE FTP server. Please have a look at the link below to
find a mirror site in your geographic region.

www.kde.org/mirrors KDE web and FTP mirror sites

www.kde-apps.org A directory of KDE applications.

www.kde-look.org KDE themes, icons, and other items to change the look of
your desktop.
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Chapter 5

Supporting KDE

2002-03-04 2.02.00

5.1 Supporting KDE

If you are new to KDE, the KDE project might look like big machinery to you.
Undoubtedly, KDE is no longer a small project, nevertheless it is very impor-
tant to realize that it is easy to ‘make a difference’ in the KDE world.

There is always a need for dedicated developers, graphic artists, sound engi-
neers, translators and documentation writers. Consider jumping aboard this
exciting international project and make yourself a name in the software world.

Along the way you will make countless friends and acquaintances all over the
world. Also, the satisfaction that stems from doing actual hands-on work, that
will benefit an uncountable number of users world-wide, and from seeing an
unparalleled project grow, is hard to beat. Please consider joining and sup-
porting KDE and hop aboard this exciting journey towards a free and open
alternative computing platform.

5.2 How to get started

• Subscribe to the KDE mailing lists that interest you.

• Read the mailing list archives in order to get a feel for KDE development.

• Learn how to program using the KDE application framework and join the
friendly KDE developers’ community.
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5.3 Supporting financially

The KDE team is working very hard on providing you with the best desktop
available for the UNIX R© operating system. KDE is available for free and will
always be available for free, including each and every line of its source code, for
everyone to modify and distribute. If you enjoy and use KDE please consider
supporting the KDE Project financially. KDE is in constant need of funds in
order to finance its operations.

If your busy schedule or skills do not permit you to be actively involved in
KDE development, please consider supporting KDE financially by sending a
donation to:
You can send regular US checks to the following address:

K Desktop Environment e.V.
Mirko Boehm
2029 Chadds Ford Drive
Reston, VA 20191
USA

Use "KDE e.V. - Mirko Boehm" in the "Pay to the order of..." line.

From Europe, you may remit your donation to (be aware of a fee if wiring from
outside of Germany):

K Desktop Environment e.V.
Account-Nr. 0 66 64 46
BLZ 200 700 24
Deutsche Bank 24

Please contact Mirko Boehm kde-ev-treasurer@kde.org if you have any ques-
tions.
Your contribution is very much appreciated. Thank you!
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