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Abstract

This is the handbook for the plugins for Kate, KDE’s Advanced Text Editor.
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Chapter 1

Kate plugins

Kate plugins are additional functions for the Kate editor. They can add extra
menus and shortcuts, and extend Kate’s features. You can install as many or as
few as you like, from within Kate. Open Kate’s configuration dialog with Set-
tings→ Configure Kate.... Select Application→ Plugins to choose the wanted
plugins.

More information on using Kate and enabling the plugins you want is available
in the Kate handbook.
The plugins installed in this handbook are:

• XML Completion

• XML Validation

• Insert Command

• HTML Tools

• Open Header

• Text Filter

• File Templates
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Chapter 2

Introduction

XML Completion Daniel Naber 2006-05-17 3.5.2
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Abstract

This plugin supports writing XML files by listing allowed tags and more.
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This plugin gives hints about what is allowed at a certain position in an XML
file, according to the file’s DTD. It will list possible elements, attributes, at-
tribute values or entities, depending on the cursor position (e.g. all entities are
listed if the character on the left of the cursor is ‘&’). It’s also possible to close
the nearest open tag on the left.

The DTD must exist in XML format, as produced by the Perl program dtdparse.
We will call a DTD in this format ‘meta DTD’. Some meta DTDs are supplied.
They are installed in $KDEDIR/share/apps/katexmltools/, which is also the
default folder when you choose Assign Meta DTD.... To produce your own
meta DTDs, get dtdparse from http://dtdparse.sourceforge.net.

2.1 How to Use

Start Kate and open the configuration dialog under Settings→Configure Kate....
Then select Kate XML Completion which will appear in the Application/Plug-
ins section and close the dialog. After that, select XML→Assign Meta DTD....
If your document contains no ‘DOCTYPE’ or the doctype is unknown, you’ll
have to select a meta DTD from the file system. Otherwise the meta DTD that
matches the current document’s DOCTYPE will be loaded automatically.

You can now use the plugin while typing your text:

< (less than key) This will trigger a list of possible elements unless the cursor
is inside a tag already. Note that you currently cannot use this to insert
the top level element (e.g. ‘<html>’).

" (quote key) The quote key will trigger a list of possible attribute values (if
there are some) if you are inside a tag.

(space key) This key will trigger a list of possible attributes for the current
element if you are inside a tag.

& (ampersand key) This key will trigger a list of named entities.

2.2 Features and Limitations

You can test all functions and limitations by loading $KDEDIR/share/apps/ka-
texmltools/testcases.xml into Kate and following the instructions. Note that
working with more than one view per document is not yet correctly supported
by this plugin.

2.3 Menu Structure
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XML→ Insert Element... (Ctrl+Return) This will open a dialog that lets you
insert an XML element. The <, > characters and the closing tag will be
inserted automatically. If you have selected text when this menu item
is selected, the selected text will be surrounded by the opening and the
closing tag. The dialog also offers completion of all elements that may be
inserted at the current cursor position if you have assigned a meta DTD
by using Assign Meta DTD....

XML→ Close Element (Ctrl+<) This will search your text for a tag that is not
yet closed and will close it by inserting the corresponding closing tag.
The search starts at the cursor position and goes left. If it cannot find an
open tag nothing will happen.

XML→Assign Meta DTD... This will tell the plugin which meta DTD to use
for the current document. Note that this assignment will not be saved.
You will have to repeat it when you start Kate the next time.

2.4 Thanks and Acknowledgments

Kate Plugin ‘XML Completion’ copyright 2001,2002 Daniel Naber daniel.naber@t-
online.de.
Documentation copyright 2001,2002 Daniel Naber

This program is licensed under the terms of the GNU General Public License.
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Introduction

XML Validation Daniel Naber 2006-05-17 3.5.2
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Abstract

This plugin checks XML files for well-formedness and validity.
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This plugin checks the current file. A list of warnings and errors will appears
at the bottom of Kate’s main window. You can click on an error message to
jump to the corresponding place in the file. If the file has a ‘DOCTYPE’ the
DTD given with this doctype will be used to check the file for validity. The
DTD is expected at a position relative to the current file, e.g. if the doctype
refers to ‘DTD/xhtml1-transitional.dtd’ and the file is /home/peter/test.xml
the DTD is expected to be located at /home/peter/DTD/xhtml1-transitional-
.dtd. However, remote DTDs specified via http are supported.

If the file has no doctype it will be checked for well-formedness.

To learn more about XML check out the official W3C XML pages.

Internally this plugin calls the external command xmllint, which is part of
libxml2. If this command is not correctly installed on your system, the plu-
gin will not work.

NOTE
A temporary file needs to be written to the same folder as the file that should be
checked, so you need to have write access to that folder.

To load this plugin open Kates configuration dialog under Settings→Configure
Kate.... Then select Kate XML Validation which will appear in the Applica-
tion/Plugins section and close the dialog.

3.1 Menu Structure

XML→Validate XML This will start the check, as described above.

3.2 Thanks and Acknowledgments

Kate Plugin ‘XML Validation’ copyright 2002 Daniel Naber daniel.naber@t-
online.de.
Documentation copyright 2002 Daniel Naber

This program is licensed under the terms of the GNU General Public License.
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Introduction

Insert Command Anders Lund 2006-05-17 3.5.2
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Abstract

The ‘Insert Command’ plugin allows you to insert shell command output into
a document open in Kate.
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The ‘Insert Command’ plugin allows you to insert shell command output into
a document open in Kate.

First enable the ‘Insert Command’ plugin by using the Settings→ Configure
Kate... dialog and checking Kate InsertCommand in in the Application Plugins
section and close the dialog.

4.1 Onscreen Fundamentals

To use the plugin, select Insert Command... from the Tools menu, which will
present you with a small dialog for entering the command, choosing a working
folder and selecting whether to include errors (STDERR output) in the inserted
text. You can also have the command string printed above the output.

The plugin can remember a number of commands as chosen in the configura-
tion page. These are used for autocompletion, and can be selected from a list
in the command entry.

By default, the command will be run in the working folder of the kate process,
which is usually your home folder. This can be changed in the configuration
page for the plugin.

Note that any shell command that requires user input (for example passwd)
or uses a ncurses interface or something similar (for example top) will fail to
produce the expected output.
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4.2 Configuration

To configure the ‘Insert Command’ plugin, open the Kate configuration dialog
from the Settings→ Configure Kate... menu and choose Plugins+Insert Com-
mand .

The following configuration options are available:

Number of commands to remember This setting is presented as a spinbox which
you can set to the number of commands to be remembered. Any number
from 0 to 99 is legal. Default is 20.

Default Working Folder This setting, presented as a set of radio buttons, al-
lows you to decide how the working folder of a command is chosen. The
options are the working folder of the Kate process (usually your home
folder when Kate is started from the K menu), the folder of the document
(if any, otherwise the above option is used) or the working folder of the
last command run in the plugin.

4.3 Thanks and Acknowledgments

Kate Plugin ‘Insert Command’ copyright 2001 Anders Lund anders@alweb.dk.
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Documentation copyright 2001 Anders Lund anders@alweb.dk

This program is licensed under the terms of the GNU General Public License.
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Introduction

HTML Tools Francis Giannaros 2002-05-15 1.00.00
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Abstract

A plugin to help with the insertion of HTML elements.
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This plugin will open a dialog which will prompt your for a HTML tag name.
Attributes and values to be put in the opening tag should be entered attr-
ibute-name="attribute-value". After pressing Enter, the opening -- and
respective closing -- tag will be placed into the document.

5.1 Menu Structure

Tools→HTML Tag... This will open the dialogue as described above.

5.2 Thanks and Acknowledgments

Kate Plugin ‘HTML Tools’ copyright 2002 Joseph Wenninger kde@jowenn.at.

Documentation copyright 2005 Francis Giannaros

This program is licensed under the terms of the GNU General Public License.
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Chapter 6

Introduction

Open Header The Kate plugin ‘Open Header’ currently has no documenta-
tion. If you are interested in rectifying that situation, please contact Lauri Watts
lauri@kde.org, KDE’s Documentation Team coordinator.

2

mailto:lauri@kde.org


The Kate Plugins Handbook

Chapter 7

Introduction

Text Filter The Kate plugin ‘Text Filer’ currently has no documentation. If you
are interested in rectifying that situation, please contact Lauri Watts lauri@kde.org,
KDE’s Documentation Team coordinator.
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Chapter 8

Introduction

File Templates Anders Lund 2006-01-10 0.1 The File Templates plug-in allows
you to create files based on other files. You can use any file as a template, which
will create a copy of the file with an empty URL, or use a special template
file which may contain macros to fill in information like your name and email
address, the current date and so on, and position the cursor at a convenient
position in the new file.

Furthermore, templates located in the template folder will be presented in the
menu item File→New from Template.

The plug-in also provides a method to easily create a new template from an
open document.

The template folder is part of the KDE file system, and consists of at least
KDEDIR/share/applications/kate/plugins/katefiletemplates/templates and KDE-
HOME/share/applications/kate/plugins/katefiletemplates/templates. If your
KDEDIRS environment variable contains additional directories, those are searched
for a similar subdirectory as well. If equally named templates are found, the
one in the local (KDEHOME) folder is chosen.

8.1 Menu Structure

File+New From Template→Any File... Presents you with Open File dialog
that allows you to use any file as a template. If the chosen file has the
extension katetemplate it will be parsed for template information and
macros.

File+New From Template→Use Recent Presents a list of files recently used
as templates, represented by their URL.

File→New From Template The remainder of submenus contains links to tem-
plates. Click a menuitem to create a file as described by the menu item
text.
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Settings→Manage Templates... This will launch a dialog with a list of all
templates found within the template directories, along with options to
add, edit or remove templates.

8.2 Using a Kate Template

When creating a file from a template that contain template macros, some macros
appears as editable variables in the text. Such variables appears as underlined
words in the text.
The first variable will be selected, so you just have to type to edit it.If the doc-
ument text contains more instances of the same variable, they are changed as
you edit. To move to the next editable variable, press the TAB key. When the
last variable is edited, the list is dropped, and your TAB key works as normal.

8.3 Creating your own templates

To create a new template, use the Settings→Manage Templates Item to launch
the template management dialog. In that, click New... to launch the File Tem-
plate Wizard. You will be asked for an optional file to turn into a template and
prompted for template information settings, and a template file will be created
for you.

Alternatively, you can create a template manually by adding template infor-
mation to the top of any file, add text and macros, and save it with the katet-
emplate extension.

The template menu gets automatically updated if you chose to store your tem-
plate in the template directory.

8.4 Editing templates

To edit a template, use the Settings→Manage Templates.... Select the template
you want to work on and click Edit..., and the template file will be opened.
Close the dialog, edit the template file as desired, save it and close it. Changes
to templates takes immediate effect, you can activate the template to test your
changes after saving it.

8.5 The Kate Template Format

If you use files with the extension katetemplate, they will be parsed for tem-
plate information, macros and a cursor position.

5



The Kate Plugins Handbook

8.5.1 Template information

While reading in the file, the parser keeps lines beginning with the phrase k-
atetemplate: and searches them for template information in the form VARI-
ABLENAME=VALUE. The first line not starting with katetemplate: will be
taken as the start of the template contents. VALUE may contain any character
but equal sign (=). Legal variable names are:

Template This is the template name, displayed in the File→New from Tem-
plate menu.

Group The group places the template in a submenu of the File→ New from
Template menu.

Name This is the name that will be set for the document, and displayed in the
file list and title bar. If the name contains %N that will be replaced with a
number, increasing if more documents has the same name.

Highlight The plug-in will try to set the Highlight for the new document to
the value of this variable. The value should be the name, as found in the
Tools→Highlighting.

Description A short informative description of the template. This is cur-
rently used to set a Whatsthis string for the menu item, but may be used
for more purposes in the future.

Author A string identifying the author, for example in the form Name <email
address>. This is currently used to set a Whatsthis string for the menu
item, but may be used for more purposes in the future.

8.5.2 Template Macros

While parsing the template contents, macros in the form %{NAME} or ${NAME}
are expanded. If you use the $ prefix, the expanded macro will be treated as
a editable variable when a document is created from the template, whereas if
you use % it is not, unless expanding failed.

The following macros are expanded:

time Expands to the current time in your locale format.

date Expands to the current date in short format.

datetime Expands to the current date and time, formatted as a string according
to your locale.

year The current year as a four digit number.

month The full name of the current month, according to your locale.

day Expands to the current day of the month.
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hostname Expands to the ’hostname’ of your computer.

index Expands to ’i’.

fullname Expands to your full name, as defined by the owner addressee in
your standard KDE addressbook.

firstname Expands to your first name, as defined in the owner addressee in
your standard KDE addressbook.

lastname Expands to your last name, as defined in the owner addressee in
your standard KDE addressbook.

email Expands to your email address, as defined by the owner address in your
standard KDE addressbook.

Any macro not in the above list is treated as a editable variable no matter the
prefix. If the same variable occurs multiple times in the template, they can be
edited at once after creating a document from the template.

8.5.3 Setting the cursor position

The special macro ${cursor} will be replaced with a vertical bar and added to
the end of the list of editable variables, independent on its location in the text.

8.6 Thanks and Acknowledgments

Kate Plug-in ‘File Templates’ copyright 2004 Anders Lund anders@alweb.dk.

Documentation copyright 2004 Anders Lund

This program is licensed under the terms of the GNU General Public License.
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Chapter 9

Credits and License

Copyrights for each applet is listed in the applicable chapter.

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Chapter 10

Index

D
DTD, 1

F
filter, 3
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template, 4
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X
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