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Abstract

Kivio is the KOffice flowchart and diagram creation tool.
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Chapter 1

Introduction

Ben Lamb

1.1 What is Kivio?

Kivio is the KOffice flowchart and diagram creation tool. It allows you to create
accurate scale diagrams by arranging pre-drawn shapes and stencils on a page.
The stencils might represent stages of a process, office furniture or components
on an electronic circuit. Kivio comes with a large collection of different stencils
which are grouped into collections, known as stencil sets, by subject area.

1.2 About this Document

This document describes the features of Kivio and how to use them. There are
often several ways to perform a particular task. Where possible the appropri-
ate menu option is described as this is the easiest to explain without the aid
of screenshots. Users are encouraged to explore the menus and to try right-
clicking on stencils to reveal shortcut menus.

1.3 Contributing to Kivio

Kivio is a volunteer project. Your contributions are welcome. If you find a bug
whilst using the software please report it by selecting Help→ Report Bug....

Contributions to the documentation, stencils, translations into other languages
and the code itself are welcome. Please see the KOffice website for more infor-
mation about how to contribute.
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Chapter 2

Basic Usage

Ben Lamb

2.1 Starting Kivio

Like other KOffice applications, on startup Kivio presents a startup dialog. The
dialog offers a choice of creating a new document, opening a saved document
or choosing a document from a list of recently saved files.

If you’re new to Kivio begin by creating an empty document by double-clicking
on the Empty Document template.

Kivio’s main window contains a view of the current document. The page out-
line and margins are shown, as is a grid. Surrounding this view are horizontal
and vertical rules. By default a tools toolbar is placed on the left-hand side
and beneath the document view is a page selector. Beneath that is the status
bar which shows the current position of the mouse pointer as a location on the
page.

At the top of the window are the two main toolbars. These contain buttons for
the most commonly used features of Kivio.

2.2 Using Stencils

Diagrams are created by placing different pre-drawn shapes and stencils on
the page. Stencils can represent many different things and Kivio comes with a
wide selection. For ease of reference they are grouped into collections known
as stencil sets. To use a stencil set select Tools→ Add Stencil Set. The stencil
sets have been sub-divided into several groups; a sub-menu lists these. The
shapes in the stencil set are shown on the left-hand side of the document view.

2
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Stencils are grouped into stencil sets for organizational purposes only; it is per-
fectly okay to add several stencil sets to a document and Kivio allows you to
mix and match stencils from different sets freely.

To place a stencil onto the document simply drag it from the stencil area to the
page.

2.2.1 Selecting Stencils

Kivio identifies the stencil currently being edited by displaying eight green
squares on the corners and edges of a square around the stencil. Stencils shown
in this manner are described as being selected. The green rectangles are known
as handles. To change the currently selected stencil move the mouse pointer
over the stencil you wish to select and press the left mouse button. To select all
the stencils on the current page select Edit→ Select All. To deselect all stencils
select Edit→Deselect.

2.2.2 Moving Stencils

To move a stencil to another position on the page, select the stencil. Note the
pointer will change to a hand icon. Hold down the left mouse button and move
the mouse to the new position. Release the mouse button to place the stencil at
the new position.

2.2.3 Resizing a Stencil

Select the stencil, and then move the mouse pointer over one of the handles.
Note the mouse pointer change. Hold down the left mouse button and move
the mouse. The coordinates of the stencil will be adjusted continuously as the
mouse is moved. When you are happy with the new size release the mouse
button to give the stencil its new final size.

2.2.4 Undoing a Mistake

If at any time you are unhappy with a change you have made to the document
you can select Edit→ Undo to revert the change. There is also an icon on the
toolbar.
If you undo an action and decide that was a mistake, select Edit→ Redo to
restore the change. Kivio stores multiple actions to undo/redo several changes.

2.2.5 Limitations of the Stencils

Note that stencils cannot currently be rotated.

3
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2.2.6 Labeling Stencils

A lot of stencils in the Flowcharting Collections, Geographic Collections, Hard-
ware Collections, Miscellaneous Collections and UML Collections can contain
text to describe their function. To add text to a stencil move the mouse pointer
over the stencil and double-click it or open the context menu with the right
mouse button and select Edit Text.... A dialog box will appear prompting for
some text. Enter some text and click OK. The text should be shown inside the
stencil.
The item Edit Text... in the menu is disabled, if a stencil cannot be labeled.

The font, size, alignment and style of the text can be adjusted by selecting For-
mat→ Text.... Alternatively use the buttons on the Format toolbar. The adjust-
ments will only affect the currently selected stencil.

2.2.7 Selecting Several Stencils

There are two ways to select multiple stencils in Kivio.

1. Click once inside the first stencil you wish to select. Hold down Ctrl as
you click inside subsequent stencils. All the stencils will be shown with
handles around them.

2. Move the mouse pointer to a blank area of the document near the stencils
you want to select.
Hold down the left mouse button and move the mouse to the other side
of the stencils you want to select, drawing a rectangle around them.
The rectangle must completely encompass the stencils for them to be se-
lected.

2.2.8 Adjusting the Fill Color and Line Color

Stencils can be filled with a solid color and the color of the outline can be
changed. Select a stencil then select Format→ Stencils & Connectors....

2.2.9 Adjusting the Line Thickness

The width of a stencil’s border can be adjusted by selecting Format→ Stencils
& Connectors.... The line width can be entered in centimeters or increased/de-
creased using the arrows of the spin box. Or use the Line Width button on the
Format toolbar. Select a width from the drop down box or select Custom... to
open enter the width in the spin box.

4
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2.2.10 Connecting Shapes Together

Kivio’s connector tool allows lines to be drawn between shapes. The lines re-
main connected to the shapes even when the shapes are moved to new posi-
tions on the page.

To draw a connector select Tools→ Straight Connector or Tools→ Polyline
Connector.
The Polyline Connector tool is also available from the Tools toolbar; by default
shown on the top side of the window. Click on this tool to begin using it; the
mouse pointer will change shape.

Notice that all stencils have little blue crosses around their edges. These crosses
mark points where connectors can be attached.

To connect two stencils move to one of the connection points on the first stencil,
hold down the left mouse button and drag a line to one of the connection points
on the second stencil. The green square at the end of the line will change to
red when it is over a connection point indicating that the line is attached to a
stencil.
When you have finished using the connector tool, click on the Arrow tool to
regain normal selection functionality.

NOTE
A stencil can have multiple connectors attached to it, even at the same connection
point.

Various properties of the connector can be adjusted including line thickness
and color, this is done in the same way as for stencils.

Straight Connectors may also be labeled with text. To add text to a straight
connector open the context menu with the right mouse button and select Edit
Text.... Enter the text in the dialog that appears. The text will be shown with a
green handle next to it. Use this to modify the position of the text.

Arrowheads can be added to either end of a connector. Select the connector
and then select Format→Arrowheads....
Limitations: Connectors do not currently reroute around stencils, you need to
adjust them manually. Text is always displayed horizontally; rotated text is not
currently possible.

2.2.11 Grouping Stencils

Several stencils may be semi-permanently grouped together. Once this has
been done any changes made to one stencil will affect the others in the group.

To make a group select the stencils and select Format→Group Selection.

The procedure can be reversed by selecting a group of stencils and select For-
mat→Ungroup.

5
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2.2.12 Overlaying Stencils

Stencils can be positioned on top of one another. A stencil drawn on top of
another stencil will obscure the stencil underneath it. To adjust the drawing
order select one of the stencils and select either Format→ Bring to Front or
Format→ Send to Back.
Send to Back will cause the stencil to be obscured by any stencil which overlaps
it. Bring to Front will cause the stencil to obscure any stencil which it overlaps.

2.2.13 Locking Stencils

A stencil’s properties may be ‘locked’ to prevent accidental changes. To alter a
stencil’s protection use the protection palette. This can be displayed by select-
ing View→ Palettes→ Show Protection. Select the stencil or stencils you wish
to protect and then tick the properties you want to protect on the protection
palette.

The protections available are: Width, Height, Aspect ratio, X position, Y po-
sition and Deletion. Deletion prevents a stencil from being deleted from the
document.

2.2.14 Stencil Geometry

For accurately specifying the dimensions of a stencil use the Geometry palette.
To display the palette select View→ Palettes→ Show Geometry. The palette
contains four spin boxes for specifying the horizontal (X:) and vertical (Y:) po-
sition of the stencil and the Width: and Height:.

TIP
Although the measurements are displayed in centimeters it is possible to enter other
units into the textbox. For example, entering 2.5 mm will be converted into centime-
ter. Points (pt) and inches (in) are also accepted.

2.3 Viewing the Document

2.3.1 Zooming In and Out

To adjust the zoom level select View→ Zoom Level. This submenu contains a
list of percentages from 33% to 500%; selecting one of these magnify the docu-
ment by that percentage.

There is also a list of zoom levels in a spin box on the Edit toolbar, by default
shown at the top of the screen.
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A second method of controlling the magnification is to use the zoom tool. This
is available on the Tools toolbar. This tool can be used in two ways. Clicking
on the document with the zoom tool active will increase the magnification.
Holding down the Shift key whilst clicking will decrease the magnification,
i.e. zoom out.
Alternatively, holding down the left mouse button and dragging out a box then
releasing the mouse button will increase the magnification so that that portion
of the document fills the available space.

2.3.2 Panning the Document

The Pan Document tool lets you move the document around, adjusting the
portion that is visible. This is very useful when working at high magnifications
where the entire document is not completely visible. To pan a document select
Pan Document from the Tools toolbar or Tools→ Pan Document in the menu.
Once activated the mouse pointer turns into a hand. To move the document
move the mouse over the currently visible portion, hold down the left mouse
button and drag.

2.3.3 The Overview

The Overview palette provides a quick way of adjusting the zoom level and
moving around the document. To enable it select View→Palettes→Overview.

A miniature representation of the document itself is shown underneath. A
red rectangle indicates the portion that is currently visible. Clicking anywhere
on this representation pans the view to that area. The rectangle can also be
dragged.

At the bottom of the palette there is a slider and two buttons to zoom 25% in
or out.

2.3.4 Using Palettes

All palettes have a handle on the top side which enables them to be moved
around and positioned on any edge of the main view. They can also float any-
where on the screen. To hide or show a palette select it from View→ Palettes.

2.3.5 Multiple Views

It is possible to have multiple views of the same document displayed simulta-
neously.

Select New View from the View menu and a new Kivio window showing the
same document will appear. This is very useful for multiple monitor setups.

7
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The additional windows can be closed and Kivio will only prompt you to save
the document when the last window is closed. All windows pertaining to a
particular document can be closed simultaneously by selecting View→ Close
All Views.

2.3.6 Split Views

It is also possible to split the window into two or more portions which can be
used to view two areas of a document at once. To split a window select View
→ Split View. The orientation of the split can be changed from horizontal to
vertical using View→ Splitter Orientation. To restore the window to its original
state select View→ Remove View.

2.3.7 Customizing the Display

The View menu contains options for toggling the display of page margins,
rulers, guides and the grid.

8
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Chapter 3

Working with Kivio

Ben Lamb

3.1 Opening a Document

To open a previously saved document select File→ Open..., a standard KDE
file dialog box will appear.

Recently used documents are listed under File→Open Recent.

3.2 Saving a Document

To save the current document select File→ Save or File→ Save As... to give an
existing file a different name.

NOTE
It is possible to save the document in a format that can be opened by earlier ver-
sions of Kivio. Select the version you require from the Filter: combo box in the save
file dialog.

3.3 Printing

The document can be printed by selecting File→ Print.... The standard KDE
printing dialog appears. A preview of the printed output can be obtained by
selecting File→ Print Preview....

9
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3.4 Importing/Exporting Documents

The Import... menu option on the File menu currently loads a Kivio or XML
document into a new Kivio application.

The Export... menu option on the File menu currently perform the same func-
tions as File→ Save As.... These options let you save a document under a dif-
ferent name or into an other format.

3.5 Documents with Multiple Pages

A Kivio document can contain several pages of diagrams.

3.5.1 Adding Pages

To add additional pages to a document select Page→ Insert Page or click with
the right mouse button on the page tab and select Insert Page from the context
menu. The selector beneath the document view shows tabs for all the pages in
the document that have not been hidden.

3.5.2 Removing Pages

Unwanted pages can be removed by selecting Page→ Remove Page or click
with the right mouse button on the page tab and select Remove Page from the
context menu.

3.5.3 Renaming Pages

The names given to each page can be adjusted by double-clicking on the page
name on the page selector or by clicking with the right mouse button on the
page tab and select Rename Page... from the context menu. A dialog box will
appear allowing the name to be edited.

3.5.4 Working with Pages

The order of the pages can be adjusted by dragging the tabs on the page selector
bar.

NOTE
The arrow buttons on the page selector bar are for scrolling through the page tabs,
they do not cycle through the pages themselves.

10
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If you have a lot of pages in a document and you do not want to see them all
on the page selector you can hide pages by selecting Page→Hide Page. This
will remove the currently selected page from the page selector bar.

To reveal a hidden page select Page→ Show Page... and choose the page you
want to see from the list box.

3.6 Exporting a Page

Individual pages can be exported as bitmap graphics files. To export the cur-
rent page select File→ Export... or File→ Save As.... A standard KDE file dia-
log box appears. The export format is determined by the name extension you
give the file, it must end with one of the extensions listed below.

The following formats are supported:

• PNG Image (.png)

• JPEG Image (.jpg)

• BMP Image (.bmp)

• Encapsulated Postscript Image (.eps)

• Portable Bitmap (.pbm)

• PCX Image (.pcx)

• Portable Pixmap Image (.ppm)

• SGI Image (RGB) (.rgb)

• X PixMap Image (.xpm)

• JPEG 2000 Image (.jp2)

• Krita Document (.kra)

• Adobe Illustrator Document (.ai)

• TIFF Image (.tiff)

• ILM EXR Image (.exr)

• Karbon14 Document (.karbon)

• GIMP Native Image Format (.xcf)

• Scalable Vector Graphics (.svg)

• Windows R©MetaFile (.wmf)

You have to confirm the export, because this may result in some loss of format-
ting. Click the button Save and the Export to Image dialog is displayed. In this
dialog you can set some export options: Page: range, the Area to export:, the
Bitmap DPI: and the Margin (Pixels): of the page.

11



The Kivio Handbook

3.7 The Grid

Kivio displays a regularly spaced grid over the document to aid stencil posi-
tioning. The visibility of the grid can be toggled by selecting View→ Show
Grid.
Objects edges are snapped to the nearest point on the grid regardless of whether
it is visible. To toggle this behavior select View→ Snap Grid.

To customize the grid select Settings→Configure Kivio... and click on the Grid
on the icon list.
This dialog box will let you adjust the color the grid is drawn in, the horizontal
and vertical spacing and the snap distance.

Tip: It is possible to have a non-square grid by specifying different horizontal
and vertical spacings.

3.8 Freestanding Text

The text tool can be used to add text to a document that is not associated with
any object. This is useful for noting general information about a drawing.

To add freestanding text make sure no object is selected by selecting Edit→
Deselect , then activate the text tool by selecting Tools→ Text Tool. The mouse
pointer will change to indicate the text tool is activated.

Drag a box to contain the text. A dialog box will appear prompting for the text,
enter some text and click OK. The formatting of the text can be adjusted by
selecting Format→ Text... or by using the toolbars.

3.9 Page Layout

The page size, margins and orientation, portrait or landscape, can be adjusted
using the Page Size & Margins dialog box. This is accessible by selecting For-
mat→ Page Layout....

3.10 Using Guides

Guides are lines used to help you position stencils. Not only can you use guides
as a visual reference when aligning items but, optionally, Kivio will snap sten-
cils to guides. This means that as soon as the edge of a stencil is within a certain
distance to a guide it will immediately move to the guide’s position.

12
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3.10.1 Adding Guides

To add a guide move the mouse pointer over either the horizontal or vertical
ruler, depending on the type of guide you require. Hold down the left mouse
button and drag the mouse over the document and release the mouse button
where you want to position the guide. As you drag the mouse the guide will
move accordingly. Or use View→Add Guide Line... to open a dialog to select
the Orientation and the Position of the guide.

3.10.2 Repositioning Guides

Once a guide is in place you can reposition it by moving the mouse over it,
holding down the left mouse button and dragging. Release the mouse button
when the guide is in its new position.

3.10.3 Visibility and Snapping

To hide guides select View→Guide Lines, this toggles the visibility.

By default stencil edges are snapped to the nearest guide, to toggle this behav-
ior select View→ Snap Grid.

3.11 Layers

Kivio allows complex diagrams to be split into multiple layers. The visibility
of layers can be turned on and off. This functionality is useful if you have a
basic diagram, for example a floorplan, and need to create several versions of
it for different audiences. The information for each audience can be placed in
a different layer. Each page of the document has its own set of layers.

3.11.1 The Layer Palette

To adjust the current page’s layers select View→ Palettes→ Show Layers . The
layer palette allows layers to be created, deleted and renamed. It can also be
used to adjust layer visibility, drawing order and select the current layer.

Kivio has the concept of the currently active layer which is the one affected
by any editing actions. By default a page contains only one layer which is the
active layer.

13
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3.11.2 Adding Layers

Using the Layers palette you can add new layers by clicking the New Layer
button, the first from the left. Layers can be deleted by clicking the second
button, Remove Layer. Kivio numbers the layers consecutively, to rename a
layer select it in the list and click Rename Layer.

3.11.3 Layer Settings

Layers are drawn in the order they are listed. The drawing occurs from the top
down so objects in the layer at the bottom of the list are drawn on top of objects
in all the other layers. The order of the list can be changed by selecting a layer
and using the Move Layer Up and Move Layer Down buttons to change its
position.

Each layer is listed with four small icons next to its name. From left to right
they represent:

Visibility (shown as a small eye) Clicking on the icon will toggle the layer’s
visibility.

Printable (shown as a small printer) Toggles if the layer should be printed with
the document or not. You might use a non-printing layer to keep notes to
yourself, or as a scrapbook to hold images you’re not ready to use yet.

Editable (shown as a small pencil) Toggles if you can edit a layer or not. You
might want to mark some layers non-editable while you work on others,
to prevent inadvertant changes.

Connectable (shown as a small connector) You can permit connecting of items
that lie on different layers with this icon.

3.12 Arranging Stencils

3.12.1 The Align Tool

The Align tool rearranges a group of stencils so that they are aligned on one
edge or on an invisible centerline. To use the tool select several stencils, then
select Format→Align & Distribute.... If the stencils are arranged in a horizon-
tal row you have the choice of aligning along the top or bottom edges or the
centerline. For stencils that are arranged in a vertical row the choice is left or
right edge or the centerline.

14
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3.12.2 The Distribute Tool

The Distribute tool arranges a group of stencils so that there is an even amount
of spacing between each stencil.

First select the stencils you want to rearrange, then select Format→ Align &
Distribute... and click on the Distribute tab in the tabbed window that appears.

You can choose whether the items should be spaced so that there is equal spac-
ing between two edges, for example, the distance between the lefthand edge of
each stencil should be the same. Or, whether the gap between each item should
be identical. Choose the Spacing option if you desire this.

The second choice is whether the spacing should use the entire extent of the
page or just the extent of the selection. If the latter is chosen the stencils will
not occupy any more space than they did originally.

NOTE
The option to use the extent of the page takes the page margins into consideration.

15
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Chapter 4

Credits and License

Ben Lamb Kivio
Program copyright 2000-2003 The Kivio Team

Current maintainer is Peter Simonsonn psn@linux.se.

CONTRIBUTORS

• Ian Reinhart Geiser geiseri@kde.org

• Laurent Montel montel@kde.org

• Frauke Oster frauke@frsv.de

• Dave Marotti lndshark@verticaladdiction.net

• The Kompany.com - "Where Open Source is at HomeTM" info@thekompany.com

• Current documentation is maintained by Ben Lamb kde@zurgy.org

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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