Chapter 5. Command and Menu Reference

Daniel Naber

David Rugge

Michel Boyer de la Giroday

Laurent Montel

Scarlett Clark

Revision KDE 4.11 (2013-11-25)

Each KMail specific menu item is discussed below. When there is a keyboard shortcut that performs a menu item function, the default shortcut is listed with the menu item.

The KMail Reader Window

File Menu

FileNew

Here you can create several new items as follows:

FileNewNew Message...

Compose a new message.

FileNewMessage from Template

Creates a new message from a selected template. Please see Compose From Templates for additional information on creating templates.

If you do not have any templates saved, you will see MessageMessage from Template(no templates).

FileNewAdd Folder...

Create a new folder.

FileNewNew AddressBook Contact...

Brings up the New Contact dialog.

FileOpen... (Ctrl+O)

Open email messages or mailboxes.

FileOpen Recent

Opens recently used messages. Only messages that have been saved and then opened will show up on this list.

FileSave As... (Ctrl+S)

Saves the currently displayed message to a .mbox. This includes all the headers and attachments.

If you would like to save it to a different format e.g. .txt, deselect Automatically select filename extension (.mbox), and be sure to change the file extension while naming the file.

FileImport Messages...

Starts up KMailCVT. This application lets you import messages from several email clients into KMail.

FilePrint Preview...

Display a dialog which shows how your email will be printed.

Note

This will only be enabled if a printer has been configured and is online available for use.

FilePrint... (Ctrl+P)

Display a dialog that lets you print the currently displayed message.

FileExpire All Folders

Delete old messages from all folders. Deletion will occur according to the rules in each folder's Properties dialog (the default is not to delete old messages at all).

FileEmpty All Trash Folders

Use this to empty all trash folders, i.e. the local trash folder and all trash folders that you might have on IMAP servers.

FileWork Offline

Sets KMail to offline mode. This turns off all network jobs. This is useful when working with messages without a network connection. This selection will become FileWork Online, which needs to be selected to go back online (required to send and receive).

FileCheck Mail (Ctrl+L)

Checks for new messages in all your accounts.

FileCheck Mail In

Check for new messages from a particular account, these accounts will be listed in the submenu.

FileUpdate Folder (F5)

Checks whether new mail arrived in the currently selected folder.

Note

This is only available for IMAP folders.

FileUpdate This Folder and All Its Subfolders (Ctrl+F5)

Checks whether new mail arrived in the currently selected folder and all of its subfolders.

You can also select multiple folders and the menu item will turn into FileUpdate These Folders and All Their Subfolders

Note

This is only available for IMAP folders.

FileSend Queued Messages

Sends the messages that are in your outbox. Messages can end up in your outbox by selecting Queue in the composer menu, composing a message in offline mode, and sending while you have no Internet connection.

FileSend Queued Messages Via

Sends the messages that are in your outbox via a specific outgoing account. This allows you to choose which server to send your queued messages from. They must be configured in Configure KMail dialog, under the Accounts+Sending tab to show up here.

FileQuit (Ctrl+Q)

Exits KMail.

Edit Menu

If the menu item you are looking for is missing, please see Edit Menu of the KDE Fundamentals. The items listed here are KMail specific.

EditMove to Trash (Del)

Moves the selected messages to the trash folder. If the selected messages are already in the trash folder, they will be permanently deleted.

EditMove Thread to Trash (Ctrl+Del)

Moves the selected thread to the trash folder, e.g. a conversation in a mailing list.

EditFind Messages... (S)

Opens up a search window that lets you search for messages with certain characteristics, e.g. a certain subject. Please see Filter Criteria for details on search options.

Your search results will display in the text area, at which point you can open the Open Search Folder or highlight the desired message and select Open Message.

EditFind in Message... (Ctrl+F)

Searches the current message text for a string entered into the Find: textbox.

EditSelect All Messages (Ctrl+A)

Selects all messages in the current folder.

EditSelect All Text (Ctrl+T)

Selects the text of the currently displayed message.

View Menu

ViewMessage List

This menu has the following options to change the view of your message list.

Sorting

Contains options to customize your sort order as follows:

  • Message Sort Order has several options, most are self explanatory. The following options may not be immediately obvious, therefore deserve an explanation.

    • By Smart Sender/Receiver will display the sender when you are reading in your outbox folder/template folder, and display the receiver when you are in your inbox/inbox subfolders.

    • By Action Item Status and By Important Status need to be set before they can be sorted. Please see Mark Messages for more information on marking your messages.

  • Message Sort Direction and Group Sort Direction allow you to change the direction of your messages/groups sort respectively.

  • Folder always Uses this Sort Order allows you to keep your sort settings per folder.

Aggregation

Allows you to set your aggregation view.

Configure... Allows you to configure aggregation, please see Configure Appearance Message List for more information on aggregation.

Theme

Allows you to select a theme.

Configure... Allows you to configure themes, please see Configure Appearance Message List for more information on themes.

Create New Tab (Ctrl+Shift+O)

Creates a new tab, then select the folder you would like to display in the tab.

Close Tab (Ctrl+Shift+W)

Closes the currently selected tab.

ViewHeaders

Select your headers view. Please see Header Options for details on headers.

ViewAttachments

Changes the way attachments appear in the Message Preview Pane (independent of the MIME Tree). Please see Attachment Options for details on attachments.

ViewExpand Thread / Group (.)

This will display the thread of the current message, i.e. all messages that are replies to the current message.

ViewCollapse Thread / Group (,)

This will hide the thread of the current message, i.e. it will hide all messages that are replies to the current message.

ViewExpand All Threads (Ctrl+.)

Expands all threads in the current folder.

ViewCollapse All Threads (Ctrl+,)

Collapses all threads in the current folder.

ViewView Source (V)

Shows the message and its complete headers in plain text format in a new window. This can be useful to find out the origin of a mail.

Note

You should know that it is easy to fake the From: header of a mail, but one can still find out which mail servers have been used to send the message by looking at the Received: lines in the header.

ViewShow Message Structure

Display the structure viewer, which is a part of the main window that lets you access all parts of a message.

ViewUse Fixed Font (X)

Uses a fixed width (Monospace) font to display the messages in the current folder. The font to be used can be configured in the Fonts tab on the Appearance page of the KMail configuration dialog.

ViewSet Encoding

Lets you choose the character encoding to be used in the Message Pane. The default, Auto, should work in almost all cases.

ViewZoom

Allows to zoom message in the Message Pane.

Go Menu

GoJump to Folder... (J)

Show a dialog box with a list of all your folders. Click on the folder you wish to view and it will display it in the message view pane.

GoNext Message (N)

Selects the next message in the message list. The keyboard shortcut Right Arrow also performs this action.

GoNext Unread Message (+)

Selects the next unread message in the message list. If there are not any unread messages below the currently selected message, then the behavior depends on the value of the When trying to find unread messages option.

GoPrevious Message (P)

Selects the previous message in the message list.

GoPrevious Unread Message (-)

Selects the previous unread message in the message list. If there is not an unread message above the currently selected message, then the behavior depends on the value of the When trying to find unread messages option.

GoNext Unread Folder (Alt++)

Jumps to the next folder with unread messages.

GoPrevious Unread Folder (Alt+-)

Jumps to the previous folder with unread messages.

GoNext Unread Text (Space)

Scrolls down if you are not yet at the bottom of a message, otherwise jumps to the next unread message.

Folder Menu

FolderAdd Folder...

Opens the Folder Properties dialog that lets you create a new folder.

FolderMark All Messages as Read

Sets the status of all new and unread messages in the current folder to read.

FolderUpdate Folder (F5)

Checks whether new mail arrived in the currently selected folder.

Note

This is only available for IMAP folders.

FolderUpdate Folder and All Its Subfolders (Ctrl+F5)

Checks whether new mail arrived in the currently selected folder and all of its subfolders.

Note

This is only available for IMAP folders.

FolderMove All to Trash

Moves all of the messages in the selected folder into the trash folder.

Note

This is only available if the currently selected folder is not a trash folder. If the currently selected folder is a trash folder, you will see Empty Trash. Please see next section for details.

FolderEmpty Trash

Permanently deletes all messages.

Note

This is only available if the currently selected folder is a trash folder.

FolderArchive Folder...

Brings up a dialog to allow you to create an archive of the currently selected folder. Please see Folder Archive for details.

FolderDelete Folder

Removes the selected folder and all its contents, including subfolders.

Warning

Please note that there is no way to access the contents of a folder after it has been removed.

FolderRemove Duplicate Messages (Ctrl+*)

Searches the folder for duplicate messages and deletes them.

FolderApply All Filters On Folder

Applies all configured filters on the currently selected folder. Please see Filter dialog for more information on filters.

FolderPrefer HTML to Plain Text

If enabled then HTML messages in this folder will be shown using HTML rendering.

Warning

For security reasons, we recommend to only activate this for folders which only contain trusted messages.

FolderLoad External References

If you have HTML messages enabled (see above), then you have the option to enable this to have images and resources linked from the web will load automatically.

Warning

For security reasons, we recommend to only activate this for folders which only contain trusted messages.

FolderMailing List Management...

This opens up the mailing list management dialog. Please see Mailing List dialog for more information on mailing lists.

FolderAssign Shortcut...

This allows you to assign a keyboard shortcut to the currently selected folder.

Message Menu

MessageNew Message... (Ctrl+N)

Opens the composer window so you can write a new message.

MessageNew Message to Mailing-List... (Ctrl+Shift+N)

Opens the composer window so you can write a new mail. If the current folder holds a mailing list and has a posting address defined, this address will be the default To: address.

MessageReply... (R)

Opens up the composer window, inserts the quoted text of the currently selected message and presets the To: field either with the mailing-list address (if you reply to a mailing-list message) or with the preferred reply address of the sender. If you want to control which address the To: field is preset with then you should use Reply Special. Your identity will automatically be set to the identity this message was originally sent to.

MessageReply to All... (A)

Opens up the composer window, inserts the quoted text of the currently selected message and presets the To: field either with the mailing-list address (if you reply to a mailing-list message) or with the preferred reply address of the sender. The Copy to (CC): field is preset with the addresses of all other recipients of the currently selected message excluding your own address. Your identity will automatically be set to the identity this message was originally sent to.

MessageReply SpecialReply to Author... (Shift+A)

Opens up the composer window, inserts the quoted text of the currently selected message and presets the To: field with the preferred reply address of the sender. Your identity will automatically be set to the identity this message was originally sent to.

MessageReply SpecialReply to Mailing-List... (L)

Opens up the composer window, inserts the quoted text of the currently selected message and presets the To: field with the mailing-list address. If you did not specify a mailing-list address for the currently selected folder and KMail cannot determine the posting address from the currently selected message then the To: field will be empty. Your identity will automatically be set to the identity this message was originally sent to.

MessageReply SpecialReply Without Quote... (Shift+R)

Works just like Reply... except that the text of the currently selected message is not quoted.

MessageReply SpecialReply With Custom Template

Works just like Reply... with the option to select a custom template that has been configured in Custom Templates.

MessageReply SpecialReply to All With Custom Template

Works just like Reply to All... with the option to select a custom template that has been configured in Custom Templates.

MessageForwardAs Attachment (Shift+F)

Forwards the message to a new recipient. The message and its attachments will become an attachment of the new message. The original message headers will be included in the forwarded message as well.

MessageForwardInline (F)

The message's text and some important header fields will be copied to the body of the new message with text marking the forwarded part. Attachments will be forwarded as attachments of the new message.

MessageForwardRedirect (E)

This works like forward, except that the message stays the same (even the From: field). The user who redirected the message is added in special header fields (Redirect-From, Redirect-Date, Redirect-To, etc.).

MessageForwardWith Custom Template

Works just like forward with the option to select a custom template that has been configured in the composer custom templates tab in Custom Templates.

MessageSend Again...

Opens a composer window with the currently selected message so it can be sent again.

Note

This is only available for messages which you have sent or, more precisely, for messages which have the sent status.

MessageEdit Message (T)

Edits the selected message if it is editable.

Note

Only messages in the outbox and drafts folder can be edited.

MessageMailing List

Offers several options for mailing list messages.

Note

The current working folder must be configured as a mailing list for this to be available. Please see Folder Properties Mailing List for information on setting up mailing lists.

The following options are available to mailing list folders:

  • Post New Message(email) will presets the To: with the address configured in Post to List.

  • Request Help(email) will presets the To: with the address configured in Post to List and help word in the Subject: field.

  • Subscribe to List(web) will open your default web browser to the subscribe website of the configured mailing list.

  • Subscribe to List(email) will presets the To: with the mailing list subscription address and subscribe word in the Subject: field.

  • Unsubscribe from List(web) will open your default web browser to the unsubscribe website of the configured mailing list.

  • Unsubscribe from List(email) will presets the To: with the mailing list subscription address and unsubscribe word in the Subject: field.

MessageCopy Message To

Copies the selected messages to a specified folder, you can choose from recent folders, local folders, or a specific account folder.

MessageMove Message To

The same as copy message to, except you permanently move the selected messages to a specified folder.

MessageMark Message

Allows you to change the status of the selected message to one of the following states:

StatusSymbolMeaning
Mark Message as Read (Ctrl+R)The message has been read.
Mark Message as Unread (Ctrl+U)The message has not been read yet.
Mark Message as ImportantThis status will not automatically be set by KMail. You can use it freely to mark messages that are in some way important to you.
Remove Important MarkRemove a previously set important flag from the message.
Mark Message as Action ItemThis status will not automatically be set by KMail. Use this to mark messages that are action items e.g. To-do list.
Remove Action Item MarkRemove a previously set action item mark from the message.
MessageMark Thread

Allows you to change the status of all messages in a thread as follows:

StatusSymbolMeaning
Mark Thread as ReadThe entire thread has been read.
Mark Thread as UnreadThe thread has not been read yet.
Mark Thread as ImportantThis status will not automatically be set by KMail. You can use it freely to mark threads that are in some way important to you.
Remove Important Thread MarkRemove a previously set important flag from the thread.
Mark Thread as Action ItemThis status will not automatically be set by KMail. Use this to mark threads that are action items e.g. To-do list.
Remove Action Item Thread MarkRemove a previously set action item mark from the thread.
Watch ThreadSet the watched thread status, which allows you to easily view threads your interested in by selecting Watched status in the drop down box found into Quick Search Bar.
Ignore ThreadAllows you to ignore entire threads.
MessageCreate Filter

Opens up the Filter dialog with a new filter added. This new filter is based on fields of the current mail, depending on which sub menu item you select from:

Filter on Subject...
Filter on From...
Filter on To...
Filter on Mailing-List...(currently selected mail must be a mailing list for this to be available)
MessageApply Filter

Allows you to Apply all Filters. If you have spam filtering set up through Anti-Spam Wizard the options Classify as Spam and Classify as NOT Spam will be available for spam filtering.

MessageCreate To-do/Reminder

Brings up the Kontact To-do/Reminder dialog with options to add the selected email as a link, inline, or inline without attachments.

MessageAdd Note...

Brings up the Kontact Note dialog to add a note to the selected email.

Tools Menu

ToolsFind Messages... (S)

Opens up a search window that lets you search for messages with certain characteristics, e.g. a certain subject. Please see Filter Criteria for details on search options.

Your search results will display in the text area, at which point you can open the Open Search Folder or highlight the desired message and select Open Message.

ToolsCertificate Manager...

Starts Kleopatra, the KDE certificate manager.

ToolsGnuPG Log Viewer

Starts KWatchGnuPG, a tool to present the debug output of the GnuPG application. If signing, encryption, or verification mysteriously stop working, you might find out why by looking at this log.

ToolsEdit "Out of Office" Replies...

Launch the Configure "Out of Office" Replies dialog, which allows you to set-up vacation notifications.

Note

Out of Office reply functionality relies on server-side filtering. To be able to use it you need to configure the Filtering tab (see option relevant to kolab server) of your IMAP account set-up.

ToolsDebug Sieve...

Launch the Sieve Diagnostics dialog. This is useful to debug sieve if you are having problems with it.

Note

You must have sieve support on your email server.

ToolsFilter Log Viewer...

Opens up the viewer window for the filter log; there you find some options to control the logging of the filtering process. In the log you will find valuable information about what filter rules were used, what was the result of the evaluation of those rules, and which filter actions were applied to a message.

ToolsImport Wizard...

Brings up the Import Wizard dialog which assists in easily importing settings and email. Please see Import Wizard for details.

ToolsExport KMail Data...

Brings up the PIM Setting Exporter dialog which assists in easily exporting your settings and email. Please see pimsettingexporter for details.

ToolsAccount Wizard...

Brings up the Account Wizard dialog which assists in easily setting up accounts. Please see Account Wizard for details.

ToolsAnti-Spam Wizard...

Brings up the Anti-Spam Wizard which can help you to set up spam filtering. Please see Anti-Spam Wizard for details.

ToolsAnti-Virus Wizard...

Brings up the Anti-Virus Wizard which can help you to set up scanning messages for viruses. Please see Anti-Virus Wizard for details.

Settings Menu

If the menu item you are looking for is missing, please see Settings Menu of the KDE Fundamentals. The items listed here are KMail specific.

SettingsShow Quick Search bar (Ctrl+H)

Allows you to enable the Quick Search bar, which allows you to quickly search for messages matching a search text, is visible.

SettingsConfigure Filters...

Opens the Message Filters window.

SettingsManage Sieve Scripts...

If your mail server supports sieve (server side filtering), you would configure your scripts here.

SettingsConfigure Automatic Archiving...

Brings up the dialog to set up automatic archiving. Please see Automatic Archiving for details.

SettingsConfigure Send Later Agent...

Brings up a dialog that allows you to modify and remove emails that have been sent using the send later feature. Please see Send Later Agent for details.

SettingsConfigure Folder Archive Agent...

Brings up a dialog that allows you to configure accounts to use the folder archive agent feature with. Please see Folder Archive Agent for details.

SettingsConfigure Notifications...

Opens a dialog that lets you configure what happens when new mail arrives, e.g. play a sound, display a popup, etc.

Help Menu

Help Menu of the KDE Fundamentals.