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Abstract

Okular is a KDE universal document viewer based on KPDF code.
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Chapter 1

Introduction

Okular is a KDE universal document viewer based on the code of the KPDF
application. Although being based on KPDF code, Okular has some unique
features such as overview mode, improved presentation support and annota-
tion support.
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Chapter 2

Basic Usage

2.1 Opening Files

To view any supported file in Okular, select File→Open..., choose a supported
file in the dialog and click Open. Your file should now be displayed in the main
window.
If you have already opened files in Okular before, you can quickly access them
by selecting them in the File→Open Recent menu.

After having a file opened you probably want to read it and therefore navigate
through it. Go to the next section to learn more about this.

2.2 Navigating

This section describes how you can navigate through a document in Okular.

There are multiple ways of scrolling the viewing area. One is to use the Up Ar-
row and Down Arrow keys. You may also use the scrollbar, your mousewheel
or the Page Up and Page Down keys.

Another way is to hold the left mouse button down at any place on the docu-
ment while dragging the mouse in the opposite direction of where you want
to move. This procedure only works if the Browse Tool is enabled, which you
can select by choosing Tools→ Browse Tool .

The navigation panel on the left side of the screen enables two more ways of
navigating through a document:

• If you click on a page thumbnail the viewing area will be brought to that
page.

2



The Okular Handbook

• If the document has a table of contents, clicking on a table of contents item
will bring the document to the page linked to that item.

Some documents have links. In this case you can click on them and the view
will change to the page it links to. If the link is to a web page or some other
document the default KDE handler for that format will be invoked. For ex-
ample, clicking on a link pointing to ‘http://www.kde.org’ will open the web
page in the default KDE’s web browser.

Additionally, you may use the following functionality to quickly move to spe-
cific places in the document:

• You can go to the first page of the document using Ctrl+Home or using Go
→ First Page.

• You can go to the last page of the document using Ctrl+End or using Go
→ Last Page.

• You can go forward in the document using Space or Page Down. To go to the
next page of the document use the Next Page Toolbar button or Go→Next
Page in the menubar.

• You can go back in the document using Backspace or Page Up. To go to
the previous page of the document use Previous Page Toolbar button or Go
→ Previous Page in the menubar.

2.3 Presentation Mode

The Presentation mode represents another way to view documents in Okular.
It can be enabled in View→ Presentation. It shows the document on a page per
page basis. The pages are shown with zoom to page, that means all the page is
visible.

NOTE
PDF documents can even specify that they are always opened in presentation
mode.

When in presentation mode, you have an helper bar located on the top of the
screen. Just move the mouse cursor to the top of the screen to make it appear.

To navigate between pages you may use the left mouse button (next page) and
the right mouse button (previous page), the mouse wheel, the arrow icons or
the line edit in the top bar, or the keys specified in the Navigating section.

You can exit presentation mode at any time by pressing the Esc key or clicking
the Quit icon in the top bar.

You can also draw on the current page with a pencil. Click on the Toggle Draw-
ing Mode icon in the top bar to enable or disable the possibility of draw in the
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presentation mode. The drawings are cleared automatically when switching to
another page, or manually selecting the Erase Drawings icon in the top bar.

The presentation mode has support for more than one screen in a multi-monitor
configuration. With more than one screen a new button will appear in the top
bar, with the icon of a screen: this is a drop down box that allows you to move
the presentation to any of the other available screens.

Presentation mode has some configuration options, you can find their descrip-
tion in the chapter Configuring Okular.
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Chapter 3

Okular Advanced Features

3.1 Embedded Files

If the current document has some files embedded in it, when you open it a
yellow bar will appear above the page view to notify you about the embedded
files.

In this case, you can either click on the link in the text of the bar or choose File
→ Embedded Files to open the embedded files dialog. The dialog allows you
to view the embedded files and to extract them.

3.2 Annotations

Okular allows you to review and annotate your documents. Annotations cre-
ated in Okular are automatically saved in the internal local data folder for each
user. Okular does not implicitly change any document it opens.

Since KDE 4.2, Okular has the "document archiving" feature. This is an Okular-
specific format for carrying the document plus various metadata related to it
(currently only annotations). You can save a "document archive" from the open
document by choosing File→ Export As→ Document Archive. To open an
Okular document archive, just open it with Okular as it would be e.g. a PDF
document.

NOTE
Due to DRM limitations (typically with PDF documents), adding, editing some prop-
erties or removing annotations could not be possible.
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3.2.1 Adding annotations

To add some annotations to the document, you have to activate the annotating
toolbar. This is done by either selecting Tools→ Review or pressing F6. Once
the annotating toolbar is shown, just press one of its buttons to start construct-
ing that annotation.

NOTE
The annotating toolbar can be docked in any side of the viewing area: just drag it
to move it to another place.

NOTE
Activating the annotating toolbar will make you switch to the Normal Mode.

You can stop the construction any time by pressing again on the button of the
annotation you are constructing, or by pressing the Esc key.

The newly constructed annotation will have as author the author you set in the
Identity page in Okulars configuration dialog.

3.2.2 Removing annotations

To remove an annotation, just click on it with the right mouse button, and select
Delete.
When removing the annotation, its window will be closed if open.

NOTE
This option could not be enabled because the document does not allow removing
annotations.

3.2.3 Editing annotations

To edit an annotation, click on it with the right mouse button and select Prop-
erties. A dialog will appear with the general annotation settings (like color and
opacity, author, etc.) and the settings specific to that annotation type.

To move an annotation, hold down the Ctrl key, move the mouse pointer on it
and then start dragging with the left mouse button.

NOTE
Depending on the document permissions (typically with PDF documents), some
options can be disabled.
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Chapter 4

The Menubar

4.1 The File Menu

File→Open... (Ctrl+O) Open a supported file or Okular archive. If there is
already an opened file it will be closed. For more information, see the
section about Opening Files.

File→Open Recent Open a file which was used previously from a submenu.
If a file is currently being displayed it will be closed. For more informa-
tion, see the section about Opening Files.

File→ Import PostScript as PDF... Open a PostScript file and convert it to
PDF.

File→ Save As... Save the currently open file under a different name using
the document backend. With the PDF backend (Poppler >= 0.8 required)
it is possible to save the document with the changed values of the form
fields.

File→ Save Copy As... Save a copy of the currently open file under a differ-
ent name without using the current document backend.

File→ Reload (F5) Reload the currently open file.

File→ Print... (Ctrl+P) Print the currently displayed document.

File→ Print Preview... Show a preview of how the currently displayed doc-
ument would be printed with the default options.

File→ Properties Display some basic information about the document, such
as title, author, creation date, and details about the fonts used. The avail-
able information depends on the type of document.

File→ Embedded Files... Show the files embedded in the document, if the
document has any. For more information, see the section about the Em-
bedded Files.
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File→ Export As This item contains the export formats the current document
can be exported to. The first entry for all kind of documents is always
Plain Text...
The second entry is Document Archive, which allows you to save the
document with your annotations into an Okular-specific archive format.
Thus it is easily possible to share the original document and your anno-
tations with other Okular users or work with them collaboratively.

File→Quit (Ctrl+Q) Close Okular.

4.2 The Edit Menu

Edit→ Copy (Ctrl+C) Copy the currently selected text in Text Selection mode
to the clipboard.

Edit→ Select All (Ctrl+A) Selects all the text (if the document provides it).
This works only in Text Selection mode.

Edit→ Find... (Ctrl+F) Show the find bar on the bottom of the viewing area
that allows you to search for a string in the document.

Edit→ Find Next (F3) Try to find the previous searched string again in the
document.

Edit→ Find Previous (Shift+F3) Goes to the previous occurrence of the search
string in the document.

4.3 The View Menu

View→ Presentation (Ctrl+Shift+P) Activates the Presentation Mode. For
more information, see the section about Presentation Mode.

View→ Zoom In (Ctrl++) Increase the magnification of the document view.

View→ Zoom Out (Ctrl+-) Decrease the magnification of the document view.

View→ Fit Width Change the magnification of the document view to a value
that makes the pages’ width equal to the document view’s width.

View→ Fit Page Change the magnification of the document view to a value
that makes at least one whole page visible.

View→ Continuous Enable the continuous page mode. In continuous mode,
all pages of the document are shown, and you can scroll through them
without having to use the Go→ Previous Page and Go→Next Page op-
tions.
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View→View Mode This submenu makes you choose the view mode for the
pages. The possible options are: Single Page (only one page per row),
Facing Pages (two pages per row, in a book style) and Overview (the
number of columns is the one specified in the Okular settings).

View→Orientation This submenu allows you to changes the orientation of
the pages of the document.

NOTE
The rotation is applied to the orientation of every page.

You can select Original Orientation to restore the orientation of the docu-
ment, discarding all the rotations applied manually.

View→ Page Size Changes the size of the pages of the document.

NOTE
This submenu is active only if the current type of document supports different
page sizes.

View→ Trim Margins Remove the white border of pages when viewing pages.

View→ Show/Hide Forms Show or hides the display of the form fields of
the document.

NOTE
This menu item is active only if the current document has form fields.

4.4 The Go Menu

Go→ Previous Page (Backspace) View the previous page of the document.

Go→Next Page (Space) View the next page of the document.

Go→ First Page (Ctrl+Home) Go to the first page of the document.

Go→ Last Page (Ctrl+End) Go to the last page of the document.

Go→ Back in the Document Go back to the previous view of the document.

Go→ Forward in the Document Move forward to the next view of the doc-
ument. This only works if you have already moved back before.

Go→Go to Page... (Ctrl+G) Open a dialog which allows you to go to any
page of the document.
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4.5 The Bookmarks Menu

Bookmarks→Add/Remove Bookmark (Ctrl+B) Add or remove a bookmark
for the current page.

Bookmarks→ Previous Bookmark Go to the previous bookmarked page, or
do nothing if there are no bookmarked pages prior to the current one.

Bookmarks→Next Bookmark Go to the next bookmarked page, or do noth-
ing if there are no bookmarked pages after the current one.

Bookmarks→No Bookmarks This is an always disabled action that appears
in this menu only if the current document has no bookmarks. Otherwise
a list of all bookmarked pages is displayed here. Clicking on these book-
marks allows you to go directly to the associated pages.

4.6 The Tools Menu

Tools→ Browse Tool (Ctrl+1) The mouse will have its normal behavior, left
mouse button for dragging the document and following links and right
mouse button for adding bookmarks and fit to width.

Tools→ Zoom Tool (Ctrl+2) The mouse will work as a zoom tool. Clicking
left mouse button and dragging will zoom the view to the selected area,
clicking right mouse button will bring the document back to the previous
zoom.

Tools→ Selection Tool (Ctrl+3) The mouse will work as a select tool. In that
mode clicking left mouse button and dragging will give the option of
copying the text/image of current selected area to the clipboard, speak a
text or to save an image to a file.

Tools→ Text Selection Tool (Ctrl+4) The mouse will work as a text selection
tool. In that mode clicking left mouse button and dragging will give the
option of selecting the text of the document. Then, just click with the right
mouse button to copy to the clipboard or speak the current selection.

Tools→ Review (F6) Open the review toolbar. The review toolbar allows
you to add annotations on the document you are reading. For more in-
formation, please see the section about Annotations.

Tools→ Speak Whole Document , Tools→ Speak Current Page , Tools→ Stop Speaking
These items allow you to speak the whole document or just the current
page and stop speaking using the KDE Text-to-Speech system KTTS.
The Speak ... actions are enabled only if KTTS is available in the system.
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4.7 The Settings Menu

Settings→ Show Menubar (Ctrl+M) Toggle the Menubar display on and off.
Once hidden it can be made visible using the shortcut Ctrl+M again.

Settings→ Show Toolbar Toggle the Toolbar display on and off.

Settings→ Show Navigation Panel (F7) Toggle the navigation panel on and
off.

Settings→ Full Screen Mode (Ctrl+Shift+F) Enables the full screen mode.
Note that full screen mode is different from presentation mode insofar
as the only peculiarity of full screen mode is that it hides the window
decorations, the menubar and the toolbar.

Settings→ Configure Shortcuts... Opens a window that lets you configure
the keyboard shortcuts for many menu commands.

Settings→ Configure Toolbars... Opens a window that lets you choose which
icons are visible in the toolbar.

Settings→ Configure Backends... Opens the Backend Configuration window.

Settings→ Configure Okular... Opens the Configure window.

4.8 The Help Menu

Help→Okular Handbook (F1) Invokes the KDE Help system starting at the
Okular help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within Okular will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→ Switch Application Language... Opens a dialog where you can edit
the Primary language and Fallback language for this application.

Help→About Okular This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.
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Chapter 5

Configuring Okular

5.1 General configuration

You can configure Okular by choosing Settings→Configure Okular.... The con-
figuration dialog is split into six sections. This chapter describes the available
options in detail.

• General

• Accessibility

• Performance

• Presentation

• Identity

• Editor
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Depending on the currently installed backends, the Settings→Configure Back-
ends... menu item could be enabled. This particular configuration dialog holds
the configurations of the backends that can actually be configured.

5.2 General

Show scrollbars Whether to show scrollbars for the document view.

Link the thumbnails with the page Whether the thumbnails view should al-
ways display the current page or not.
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Show hints and info messages Whether to show some informative messages
on startup, file load, etc..

Obey DRM limitations Whether Okular should obey DRM (Digital Rights Man-
agement) restrictions. DRM limitations are used to make it impossible to
perform certain actions with PDF documents, such as copying content to
the clipboard. Note that in some configurations of Okular, this option is
not available.

Reload document on file change Whether opened files should be automati-
cally checked for changes and updated, if necessary.

Show backend selection dialog Whether Okular should ask the user which
backend to use in case of more than one backend able to open the current
file. If unchecked, Okular will use the backend with the highest priority.

Center first page Whether the first page should be centered or aligned to the
left when displaying the pages in facing and overview mode.

Overview columns This options represent the number of columns to use in
the overview mode.

5.3 Accessibility

Draw border around links Whether to draw a border around links.

Change colors Enables the color changing options.

Invert Colors Inverts colors on the view, i.e. black objects will be shown white.

Change Paper Color Changes the paper’s color, i.e. the document’s background.

Change Dark & Light Colors Changes the dark and light color to your pref-
erence, that means black will not be rendered as black but as the selected
dark color and white will not be rendered as white but as the selected
light color.

Convert to Black & White Converts the document to black and white. You
can set the threshold and the contrast. Setting the threshold to a higher
value will result in darker grays used.

5.4 Performance

Enable transparency effects Draw selections and other special graphics using
transparency effects. Disable the option to draw them using outline or
opaque fill styles and increase speed on selections.
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Enable background generation Use a background thread to generate the pages.
By disabling this option the user interface will become less reactive (will
be blocked if necessary), but pages will be displayed a bit faster.

Memory Usage Okular can achieve best performance by tuning the memory
usage, based on your system and your tastes. The more memory you let
it to use, the faster the program will behave. The Default profile is good
for every system, but you can prevent Okular from using more memory
than necessary by selecting the Low profile, or let it get the most out of
your system using Aggressive.

5.5 Presentation

Advance every Enables automatic advancing of pages given a time period.

Loop after last page When navigating on presentation mode and going past
the last page the first page will appear.

Background color The color that will fill the part of the screen not covered by
the page when on presentation mode.

Pencil color The color of the pencil used when drawing on the pages during
the presentation mode.

Mouse cursor Whether the mouse should be always hidden, always shown or
hidden after a small time of inactivity.

Show progress indicator Whether to show a progress circle that shows the
current page and the total number of pages on the upper right corner
of the presentation screen every time you change the page.

Show summary page Whether to show a summary page at the beginning of
the presentation with the title, author and number of pages of the docu-
ment.

Default transition The transition effect between page and page if the docu-
ment does not specify one. Set this to Random Transition to make Okular
randomly choose one of the available effects.

Placement In this section you can select the Screen used to display the presen-
tation.
Current Screen is same screen of the Okular window that starts the pre-
sentation mode.
Default Screen is the screen marked as default in the xinerama configu-
ration.
Screen 0, Screen 1 etc. are the available screens.
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5.6 Identity

Author The author of the contents added on a document.

5.7 Editor

Editor Choose the editor you want to launch when Okular wants to open a
source file. This is the case when the document has references to the vari-
ous points (usually row and column number) of sources it was generated
from. The DVI format supports natively the addition of the information
about the sources the LaTeX document was generated from. A similar
system exists for PDF documents, called pdfsync, which stores these ex-
tra information in an external file named after the PDF file itself (for ex-
ample mydocument.pdfsync for mydocument.pdf).

Command This is the command and its parameters to invoke the selected ed-
itor with the source file of the actual document.
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Chapter 6

Credits and License

PROGRAM COPYRIGHT:

• Albert Astals Cidaacid@kde.org

• Pino Toscano pino@kde.org Current maintainer

• Enrico Roseros.kde@email.it KPDF developer

DOCUMENTATION COPYRIGHT:

• Albert Astals Cidaacid@kde.org Author

• Titus Laskatitus.laska@gmx.de Some updates and additions

• Pino Toscano pino@kde.org

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Installation

A.1 How to obtain Okular

Okular is part of the KDE project http://www.kde.org/ .

Okular can be found in the kdegraphics package on ftp://ftp.kde.org/pub/-
kde/ , the main FTP site of the KDE project.

A.2 Compilation and Installation

NOTE
If you are reading this help in the KHelpCenter, Okular has already been installed
on this system and you do not need install it anymore.

For detailed information on how to compile and install KDE applications see
Building KDE4 From Source

Since KDE uses cmake you should have no trouble compiling it. Should you
run into problems please report them to the KDE mailing lists.
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