The Menubar

In the menubar you find all the actions of KTurtle. They are in the following groups: File, Edit, Canvas, Run, Tools, Settings, and Help. This section describes them all.

The File Menu

FileNew (Ctrl+N)

Creates a new, empty TurtleScript file.

FileOpen... (Ctrl+O)

Opens a TurtleScript file.

FileOpen Recent

Opens a TurtleScript file that has been opened recently.

FileExamples

Open example TurtleScript programs. The examples are in your favorite language that you can choose in SettingsScript Language.

FileGet more examples...

Open the get Hot New Stuff dialog to download additional TurtleScript files from the Internet.

FileSave (Ctrl+S)

Saves the currently opened TurtleScript file.

FileSave As...

Saves the currently opened TurtleScript file on a specified location.

FileExport to HTML...

Exports the current content of the Editor as an HTML file that includes highlighting colors.

FilePrint... (Ctrl+P)

Prints the current code in the editor.

FileQuit (Ctrl+Q)

Quits KTurtle.

The Edit Menu

EditUndo (Ctrl+Z)

Undoes the last change to code. KTurtle has unlimited undos.

EditRedo (Ctrl+Shift+Z)

Redoes an undone change to the code.

EditCut (Ctrl+X)

Cuts the selected text from the editor to the clipboard.

EditCopy (Ctrl+C)

Copies the selected text from the editor to the clipboard.

EditPaste (Ctrl+V)

Pastes the text from the clipboard to the editor.

EditSelect All (Ctrl+A)

Selects all the text from the editor.

EditFind... (Ctrl+F)

With this action you can find phrases in the code.

EditFind Next (F3)

Use this to find the next occurrence of the phrase you searched for.

EditFind Previous (Shift+F3)

Use this to find the previous occurrence of the phrase you searched for.

EditOverwrite Mode (Ins)

Toggle between the 'insert' and 'overwrite' mode.

The Canvas Menu

CanvasExport to Image (PNG)...

Exports the current content of the Canvas as a raster image of the PNG (Portable Network Graphics) type.

CanvasExport to Drawing (SVG)...

Exports the current content of the Canvas as a vector drawing of the SVG (Scalable Vector Graphics) type.

CanvasPrint Canvas...

Prints the current content of the Canvas.

The Run Menu

RunRun (F5)

Starts the execution of the commands in the editor.

RunPause (F6)

Pauses the execution. This action is only enabled when the commands are actually executing.

RunAbort (F7)

Stops the execution. This action is only enabled when the commands are actually executing.

RunRun Speed

Present a list of possible execution speeds, consisting of: Full Speed (no highlighting and inspector), Full Speed, Slow, Slower, Slowest and Step-by-Step. When the execution speed is set to Full Speed (default) we can barely keep up with what is happening. Sometimes this behavior is wanted, but sometimes we want to keep track of the execution. In the latter case you want to set the execution speed to Slow, Slower or Slowest. When one of the slow modes is selected the current position of the executor will be shown in the editor. Step-by-Step will execute one command at a time.

The Tools Menu

ToolsDirection Chooser...

This action opens the direction chooser dialog.

ToolsColor Picker...

This action opens the color picker dialog.

The Settings Menu

SettingsScript Language

Choose the language for the code.

SettingsShow Editor (Ctrl+E)

Show or hide the Editor.

SettingsShow Inspector (Ctrl+I)

Show or hide the inspector.

SettingsShow Errors

Show or hide the Error tab with a list of errors resulting from running the code. If this option is enabled, click on Canvas to see the turtle again.

SettingsShow Line Numbers (F11)

With this action you can show the line numbers in the editor. This can be handy for finding errors.

SettingsShow Toolbar

Toggle the Main Toolbar

SettingsShow Statusbar

Toggle the Statusbar

SettingsConfigure Shortcuts...

Standard KDE dialog to configure the shortcuts.

SettingsConfigure Toolbars...

The standard KDE dialog for configuring the toolbars.

The Help Menu

HelpKTurtle Handbook (F1)

Invokes the KDE Help system starting at the KTurtle help pages. (this document).

HelpWhat's This? (Shift+F1)

Changes the mouse cursor to a combination arrow and question mark. Clicking on items within KTurtle will open a help window (if one exists for the particular item) explaining the item's function.

HelpReport Bug...

Opens the Bug report dialog where you can report a bug or request a wishlist feature.

HelpSwitch Application Language...

Opens a dialog where you can edit the Primary language and Fallback language for this application.

HelpAbout KTurtle

This will display version and author information.

HelpAbout KDE

This displays the KDE version and other basic information.

HelpHelp on: ... (F2)

This is a very useful function: it provides help on the code where the cursor in the editor is at. So, e.g., you have used the print command in your code, and you want to read and to know what the handbook says on this command. You just move your cursor so it is in the print command and you press F2. The handbook will then show all info on the print command.

This function can prove to be useful while learning TurtleScript.