Tools

Molecular Editor

The Molecular Editor allows you to view and edit molecules using Avogadro libraries.

Using control panel on the left you can change the view parameters, edit molecule, or measure molecules. There are three tabs on this panel: Display, Edit, and Measure. The buttons along the bottom of the window can be used to Save molecule, Download New Molecules, Load Molecule, and Close the window. The downloaded files will be saved in your Documents folder from where you can load them into the editor.

Statistics pane shows name (if available), formula, and weight of the molecule.

The Display tab can be used to change Quality of the image (Low, Medium, or High, can be useful on low-end system), Style (can be Balls and sticks, Sticks, Van der Waals, or Wireframe), 2nd Style (can be None, Ribbon, Ring, or Molecular Orbital), and Labels (can be None, Atom Numbers, Element Names, or Element Symbols).

The Edit tab allows you to edit the molecule. You can add elements by choosing them in the Element drop-down list then clicking with the left mouse button on the view panel on the right. The molecule can be optimized by clicking Optimize button.

The Measure tab can be used to measure distances and angles in the molecule. To make the measurement use the instructions shown on the tab.

On the right of the Molecular Editor window the molecule will be shown. Use left mouse button to rotate molecule, right mouse button to move it, and middle mouse button to zoom.


the “Molecular Editor”

Isotope Table

The Isotope Table... shows you the isotopes of the elements.

There are different kinds of isotopes, some are stable, some are not. The unstable isotopes can decay as alpha-rays are two different beta-rays. These differences are encoded by using different colors.


the “Isotope Table” window

Kalzium can display the isotopes of a range of elements


Plot Data

The Plot Data... dialog allows you to plot some information about elements. The X-axis represents a range of elements (from one number to a higher number). You set this range using the First Element and Last Element fields on the dialog.


the “Plot Data” Dialog

Kalzium can plot some data about a range of elements.


Perform Calculation

The Perform Calculation is the Kalzium calculator. This calculator contains a variety of calculators for different tasks performing different calculations.

You can find the following calculators in Kalzium

Molecular mass calculator

This calculator helps you calculate the molecular masses of different molecules.

You can specify short form of the molecule names add more such aliases.


the “Molecular mass calculator” dialog

Kalzium calculates molecular mass of phenol.


Concentrations calculator

You can calculate quantities which include

  • Amount of substance

  • Volume of solvent

  • Concentration of substance

There are a wide range of units to choose from and different methods to specify quantities.


the “Concentrations calculator” dialog

Kalzium calculates solution parameters.


Nuclear calculator

This calculator makes use of the nuclear data available in Kalzium to predict the expected masses of a material after time.


the “Nuclear calculator” dialog

Kalzium calculates parameters of uranium decay.


Gas calculator

This calculator can calculate the values of Temperature, pressure, volume, amount of gas etc. for various ideal as well as non-ideal gases.


the “Gas calculator” dialog

Kalzium calculates gas parameters.


Titration calculator

This calculator tries to find out the equivalence point of a pH-meter followed titration best fitting it with an hyperbolic tangent. You can also let it solve an equilibrium system of equations and see how the concentration of a species changes in function of another one.

There are two tabs on the calculator page, namely:

Experimental Values

You can use this calculator to draw the plot of your experimental data obtained during a titration and find out the volume of equivalence. It's strongly recommended to insert a even number of points, because of the best fit algorithm, sorted by volume (the X axis value).

Theoretical Equations

Here you can fill the table with the equations you have previously obtained for the chemical equilibrium.

For example, if you have this reaction A + B -> C + D then you will have the equation K=(C*D)/(A*B) so you must write K in the Parameter column and (C*D)/(A*B) in the Value column. If you want to assign a known value to a parameter you can simply write the numeric value in the Value field.

For example, you can use the system

A=(C*D)/(B*K)

K=10^-3

C=OH

OH=(10^-14)/H

H=10^-4

B=6*(10^-2)

Then you have to write D as X axis and A as Y axis: so you will find out how the concentration of A changes as a function of D concentration.

Note

Please don't use parenthesis for exponents: 10^-3 is correct, while 10^(-3) is wrong.

The results can be visualized by pressing Draw Plot button. The plot shows in red the curve that comes from theoretical equations, in blue the experimental points, and in green the approximated curve for experimental points. You can save the plot as SVG image.


the “Titration calculator” dialog

Predefined example of titration results.


Equation Balancer

The Equation Balancer enables the user to solve chemical equations. This is an example:

aH2O + bCO2 -> cH2CO3

The computed equation will be displayed on the top of the window. As you can see in the first example you can also define the value of one or more coefficients. The other coefficients will be adjusted. Furthermore, it is possible to use brackets around elements or electronic charges as shown in the last two examples.


the “Equation Balancer” dialog

Kalzium calculates equation balance.


Risk/Security Phrases

The R/S Phrases, also known as Risk and Safety Statements, R/S statements, R/S numbers, and R/S sentences, is a system of hazard codes and phrases for labeling dangerous chemicals and compounds. The R/S phrase of a compound consists of a risk part (R) and a safety part (S), each followed by a combination of numbers. Each number corresponds to a phrase. The phrase corresponding to the letter/number combination has the same meaning in different languages.


the “R/S Phrases” window

Kalzium can display Risk/Security Phrases


Glossary

The Glossary gives you definitions of the most used tools in chemistry as well as some knowledge data. On the left side of the windows you can see the tree of items. On top, there are chemical terms, below that there is a second tree of laboratory-tools.

On the top of the widget you can see a searchbar. If you type in the bar the trees will be adjusted immediately. The small button in the right end of the searchbar will clear it.


the “Glossary”

Tables

The Tables shows you the tables for Greek alphabet which is used to denote some chemical and physical entities, and for Latin prefixes and Roman numbers which correspond to common Arabic numbers.


the “Tables” window

Sidebar

Overview


Overview

The Overview tab is the first one and it shows you an overview of the element the mouse is over.

View

The View tab is the second in the navigation panel.

You are first presented with the following icons and text:


the “State of Matter” Dialog

Kalzium can show you which elements are solid/liquid/vaporous at a given temperature.


The View tab can be used to filter PSE. For example, this feature allows you to explore the elements of the set time period. This is great for getting a feel for how the PSE evolved over time, as more and more elements were discovered. Choose Discovery date from Gradient list. If you move the slider you will notice that color of some elements disappear if you move it to the left and reappear if you move it to the right. Furthermore the number will change constantly.

The number represents the date you are looking at. If you move the slider to e.g. 1856 you will only see the elements which where known in the year 1856.


the “Discovery date” gradient

The PSE back in time (elements known in 1856)