Chapter 3. Command Reference

The main Cantor window

Cantor has the common KDE menu items, for more information read the Menu chapter of the KDE Fundamentals.

Additional or special menu items in Cantor:

The File Menu

FileNew (Ctrl+N)

Creates a new worksheet with the default backend.

FileNewBackend

Creates a new worksheet with the chosen backend.

FileDownload Example Worksheets

Opens the dialog to download examples uploaded by other Cantor users with GetHotNewStuff.

FileOpen Example

Opens the dialog to choose an example to load. The examples should be downloaded with FileDownload Example Worksheets beforehand.

FileSave Plain Text

Allows saving the current worksheet as a plain text document.

FileExport to LaTeX

Allows saving the current worksheet as a LATEX document.

FilePublish Worksheet

Opens the dialog to publish your current worksheet and make it available to other Cantor users through GetHotNewStuff.

FileRun Script

Allows to load and run the batch scripts for the current backend.

The View Menu

ViewZoom In (Ctrl++)

Zoom in the current worksheet by 10%.

ViewZoom Out (Ctrl+-)

Zoom out the current worksheet by 10%.

ViewShow Script Editor

Opens the batch script editor window for the current backend.

ViewPanelsHelp

Toggles the visibility of the Help tab in the sidebar.

ViewPanelsVariable Manager

Toggles the visibility of the Variable Manager tab in the sidebar.

The Worksheet Menu

WorksheetEvaluate Worksheet

Triggers the evaluation of the whole worksheet.

WorksheetEvaluate Entry (Shift+Return)

Triggers the current entry evaluation.

WorksheetInsert Command Entry (Ctrl+Return)

Inserts a new command entry below the current cursor position.

WorksheetInsert Text Entry

Inserts a new text entry below the current cursor position.

WorksheetInsert Image

Inserts the image template below the current cursor position. You will need to click with right mouse button at the template to configure the image details.

WorksheetInsert Page Break

Inserts the page break below the current cursor position.

WorksheetRemove current Entry (Shift+Del)

Removes current entry from the worksheet.

The Settings Menu

This menu contains standard KDE Settings items, as well as the items described in Settings section.

The Help Menu

HelpCantor Handbook (F1)

Invokes the KDE Help system starting at the Cantor help pages. (this document).

HelpWhat's This? (Shift+F1)

Changes the mouse cursor to a combination arrow and question mark. Clicking on items within Cantor will open a help window (if one exists for the particular item) explaining the item's function.

HelpReport Bug...

Opens the Bug report dialog where you can report a bug or request a wishlist feature.

HelpSwitch Application Language...

Opens a dialog where you can edit the Primary language and Fallback language for this application.

HelpAbout Cantor

This will display version and author information.

HelpAbout KDE

This displays the KDE version and other basic information.