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An Introduction to KDE

Chapter 1

Introduction

This document is a brief introduction to the K Desktop Environment. It will
familiarize you with some of the basic features of KDE.

This guide is far from covering all aspects of the K Desktop or even most of
them. It will only describe some of the most basic ways to accomplish a few of
the most common tasks.
We assume that you are already familiar with at least one graphical user inter-
face, for example CDETM, GeosTM, GEMTM, NeXTSTEPTM, Mac R©, OS/2TM or
Microsoft R©Windows R©. So we will not explain the usage of the mouse or the
keyboard but concentrate on hopefully more interesting things.

1



An Introduction to KDE

Chapter 2

An Overview of KDE

This section is for users who prefer to learn by exploring and want only a brief
orientation to get started. Later sections provide a more thorough introduction
to the environment, with helpful hints and shortcuts. If you are impatient to
get started, skim this section, go play for a bit, then come back and peruse the
other sections of this guide as needed.

NOTE
KDE provides a highly configurable desktop environment. This overview assumes
that you are using the default environment.

2.1 The KDE Desktop

A typical KDE desktop consists of several parts:

• A panel at the bottom of the screen, used to start applications and switch
between desktops. Among other things, it contains the K menu, a large K
icon which displays a menu of applications to start when clicked.

• A taskbar, by default embedded in the panel, used to switch between and
manage currently running applications. Click on an application on the taskbar
to switch to the application.

• The desktop itself, on which frequently used files and folders may be placed.
KDE provides multiple desktops, each of which has its own windows. Click
on the numbered buttons on the panel to switch between desktops.
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2.2 Ready, Set, Go!

Here are a few quick tips to get you up and running.

• To start an application, click on the K icon button on the panel (called the K
menu) and choose an item from the menu.

• Click the icon that looks like a picture of a house on the panel to access the
files in your home folder using Konqueror, KDE’s File Manager utility.

• Choose K menu→ System→ Konsole to get a UNIX R© command prompt,
or press Alt+F2 to get a mini command prompt window to execute a single
command.

• Choose the Control Centeritem on the K menu to configure KDE.

• Press Alt+Tab to switch between applications and Ctrl+Tab to switch be-
tween desktops using the keyboard.

• Use the right mouse button mouse button to access context menus for the
panel, desktop, and most KDE applications.
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Chapter 3

Launching Applications

3.1 Using the K menu and the Panel

At the bottom of the screen you will find the desktop panel, which is called
Kicker. You use the panel to launch applications. Have a look at the button on
the left with a large K icon.

This button is called the K menu. It has a small arrow on the top to indicate
that it will pop up a menu if you click on it. Just do it! The pop-up offers you
easy access to all KDE applications installed on your computer system.

3.1.1 Customizing Kicker

If you use one application or tool very often, then you may want to have even
faster access to it, of course. In this case, you can add a single application, or
an entire sub-menu of the K menu, as a special quick-launch button, on to the
panel. If you want to reach the KFind application directly via a launch button,
simply choose K menu→ Panel Menu→ Add→ Button→ Find Files (By this
we mean that you should first click the K menu, then select Panel Menu, where
the small arrow to the right indicates that another menu will pop up. In this
menu, choose Add, then Button, and in the next sub-menu, Find Files).

You can add an entire menu this way, or one of the K icon button sub-menus.
For example, if you have KOffice installed and want quick access to all the
KOffice applications, without having to navigate through the K menu, then in-
stead of choosing an application, click on the Add this menu menu entry. Now
you will have instant access to all the KOffice applications, without having to
put an icon for each on the panel.
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NOTE
You can move all items of the panel around with the Move command of the context
menu. Just click with the third mouse button (the third mouse button is normally the
right button, but if you have configured your mouse differently, for example for left-
handers, it might also be the left one). A menu will pop up where you can choose
Move. Now move the mouse and see how the icon follows while still staying on
the panel. When you are done, simply hit the first mouse button (by default the left
one). As you may have noticed, there is also a menu entry Remove in case you are
tired of a certain launch button on your desktop.

3.1.2 Using Context menus

This leads us to another interesting topic: in many places, you can click the
right mouse button to display a context menu with choices that are applicable
to the item you clicked. It is therefore always a good idea to try out the third
mouse button on something, if you do not know what to do with it. Even the
background of the desktops has such a menu!

3.1.3 Other Panel features

There are other interesting things possible with the panel. One may be impor-
tant if you have a low resolution on your monitor: it is the ‘hide-and-show’
function, activated by clicking on the small arrowed button, which is at one or
both ends of the panel.

Perhaps you just don’t like the panel extending the full width of the screen.
That’s easily changed! right mouse button on an empty space in the panel, and
choose Configure Panel.... In the KControl dialog that pops up, you can choose
Length on the Appearance tab, and use the slider there to set the panel to less
than 100% width.
If you’re following along, and have that dialog open anyway, then feel free to
play with all the options, and use the Apply to see the effect they have. You
can easily reset everything to the default configuration, by simply pressing the
Use Defaults button.
By the way, if you are not sure what a certain button does in KDE, just move
the mouse pointer over it and wait for a short while: KDE has a built-in mini
context help, called ‘tool tips’, which explains the functionality of such controls
in a few words.

3.2 But I want my command line back!

Just calm down, there is nothing to fear. KDE does not want to take your
beloved (and sometimes very effective) command line away from you. You

5



An Introduction to KDE

can move your files with the desktop, but you can also use the UNIX R© com-
mands you are accustomed to. In fact,KDE puts command line power at your
fingertips, in perhaps some surprising places.

KDE provides a very sophisticated command line window called Konsole.
Choose K menu→ System→ Konsole to start it. This may be something you
want on your panel: luckily it’s already there in the default configuration!

Sometimes, you only want to enter one command on the command line. In
these cases, you do not need a full-blown terminal. Just hit Alt-F2 and you get
a small command line where you can enter one command. The command line
window will disappear afterwards, but it remembers your command.

When you pop up this window (which we call minicli by the way) and hit
the Up arrow, you can browse through all the commands you have previously
entered. Also, you can enter URLs in minicli to open a Konqueror window
with the specified URL.

Konqueror and the editor Kate can both display terminal windows, which be-
have just like Konsole. In Konqueror, you can turn this on with the menu choice
Window→ Show Terminal Emulator. The embedded terminal will display at
the bottom of your Konqueror window, and the really clever thing is that it will
follow your clicks in the file manager view, changing folder as you do. In Kate
you can display a terminal with the menu choice Settings→ Show Console.

TIP
To display a UNIX R© man page, enter man:command in minicli, where command is
the name of a UNIX R© command.

TIP
To search for a word or words on the Google search engine, you can try entering
gg:word or words. There are a whole lot more of these shortcut commands,
and you can even add your own! Take a look in KControl, in the tab Web Brows-
ing+Enhanced Browsing.

Finally, there’s a way to have your command line always available, no matter
what you’re doing - add one to your Kicker panel!

Simply right mouse button click on an empty space in the panel, and choose
Panel→ Add→ Applet→ Application Launcher. This will embed a mini-cli
directly into your panel, complete with command history.

So, in conclusion, the command line is never far from view when you’re using
KDE.

6



An Introduction to KDE

Chapter 4

Working with windows

If you have not already done so, start an application using the K menu; say,
Find Files.

4.1 A window! What now?

Well, usually people work inside windows, but sometimes you may want to
manipulate windows. Here’s a quick overview of some of the most common
window related functions:

Move a window Drag the window’s title bar, or hold the Alt key down and
drag anywhere in the window.

Resize a window: Drag the window’s border, or hold the Alt key down and
drag with the right mouse button anywhere in the window.

Maximize a window Click the maximize button in the titlebar (in the default
decoration it is the square, next to the X) to make the window fill the
screen, or if the window is already maximized, to shrink it back to its
original size. Clicking with the middle mouse button maximizes the win-
dow vertically, and with the right mouse button, horizontally.

Iconify a window Click the iconify button in the titlebar (next to Maximize)
to hide the window. Restore it by clicking on the window’s icon in the
taskbar.

Switch between windows Aside from the usual mouse click to switch to an-
other window, you can use Alt+Tab to switch windows. See below for
more techniques.
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4.1.1 Title bar buttons

KDE windows have some pretty standard buttons on their title bars which give
you fast access to some common operations. The default button layout looks
like this:
ON THE LEFT SIDE:

• A menu button. This usually shows a mini icon for the application. Click
on it to get a window operations menu. Shortcut: Alt+F3 opens the window
menu.

• Optionally a sticky button. What the heck is this? Stay tuned!

ON THE RIGHT SIDE:

• An iconify button.

• A maximize button.

• A close button. This closes the window. Shortcut: Alt+F4.

4.1.2 Switching between windows

Now that we know how to deal with windows, we encourage you to open
some other windows using the panel, since we will now discuss how to switch
between different windows. Since this is such a common activity, KDE offers
several ways to do it; pick your favorite!

Many window systems require you to click the mouse in another window to
begin using it. This is KDE’s default behavior, termed ‘Click To Focus’ focus
policy. But you can also configure your desktop in a way that moving the
mouse pointer on to a window will activate it. This is called ‘Focus Follows
Mouse’. If you select this policy using the KDE Control Center, the window
under the mouse pointer is always the active one. It doesn’t necessarily come
to the front automatically, but you can still click on to the titlebar or the border
of a window or, a KDE special, you can use the Alt key and click the middle
mouse button anywhere on the window to raise it.

Here are some other methods to switch windows:

• Pick a window from the window list menu. To open the menu, click the mid-
dle mouse button on an empty area of the desktop, or click the icon with
several windows on the panel, or finally click the up arrow at the left hand
end of the taskbar in the panel.

• Hold down the Alt key and press Tab to cycle through the windows.

• Use the taskbar (see below).
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4.2 Using the Taskbar

The taskbar displays a list of small icons, one for each window on the desktop.
In the default KDE setup the taskbar is located inside the panel, but it can also
be located at the top or the bottom of the screen.

The taskbar is very powerful. In the default configuration, if you have more
than one window from the same application open, they will be ‘grouped’, so
that you see one icon per application in the taskbar.

A simple left mouse button click on the taskbar button will pop up a list of the
open windows for that application and you can choose the window you want
to use. Choosing one of these entries with the left will bring you to the selected
window immediately. Click on a taskbar entry with the right and you will see
a menu allowing you to operate on all the windows grouped under that icon,
or each window individually.

You can choose to see all the windows on all the desktops in your taskbar, no
matter which desktop you are currently viewing, or to only see the icons for
the desktop you are looking at. You can also choose to ungroup the icons, so
that each open window will have its own icon in the taskbar. These and many
more options are available simply by right clicking on the taskbar handle (the
small textured bar at the left hand side) and choosing Configure Taskbar....

The icons on the taskbar resize themselves to make room for applications, so
you can fit many more applications than you might think. Making the panel
wider will let the taskbar icons take on a row and column layout, but they will
still resize to fit more icons.

4.3 Using Virtual Desktops

Now, what was that ‘sticky’ thing?

It may happen that you have more windows open than space on your desktop.
In this case you have three possibilities:

1. Leave all windows open (cluttered desktop)

2. Iconify those windows which you do not need at present and use the
taskbar or Alt+Tab to switch between them (still a bit confusing and
much work!)

3. Recommended: Do what a real operating system does if there is not
enough physical memory: Use virtual memory, in this case virtual desk-
tops.

The third option is the way to go! KDE can handle several different desktops,
each with its own windows. The default configuration provides four desktops.
You can switch between the virtual desktops easily with a click on one of the
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desktop buttons on the panel. Also Ctrl+F1...F4 will send you to the corre-
sponding desktop immediately, or Ctrl+Tab will cycle through the desktops.

Virtual desktops are very nice. But sometimes you want a window to be present
on every desktop. This could be, for example, a small chat window, an alarm
clock or whatever. In this case you can use the above mentioned ‘sticky’ button
which will pin the window on the background so that it will appear on every
virtual desktop.

The sticky button can also be used to move a window from one virtual desktop
to another one: push the sticky pin on the window, switch to a different desk-
top, and release the pin by pushing it again. You can achieve the same result
by using the context popup menu of the window’s entry in the taskbar (menu
item To Current Desktop) or the To Desktop option on the window operations
menu.
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Chapter 5

Managing your files

A common metaphor of graphical desktops is the use of folders to represent
folders on your hard disk. Folders contain files and other folders. A KDE
application called Konqueror, the K File Manager, uses this metaphor to help
you manage your files.

5.1 Using Konqueror

The first time you start KDE, a window with lots of icons in it appears. This is
a Konqueror window displaying the files in your home folder (the area where
your personal files are stored). The pathname of the folder is displayed under
the window’s tool bar. If you don’t see such a window now, click the icon on
the panel that looks like a folder with a picture of a house.

To open a file or folder, simply click it once with the left mouse button. You can
also choose Window→ Show Navigation Panel from the menu to display the
folder hierarchy for more direct navigation. Or you can edit the path displayed
under the toolbar to get to a specific folder quickly.

5.1.1 Opening Files

KDE comes with a set of applications to view and edit files of many common
types, and when you click a file containing, say, a document or image, Kon-
queror will start the appropriate application to display the file. If it doesn’t
know what application to start to open a file you clicked, Konqueror will prompt
you for the name of the application to run, and when you have chosen, Kon-
queror will offer to remember your choice for the next time you open a file of
that type.
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NOTE
Konqueror uses MIME types to associate files with applications.

5.1.2 Dragging and Dropping Icons

To copy or move a file, simply drag its icon to the desktop, to another Kon-
queror window, or to a folder icon. When you release the button, Konqueror
displays a menu to allow you to choose to copy, move, or create a link to the
file.

NOTE
Note that if you choose to create a link, KDE creates a UNIX R© symbolic link (not a
hard link), so if you move or delete the original file, the link will be broken.

Most KDE applications also support drag and drop operations: you can drag
an icon on to a window of a running application, or on to an icon of an appli-
cation that is not started, to have the application open the file. Try it!

5.1.3 Setting File Properties

To change file properties, such as its name and permissions, right mouse button
click the icon and choose Properties from the menu.

5.2 Working with Archives and Networks

In the recent past, you needed special software to access files on the Internet.
Not any more!

KDE supports a technology called ‘Network Transparent Access’ (NTA) which
allows you to work with files on the other side of the world as easily as those
on your local hard disk.

For example, to access files on an FTP server, just choose Location→ Open
Location from a Konqueror menu, and enter the URL of an FTP server. You
can drag and drop files to and from the folders on the server just as if they
were on your local disk. You’ll even be able to open files on the FTP server
without having to manually copy them to your local disk (KDE does it for you
when necessary).
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NOTE
Note that Konqueror uses anonymous FTP access, which may restrict your access
to files on the FTP server. If you have an account on the server, you can supply
your user ID as part of the URL, like this: ftp://userid@server/folder
Konqueror will prompt you for your password, and if the login succeeds, you will
have full access to your files on the server.

If you are used to the WinZipTM utility on Microsoft R© Windows R©, then you
will be happy to hear that KDE can look into tar archives, too. It treats such
archives just like a normal folder, and you can browse into the archive, open
files, etc. In general, accessing files on the Internet and in archives should look
and feel just like accessing files on your local disk, except for delays imposed
by the network and extracting the archive.

5.3 Using Templates to access Applications and De-
vices

In KDE it’s easy to put icons on the panel or the desktop to access your appli-
cations. It’s just as easy to add icons to access other items of interest. KDE has
templates for shortcuts to:

• Applications

• Printers

• Mountable Devices (e.g. floppy drives)

• Internet resources (e.g. WWW documents, FTP folders)

• Documents for some of KDE’s KOffice applications.

You can add any of these items to the desktop by right mouse button clicking
where you want the icon, and choosing Create New and selecting the item you
want to link to.
Nearly every item in the K menu, on the desktop, and on the panel refers to a
.desktop file on disk. The .desktop file specifies what icon to display, as well
as specific information about what the icon represents (an application, device,
or URL). You can drag any .desktop file to the panel to create a quick-launch
button.

5.3.1 Mounting devices

UNIX R© provides access to storage devices other than the primary hard disk
through a process called mounting. KDE uses .desktop files to allow you to
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easily mount, unmount, and access files on secondary storage devices such as
floppy drives and CD-ROM drive drives.

As an example, here are the steps needed to create an icon to access files on a
floppy disk:

NOTE
Many systems require you to be logged in as root to mount and unmount devices.

1. Right click on the desktop and choose Create New→ Device→ Floppy
Device....

2. On the General tab of the resulting dialog, change the name to whatever
you like, in the text box at the top.

3. On the Device tab, enter /dev/fd0 (or the path to the floppy device as it
is named on your system) as the Device.

4. You can add a Mount Point here too. This should be an existing folder,
but empty. Common mount points are /mnt/floppy or /floppy, but you
can just as easily have floppy disks mounted on /mydisk if you want.

5. Click the Unmounted Icon and select the picture of a floppy disk without
the green light.

6. Once you’re happy with your choices, choose OK and you are finished!

Now, place a properly formatted floppy in the drive and click the Floppy icon
to have KDE mount the floppy drive and display the files on the disk. Before
removing the disk from the drive, right mouse button click the Floppy icon and
choose Unmount from the menu.
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Chapter 6

Configuring your desktop

If you do not like something about the way the desktop looks or operates, you
can probably change it. KDE is very configurable and you can change almost
every aspect of the appearance and the behavior of your desktop. Unlike many
other UNIX R© desktop environments, you do not have to edit cryptic configu-
ration files either (but you can if you really want to!) You use the KControl, a
special program for configuring your desktop.

6.1 Using the KDE Control Center

Launch the KDE Control Center from the K menu. A window with two panes
appears, displaying a list of modules in the left pane.

Open a module by clicking its name; a list of submodules will appear. Then,
click one of the submodule category names to edit its configuration in the right
pane.

Changing the configuration is fairly straightforward. A help button is avail-
able on each configuration panel to explain settings that are not obvious. Each
panel has buttons labeled Help, Use Defaults, Apply, and Reset, which work
as follows:

Help Displays a short help text in the left hand pane, including a link to a
longer manual for the module in question.

Use Defaults Sets all the options in the current module back to the default at
the time KDE was installed.

Apply Applies the current settings in the currently open module.

Reset Resets the options to the state they were in when you opened the mod-
ule. If you have already used the Apply button, then this button will reset
the options to the state they were in when you pressed Apply.
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NOTE
If you make changes on one configuration panel and move to a different mod-
ule without clicking OK or Apply first, KDE Control Center will prompt you to ask
whether your changes should be applied first.
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Chapter 7

Logging out

We sincerely hope that using KDE gives you so much fun and pleasure that
you never want to log out. But if you do, simply choose K menu→ Logout.

There is also a logout button directly on the panel, which looks like a small
power button. Or you can press Ctrl+Alt+Delete to log out.

7.1 Session Management

When you log out, KDE can remember which applications you had open, as
well as where all the windows were located, so that it can open them for you
the next time you log in. This feature is termed Session Management. KDE-
aware applications will restore themselves to the state they were in when you
logged out. For example, Kate remembers which files you were editing.

Non-KDE applications do not memorize their state on logout, and KDE will
warn you to make sure that you have saved any important data in them when
you start to log out.

To illustrate session management, choose K menu→ Editors→ Kate to start
Kate. Open a text document to edit. Now log out and back in. You will observe
that Kate will be restored to the exact same position on the screen, including
the right virtual desktop, and the document we left open in Kate before we
logged out is opened again automatically. Kate will even remember whether
you had unsaved changes to your document before you logged out and will
save them to the file you were working on if you choose Save from the File
menu.
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Chapter 8

KDE, an exciting Journey

We hope you enjoyed this brief tour of the K Desktop environment and that
this unique desktop environment will help you get your work done faster and
more comfortably than ever.

Please remember that the KDE project is not a commercial venture, but rather a
project run by volunteers from all over the world. We would like to invite you
to join the KDE project and become part of this unique network of people. If
you are a programmer you might consider helping us write KDE applications.
If you are an artist or have experience with graphic design, consider creating
icons sets, color schemes, sound schemes and logos for KDE. If you enjoy writ-
ing we would love for you to join our documentation project.

As you can see there are many ways in which you can help. You are cordially
invited to join this world-wide network of people dedicated to making KDE
the best desktop environment for any computer. Please visit www.kde.org for
more information.
Welcome aboard on this exciting journey,
Your KDE Team
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Chapter 9
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