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Abstract

Konsole is KDE’s terminal emulator.
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Chapter 1

Introduction

1.1 What is a terminal?

Konsole is an X terminal emulator, often referred to as a terminal or a shell. It
emulates a command line interface in a text only window.

Explaining the use of the UNIX R© CLI is beyond the scope of this document. A
search of the web for these terms will produce more information.

1.2 Scrollback

Konsole uses the notion of scrollback to allow user’s to view previously dis-
played output. By default, scrollback is on and set to save 1000 lines of output
in addition to what is currently displayed on the screen. As lines of text scroll
off the top of the screen, they can be reviewed by moving the scroll bar up-
wards, scrolling with a mouse wheel or through the use of the Shift+Page Up
(to move back a page), Shift+Page Down (to move forward a page), Shift+Up
Arrow (to move up a line) and Shift+Down Arrow (to move down a line) keys.

When the scrolllock is on, ordinary input and output from the shell is sus-
pended, and you can scroll through the history with Page Up, Page Down, Up
Arrow and Down Arrow.
Konsole provides a number of actions located in the Scrollbackmenu.

1.3 Profiles

Profiles allow the user to quickly and easily automate the running of common
commands. Examples could include:

• ssh into another machine
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• starting an irc session

• use tail to watch a file

Procedure to create a new profile:

1. Click on the menu entry Settings→Manage Profiles...

2. Click on the button New Profile....

3. Fill in the first entry with a name. This is the name that will show in
the menu, and will be the default label instead of Shell when you start a
session of this type.

4. Enter a command just as you normally would if you opened a new shell
and were going to issue that command. For our first example above, you
might type ssh administration.

5. On the other tabs of the dialog, configure this session’s appearance. You
can configure a different font, colour scheme, $TERM type and many other
settings for each session.

6. Press the OK button. The new session is now available in the Manage
Profiles... dialog.

After creating profiles, they are listed by their name in the File menu under-
neath the default Shell item.

1.4 Mouse Buttons

This section details the use of the mouse buttons for the common right handed
mouse button order. For the left handed mouse button order, swap left and
right in the text below.

Left All left mouse button clicks will be sent to a mouse-aware application
running in Konsole. If an application will react on mouse clicks, Konsole
indicates this by showing an arrow cursor. If not, an I-beam (bar) cursor
is shown.
Holding the left mouse button down and dragging the mouse over the
screen with a mouse-unaware application running will mark a region of
the text. While dragging, the marked text is displayed reversed for vi-
sual feedback. Select Copy from the Edit menu to copy the marked text
to the clipboard for further use within Konsole or another application.
The selected text can also be dragged and dropped into compatible ap-
plications. Click on the selected text and drag it to the desired location.
Depending on your KDE settings, you may need to hold the Ctrl key
while dragging.
Normally, new-line characters are inserted at the end of each line se-
lected. This is best for cut and paste of source code, or the output of
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a particular command. For ordinary text, the line breaks are often not
important. One might prefer, however, for the text to be a stream of char-
acters that will be automatically re-formatted when pasted into another
application. To select in text-stream mode, hold down the Ctrl key while
selecting normally.
Pressing the Ctrl and Alt keys along with the left mouse button will select
a column of text.
Double-click with the left mouse button to select a word; triple-click to
select an entire line.
If the upper or lower edge of the text area is touched while marking,
Konsole scrolls up or down, eventually exposing text within the history
buffer. The scrolling stops when the mouse stops moving.
After the mouse is released, Konsole attempts to keep the text in the clip-
board visible by holding the marked area reversed. The marked area re-
verts back to normal as soon as the contents of the clipboard change, the
text within the marked area is altered or the left mouse button is clicked.
To mark text on a mouse-aware application (Midnight Commander, for
example) the Shift key has to be pressed when clicking.

Middle Pressing the middle mouse button pastes text currently in the clip-
board. Holding down the Ctrl key as you press the middle mouse button
pastes the text and sends it to Konsole.

NOTE
If you have a mouse with only two buttons, pressing both the left mouse button
and right mouse button together emulates the middle mouse button of a three
button mouse.

If you have a wheel as the middle button, rolling it in a mouse unaware
program will move Konsole’s scrollbar.

Right These items appear in the menu when the right mouse button is pressed:
Copy, Paste, Clear Scrollback & Reset, Open File Manager, Change Pro-
file, Edit Current Profile..., Show MenuBar, Character Encoding and Close
Tab
In a mouse aware application, press the Shift key along with the right
mouse button to get the popup menu.
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Chapter 2

Command Reference

2.1 The Menubar

The menubar is at the top of the Konsole window. If the menubar is hidden,
Show Menu Bar can be reached by right clicking in the window (as long as no
full screen application is running in that window such as vi, minicom, etc.).
The default shortcut is listed after each menu item.

2.1.1 File Menu

File→New Tab (Ctrl+Shift+N) Opens a new tab with the default profile

File→New Window (Ctrl+Shift+M) Opens a new separate Konsole window
with the default profile

File→ Shell Opens a new tab with the Shell profile

NOTE
Konsole ships with the Shell profile as the default. Any new profiles added by
the user will have its own menu item below File→ Shell.

File→Open File Manager Opens KDE’s file manager at the current direc-
tory. By default, that is Dolphin.

File→ Close Tab (Ctrl+Shift+W) Closes the current tab

File→Quit (Ctrl+Shift+Q) Quits Konsole

NOTE
Konsole will display a window if there is more than one tab open. This window
can be disabled by clicking on the Do not ask again checkbox.
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2.1.2 Edit Menu

Edit→ Copy (Ctrl+Shift+C) Copies the selected text to the clipboard

Edit→ Paste (Ctrl+Shift+V) Pastes text from the clipboard at the cursor loca-
tion

Edit→ Rename Tab... (Ctrl+Alt+S) Opens a dialog box allowing you to change
the name of the current tab (more info)

Edit→ Copy Input To→All Tabs in Current Window (Ctrl+Shift+,) Allows in-
put from the current session to be sent simultaneously to all sessions in
current window

Edit→ Copy Input To→ Select Tabs... (Ctrl+Shift+.) Allows input from the
current session to be sent simultaneously to user picked sessions (more
info)

Edit→ Copy Input To→None (Ctrl+Shift+/) Stop all input to other sessions

Edit→ Clear & Reset Clears all text from the tab and reset the session
All the text cleared will be stored in the Scrollback.

2.1.3 View Menu

View→ Split View→ Split View Left/Right (Ctrl+Shift+L) Splits all the tabs
into left and right views
Any output on one view is duplicated in the other view.

View→ Split View→ Split View Top/Bottom (Ctrl+Shift+T) Splits all the tabs
into top and bottom views
Any output on one view is duplicated in the other view.

View→ Split View→ Close Active (Ctrl+Shift+S) Closes the current view

View→ Split View→ Close Others (Ctrl+Shift+O) Closes the non-current view

View→ Split View→ Expand View (Ctrl+Shift+]) Makes the current view larger

View→ Split View→ Shrink View (Ctrl+Shift+[) Makes the current view smaller

View→Detach View (Ctrl+Shift+H) Opens the current tab in a separate win-
dow
Quiting the previous Konsole window will not affect the newly created
window.

View→ Show Menu Bar Toggles the menubar being visible

View→ Full Screen Mode (Ctrl+Shift+F11) Toggles Konsole filling the entire
screen
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View→Monitor for Silence (Ctrl+Shift+I) Toggles the monitoring of the cur-
rent tab for lack of activity
By default, after 10 seconds of inactivity, an info icon will appear on
the session’s tab. The type of alerts can be changed through Settings
→ Configure Notifications→ Silence in monitored session.

View→Monitor for Activity (Ctrl+Shift+A) Toggles the monitoring of the cur-
rent tab for activity
Upon any activity, an info icon will appear on the session’s tab. The type
of alerts can be changed through Settings→ Configure Notifications→
Activity in monitored session.

View→ Character Encoding Sets the character encoding

View→ Increase Text Size (Ctrl++) Increases the text font size

View→Decrease Text Size (Ctrl+-) Decreases the text font size

2.1.4 Scrollback Menu

Scrollback→ Search Output... (Ctrl+Shift+F) Opens a search bar at the bot-
tom of Konsole’s window
This allows for case sensitive, forward or backwards, and regular expres-
sions searches.

Scrollback→ Find Next (F3) Moves to the next search instance

Scrollback→ Find Previous (Shift+F3) Moves to the previous search instance

Scrollback→ Save Output... Saves the current scrollback as a text or html file

Scrollback→ Scrollback Options... Opens a dialog to configure number of
lines to save (more info)

Scrollback→ Clear Scrollback & Reset (Ctrl+Shift+X) Clears all text saved in
current tab and resets the terminal

2.1.5 Bookmarks Menu

Bookmarks→Add Bookmark (Ctrl+Shift+B) Adds the current location

Bookmarks→ Bookmark Tabs as Folder... Adds all tabs to a bookmark folder
A dialog will open for the bookmark folder name.

Bookmarks→New Bookmark Folder... Adds a new folder to the bookmark
list
A dialog will open for the bookmark folder name.

Bookmarks→ Edit Bookmarks Opens the bookmark editor
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NOTE
You can use the bookmark editor to manually add URLs. Currently, Konsole
accepts the following:

• ssh://user@host:port

• telnet://user@host:port

2.1.6 Settings Menu

Settings→ Change Profile Changes the profile for the current tab

Settings→ Edit Current Profile... Opens the profile editor for the current tab

Settings→Manage Profiles... Opens a editor for managing profiles

Settings→ Configure Shortcuts... Opens the keyboard shortcut editor

Settings→ Configure Notifications... Opens the notifications editor

2.1.7 Help Menu

Help→Konsole Handbook (F1) Invokes the KDE Help system starting at
the Konsole help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within Konsole will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→ Switch Application Language... Opens a dialog where you can edit
the Primary language and Fallback language for this application.

Help→About Konsole This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.

2.2 Rename Tab Dialog

The name of the current tab can be changed from this dialog. The dialog can
be displayed via the menu, the shortcut Ctrl+Alt+S or by double-clicking on
the tab in the tab bar. These changes can be made permanent by editing the
current profile.

Konsole will subsitute these tokens:
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• %n : program name

• %d : current directory (short)

• %D : current directory (long)

• %w : window title set by shell

• %# : session number

• %u : user name

Examples:

• %d : %n with /usr/src as current directory and running bash will display
usr/s : bash

• %D : %n with /usr/src as current directory and running top will display /us-
r/src : top

• %w (%#) with as current directory and running vim in the first tab will dis-
play [No Name] ( ) - VIM(1)

2.3 Copy Input Dialog

The text entered in one tab can simultaneously be sent to other tabs. This dialog
allows you to select which tabs will get that input. The current tab will be
greyed out.

2.4 Scrollback Options Dialog

The scrollback option for the history size can be changed in this dialog. There
is also a check box to save these settings to the current profile.
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Chapter 3

Command-line Options

When Konsole is started from the command line, various options can be spec-
ified to modify its behavior.

--help List the various options.

--profile file Start Konsole using a saved set of sessions.

--list-profiles List all of the available profiles.

--background-mode Start Konsole in the background and bring to the front
when the F12 key is pressed.

--new-tab Create a new tab in an existing window rather than creating a
new window.

--workdir dir Open with dir as the working (starting) directory.

--notransparency Disable transparent backgrounds, even if the system sup-
ports them.

--force-transparency Try to enable transparency, even if the system does
not appear to support it.

--hold, --noclose Do not close the initial session automatically when it
ends.

-p property=value Change the value of a profile property.

-e command Execute command instead of the normal shell.

NOTE
Any arguments after command will be passed to command, not Konsole.

Konsole also accepts generic QtTM and KDE options:
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--help-qt List QtTM-specific options

CAUTION
The following QtTM options have no effect on Konsole:

--fn, --font fontname Defines the application font

--bg, --background color Sets the default background color

--fg, --foreground color Sets the default foreground color

--btn, --button color Sets the default button color

--help-kde List KDE-specific options

--help-all List all options

--author Show the authors’ names

-v,--version Show the version number

--license Show license information
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Chapter 4

Scripting Konsole

For KDE 4, the old DCOP has been replaced with D-Bus. Konsole does support
numerous methods that can be used with D-Bus.

There are two ways to use the D-Bus interface: QtTM’s GUI qdbusviewer and
the command line qdbus.

Examples:

• % qdbus will display all services available.

• % qdbus org.kde.konsole will display the D-Bus interface for Konsole.

• % qdbus org.kde.konsole /Konsole will display methods for controlling the
main Konsole window.

• % qdbus org.kde.konsole /Sessions/1 will display methods for session 1.

If you start Konsole from a terminal you may need to change org.kde.konsole
to org.kde.konsole-‘pidof -s konsole‘.

For more information, please visit D-Bus tutorial.
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Chapter 5

Credits and Copyright

Konsole is currently maintained by Robert Knight robertknight@gmail.com

Previous Konsole maintainers include: Kurt Hindenburg kurt.hindenburg@gmail.com
and Waldo Bastian bastian@kde.org

The application Konsole Copyright (c) 1997-2008 Lars Doelle lars.doelle@on-
line.de
This document was written by Jonathan Singer jsinger@leeta.net

This document was updated for KDE 3.4 by Kurt Hindenburg kurt.hindenburg@gmail.com

This document was updated for KDE 4.1 by Kurt Hindenburg kurt.hindenburg@gmail.com

Originally converted to DocBook SGML by Mike McBride and Lauri Watts

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Links

For more information please visit these websites:

• Konsole’s homepage

• Konsole’s mailing list

• KDE on FreeBSD

• KDE on Solaris
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