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Abstract

This documentation describes KDat 2.0
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Chapter 1

Introduction

KDat is a tar-based tape archiver. It is designed to work with multiple archives
on a single tape. KDat was inspired by two separate goals. The first, was to
provide a nice, GUI front-end to tar that supported the fast selective extraction
features of the dds2tar program. The second goal was to answer my wife’s
question, "'How much longer is it going to be backing up?!?’

1.1 Features

e Simple graphical interface to local file system and tape contents.

e Multiple archives on the same physical tape.

Complete index of archives and files is stored on local hard disk.

Selective restore of files from an archive.

Backup profiles for frequently used backups.
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Chapter 2

Using KDat

2.1 Mounting/unmounting a tape

Before a tape can be used, it must be mounted by KDat. There are three ways
to mount a tape:

1. Select Mount Tape from the File menu.
2. Click on the tape drive icon on the toolbar.

3. right mouse button click on the tape drive tree node, and select Mount
Tape.

KDat will rewind the tape, and read the header information from the tape.
If KDat does not recognize the header on the tape, you will be prompted to
format the tape.

If KDat recognizes the header it will look for the corresponding tape index on
your local disk. If the tape index cannot be found you will be prompted to
recreate the index from tape.

If all goes well, the tape drive icon will change to indicate that the tape has
been mounted, and a message will appear in the status bar. The contents of the
tape can be explored under the tape drive tree node.

Before ejecting a tape, you must unmount the tape. There are three ways to
unmount the tape:

1. Select Unmount Tape from the File menu.
2. Click on the tape drive icon on the toolbar.

3. right mouse button click on the tape drive tree node, and select Unmount
Tape.
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KDat will acknowledge that the tape has been unmounted by changing the
tape drive icon, and displaying a message in the status bar. The tape may now
be safely ejected.

2.2 Formatting a tape

Before a tape can be used by KDat, it must be formatted by KDat.

Some types of tapes must be formatted before they can be used to store data.
This is not what KDat does when formatting a tape. If your tape drive requires that
the tapes be formatted before using them, then they must be formatted before
they can be ‘formatted’ by KDat. Typically floppy tape drives require that their
media be formatted, but DAT drives do not.

There are two ways to format a tape:

1. Select Format Tape... from the File menu.

2. right mouse button click on the tape drive tree node, and select Format
Tape....

You will be prompted for a name for the tape, and the stated capacity of the
tape. Both of these parameters can be changed after the tape has been format-
ted. The tape name is only used to identify the tape to the user; it is not used to
identify the tape index associated with the tape. Instead, a unique tape identi-
fier is automatically generated and written to the tape. The stated capacity of
the tape is used by KDat to warn the user if there will not be enough space to
complete a backup.

After entering the tape name and capacity, KDat will proceed to format the
tape. ALL DATA ON THE TAPE WILL BE LOST. Once KDat has finished for-
matting the tape, the tape will be automatically mounted and is ready for use.

2.3 Backing up files to tape

Before initiating a backup, you must select some files to archive. There are
three ways to select files for backup:

1. Highlight a file or folder in the local file tree. Only the selected file or
subfolder will be archived.

2. Highlight a backup profile in the tree. Only the files in the backup profile
will be archived.

3. Checkmark selected files in the local file tree. Only the checked files
and/or subfolders will be archived.

There are four ways to initiate a backup:
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1. Select Backup... from the File menu.
2. Click on the backup icon in the toolbar.

3. right mouse button click on a file or folder in the local file tree, and select
Backup....

4. right mouse button click on a backup profile, and select Backup....

Once the backup has been initiated, the Backup Options dialog will appear.
This dialog gives you a chance to review the selected files, and change the
backup options.

After accepting the backup options, the Backup dialog will appear. This dialog
shows the progress of the backup including throughput and time remaining.

2.4 Verifying tape files against local files

Before initiating a verify, you must select some files to verify.

There are two ways to select files for verification:

1. Highlight a file or folder in one of the archives under the tape drive tree
node. Only the selected file or subfolder will be verified.

2. Checkmark selected files in one of the archives under the tape drive tree
node. Only the checked files and /or subfolders will be verified.

There are three ways to initiate a verify:

1. Select Verify... from the File menu.
2. Click on the verify icon in the toolbar.

3. right mouse button click on a file or folder in one of the archives, and
select Verify....

Once the verify has been initiated, the Verify Options dialog will appear. This
dialog gives you a chance to review the selected files, and change the working
folder for the verification.

After accepting the verify options, the Verify dialog will appear. This dialog
shows the progress of the verification including throughput and time remain-

mg.
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2.5 Restoring files from tape

Before initiating a restore, you must select some files to restore. There are two
ways to select files for restoring:

1. Highlight a file or folder in one of the archives under the tape drive tree
node. Only the selected file or subfolder will be restored.

2. Checkmark selected files in one of the archives under the tape drive tree
node. Only the checked files and/or subfolders will be restored.

There are three ways to initiate a restore:

1. Select Restore... from the File menu.

2. Click on the restore icon in the toolbar.

3. right mouse button click on a file or folder in one of the archives, and
select Restore....

Once the restore has been initiated, the Restore Options dialog will appear.
This dialog gives you a chance to review the selected files, and change the
working folder for the restore.

After accepting the restore options, the Restore dialog will appear. This dialog
shows the progress of the restore including throughput and time remaining.

2.6 Recreating an index from tape

Sometimes it may be necessary to recreate the tape index file from the tape
contents. This process will overwrite any existing index file for the tape. There are
two way to recreate an index from tape:

1. Select Recreate Tape Index from the File menu.

2. right mouse button click on the tape drive tree node, and select Recreate
Tape Index.

The Index dialog will appear. This dialog shows KDat’s progress as it creates
the index file.

2.7 Creating a backup profile

There are two ways to create a backup profile:

1. Select Create Backup Profile from the File menu.
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2. right mouse button click on the Backup Profiles tree node, and select Cre-
ate Backup Profile.

This should create a new backup profile using the currently checked files and
the default backup options. The following options can be set for the backup
profile:

Archive name The symbolic name for the archive. It can be changed later.

Working folder The current working folder to perform the backup in. The list
of files to backup is automatically updated to reflect the selected working
folder.

Stay on one filesystem For each folder that is listed under Backup files, only
the files under that folder that are on the same file system as the folder
will be archived. Folders on different filesystems can be listed under

Backup files, and each will be treated independently of the others, by
tar.

GNU listed incremental Perform an incremental backup. A snapshot file is
used to determine which files have changed since the last incremental
backup. Only the files that have changed will be archived.

Snapshot file The name of the file that is used to determine which files have
changed since the last incremental backup.

Remove snapshot file before backup. Remove the snapshot file before invok-
ing tar. This has the effect of backing up all of the files, and creating the
snapshot file for use next time.

NOTE
The Files » and « Files buttons were not fully implemented at the time this docu-
mentation was written...

You must press the Apply button to commit any changes made to the backup
profile.

2.8 Configuring user preferences

User preferences can be configured by selecting Preferences... from the Edit
menu. The following preferences can be configured:

Default tape size This value will be used as the default tape size when for-
matting a tape.

Tape block size The hardware block size for the tape drive. For floppy tape
drives this value should be 10240 bytes.
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Tape device The full path to your tape device (usually /dev/tape). This path
must point to the non-rewind version of your tape device.

Tar command The full path to the tar command on your system.

Load tape on mount If enabled, before trying to mount a tape KDat will issue
an mtload command to the tape drive. Some drives may require this
before reading and writing the tape.

Lock tape drive on mount If enabled, whenever a tape is mounted by KDat,
the tape drive will be asked to disable the eject button. This option may
not work with all tape drives.

Eject tape on unmount If enabled, whenever a tape is unmounted by KDat,
the tape will automatically be ejected from the drive. Do not use this
option with floppy tape drives.

Variable block size If enabled, KDat will attempt to change the hardware
block size used by the tape drive. Not all drives support variable block
size. Whether this feature is enabled or not, you must tell KDat the block
size that your tape drive uses (i.e. 10240 for ftape users).

2.9 KDat tape format

When KDat formats a tape it writes a single file at the beginning of the tape.
This file should only occupy a single tape block. The contents of the file are:

e (9 bytes) The string literal KDatMAGIC
e (4 bytes) The file format version number (currently 1).
o (4 bytes) The length in bytes of the tape ID string.

o (n bytes) The tape ID string. The format of this string is hostname:seconds,
where hostname is the full name of the machine that the tape was formatted
on and seconds is the number of seconds since the epoch when the tape was
formatted.

The tape ID is used to locate a file, with the same name, in the $HOME/.kdat
folder.

Each of the remaining files on the tape are plain-old tar archives. You should
be able to manipulate them directly with GNU tar. Even non-GNU tar should
work for non-incremental backups.
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Chapter 3

Menu and Toolbar Reference

3.1 KDat menus

KDat has three menus: File, Edit, and Help.

3.1.1 The File Menu

File — Backup Begin a backup.

File — Restore Restore a backup from tape.

File — Verify Verify a backup.

File — Mount Tape Mount a tape.

File — Recreate Tape Index Recreate an index on the currently mounted tape.

File — Create Backup Profile Opens the dialog box that allows you to create
a Backup Profile.

File — Delete Archive Delete an archive from the tape.
File — Delete Index Delete the KDat index from a tape.
File — Delete Backup Profile Delete a Backup Profile.
File — Format Tape Format a tape for use with KDat.

File — Quit (Ctrl+Q) Exit KDat.

3.1.2 The Edit Menu

Edit — Preferences Opens the Preferences dialog, where you can configure
KDat for your needs.
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3.1.3 The Help Menu

Help — KDat Handbook (F1) Invokes the KDE Help system starting at the
KDat help pages. (this document).

Help — What's This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within KDat will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help — Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help — Switch Application Language... Opens a dialog where you can edit
the Primary language and Fallback language for this application.

Help — About KDat This will display version and author information.

Help — About KDE This displays the KDE version and other basic informa-
tion.

3.1.4 The KDat toolbar

The KDat toolbar contains 6 icons, as follows:

Mount/unmount Tape Mount or unmount a tape.
Backup Begin a backup. This item is unavailable unless a tape is mounted.

Restore Restore a backup from tape. This item is unavailable unless a tape is
mounted.

Verify Verify the contents of a backup tape. This item is unavailable unless a
tape is mounted.

Help Opens the KDat help files (this document)
Quit Quits KDat
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Chapter 4
Copyright

KDat
Program and Documentation copyright 1998-2000 Sean Vyain svyain@mail.tds.net

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.

This program is licensed under the terms of the GNU General Public License.
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