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Abstract

KCron is an application that schedules programs to be run.
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Chapter 1

Introduction

KCron is an application for scheduling programs to run in the background. It
is a graphical user interface to cron, the UNIX R© system scheduler.
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Chapter 2

Using KCron

IMPORTANT
Don’t forget to tell your system to start the crond cron daemon first, or KCron won’t
work.

2.1 KCron Start Up

When KCron starts you will see a summarized view of existing scheduled tasks
and associated environment variables. If you are running as the root user, you
will see these items for all users on the computer as well as the system sched-
uled tasks. Each of the folders can be expanded and contracted.
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2.1.1 Scheduled Tasks

Scheduled tasks appear under a Tasks folder. For each scheduled task, the
following are displayed:

Name Name to identify the scheduled task.

Value Program file and parameters.

Description Natural language description of scheduled task.

If a task has been disabled, no program file and parameters will appear, and
the description will be disabled.

2.1.2 Environment Variables

Environment variables appear under a Variables folder. For each environment
variable, the following are displayed:

Name Variable name.
Value Variable value.
Description Natural language description of variable.

Environment variables appearing here will override any existing environment
variable for all scheduled tasks. If an environment variable has been disabled,
no value will appear and the description will be disabled.

2.2 Adding Scheduled Tasks

To create a new scheduled task, first select the Tasks folder. Then select Edit
→New.... Alternatively, you can use the right mouse button menu and choose
New..., or simply press Ctrl+N.
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2.2.1 The Edit Task Dialog

Comment Enter a description of the task to schedule.

Program Enter the name of the program. You can specify either a relative path
or absolute path. If you want to look up the program, click Browse....

Enabled To enable or disable the task, select or de-select Enabled.

Silent Turns off logging of the command and the output from the command.

Months Select the months during which the task is to be scheduled.

Days of the Month Select the days of the month on which the task is to be
scheduled.
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Days of the Week Select the days of the week on which the task is to be sched-
uled.

Daily If you want to schedule the task to run daily, select Run every day.

Hours Select the hours on which the task is to be scheduled.
Minutes Select the minute at which the task is to be scheduled. KCron does

not support scheduling tasks at smaller than five minute intervals.

OK Completes the creation of this task.

Cancel Cancels the creation of this task.

If you select both days of the month, and days of the week, the task will run
when either condition is met. For instance, if you select the 1st and 15th, and se-
lect Sunday, the program will be run every 1st and 15th of the selected months
(regardless of day of week) as well as every Sunday of the selected months
(regardless of day of the month).

The scheduled task is not actually set up until the crontab has been saved.

2.3 Managing Scheduled Tasks

As with creating new tasks, changes to tasks will not actually be made until
the crontab is saved.

2.3.1 Cutting Scheduled Tasks

To cut a scheduled task, first select the task to be cut. Then select Edit→ Cut.
Alternatively, you can use the right mouse button menu and choose Cut, or
simply press Ctrl+X.

2.3.2 Copying Scheduled Tasks

To copy a scheduled task, first select the task to be copied. Then select Edit
→ Copy .

Alternatively, you can use the right mouse button menu and choose Copy, or
simply press Ctrl+C.

2.3.3 Pasting Scheduled Tasks

To paste a scheduled task, first a scheduled task must have already been cut or
copied to the clipboard. Once a scheduled task has been cut or copied, paste
will be enabled. Then select the Tasks folder. Finally, select Edit→ Paste.

Alternatively, you can use the right mouse button menu and choose Paste, or
simply press Ctrl+V.
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2.3.4 Modifying Scheduled Tasks

To modify a scheduled task, first select the task to be modified. Then select Edit
→Modify....

Alternatively, you can use the right mouse button menu and choose Modify...,
or simply press Ctrl+O. You will see the Edit Task dialog, with which you
would modify the task as described above.

2.3.5 Deleting Scheduled Tasks

To delete a scheduled task, first select the task to be deleted. Then select Edit
→Delete.
Alternatively, you can use the right mouse button menu and choose Delete.

2.3.6 Enabling/Disabling Scheduled Tasks

To enable or disable a scheduled task, first select the disabled task. Disabled
tasks will have Disabled in their descriptions. Then select Edit→ Enabled.

Alternatively, you can use the right mouse button menu and choose Enabled.
Confirm that the scheduled task’s program name, parameters, and description
are correctly displayed.

2.3.7 Running Scheduled Tasks

To run a scheduled task immediately, first select the task. Then select Edit
→ Run Now.
Alternatively, you can use the right mouse button menu and choose Run Now.

2.4 Adding Environment Variables

To create a new environment variable, first select the Variables folder. Then
select Edit→New....
Alternatively, you can use the right mouse button menu and choose New..., or
simply press Ctrl+N.
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2.4.1 The Edit Variable dialog

Variable Enter the environment variable name. You can use the drop-down
list box to select from the most common environment variables used by
scheduled tasks. Those include:

HOME To be used instead of the default user’s home folder.
MAILTO To send email output to an email address other than the user’s

default email address.
PATH To be used to search folders for program files.
SHELL To be used instead of the user’s default value.

Value Enter the environment variable value.

Comment Enter a description for the environment variable, such as its pur-
pose.

Enabled To enable or disable the variable, select or de-select Enabled.

OK Completes the setting of this variable.

Cancel Cancels the setting of this variable.

The environment variable is not actually set up until the crontab has been
saved.
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2.5 Managing Environment Variables

NOTE
As with creating new variables, changes to variables will not actually be made until
the crontab is saved.

2.5.1 Cutting Environment Variables

To cut an environment variable, first select the variable to be cut. Then select
Edit→ Cut.
Alternatively, you can use the right mouse button menu and choose Cut, or
simply press Ctrl+X.

2.5.2 Copying Environment Variables

To copy an environment variable, first select the variable to be copied. Then
select Edit→ Copy.

Alternatively, you can use the right mouse button menu and choose Copy, or
simply press Ctrl+C.

2.5.3 Pasting Environment Variables

To paste an environment variable, first an environment variable must have al-
ready been cut or copied to the clipboard. Once an environment variable has
been cut or copied, paste will be enabled. Then select the Variables folder. Fi-
nally, select Edit→ Paste.

Alternatively, you can use the right mouse button menu and choose Paste, or
simply press Ctrl+V.

2.5.4 Modifying Environment Variables

To modify an environment variable, first select the variable to be modified.
Then select Edit→Modify.... Alternatively, you can use the right mouse but-
ton menu and choose Modify..., or simply press Ctrl+O. You will see the Edit
Variable dialog, in which you would modify the variable as described above.

2.5.5 Deleting Environment Variables

To delete an environment variable, first select the variable to be deleted. Then
select Edit→Delete
Alternatively, you can use the right mouse button menu and choose Delete.
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2.5.6 Enabling/Disabling Environment Variables

To enable or disabled an environment variable, first select the disabled vari-
able. Disabled variables will have Disabled in their descriptions. Then select
Edit→ Enabled.
Alternatively, you can use the right mouse button menu and choose Enabled.
Confirm that the environment variable’s name and value are correctly dis-
played.

2.6 Saving the crontab

Once all scheduled tasks and environment variables have been created and/or
properly modified, save the crontab by selecting File→ Save.

Alternatively, you can simply press Ctrl+S. Additions or changes will not ac-
tually be made until this is done.

2.7 Printing the crontab

To print the crontab as it has been saved, select File→ Print.
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The standard KDE printer dialog will display. If you select Expand you will
see that there are two extra KCron specific options in the Print Dialog box.

Print Crontab Prints the crontab for the current user.

Print All Users Prints the crontabs for all users. This option is enabled only
for users with super-user privileges.
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Chapter 3

Command Reference

3.1 The main KCron window

3.1.1 The File Menu

File→ Save (Ctrl+S) Saves changes to the crontab.

File→ Print... (Ctrl+P) Prints the crontab.

File→Quit (Ctrl+Q) Quits KCron.

3.1.2 The Edit Menu

Edit→ Cut (Ctrl+X) Cut the selected task or variable.

Edit→ Copy (Ctrl+C) Copy the selected task or variable.

Edit→ Paste (Ctrl+V) Paste a task or variable that has been cut or copied.

Edit→New... (Ctrl+N) Create a new task or variable.

Edit→Modify... (Ctrl+O) Modify the selected task or variable.

Edit→Delete Delete the selected task or variable.
Edit→ Enabled Enable/disable the selected task or variable.

Edit→ Run Now Run the selected task now.

3.1.3 The Settings Menu

Settings→ Show Toolbar Displays toolbar.

Settings→ Show Statusbar Displays statusbar.
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3.1.4 The Help Menu

Help→KCron Handbook (F1) Invokes the KDE Help system starting at the
KCron help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within KCron will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→ Switch Application Language... Opens a dialog where you can edit
the Primary language and Fallback language for this application.

Help→About KCron This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.
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Chapter 4

Questions and Answers

1. Why aren’t the changes I am making to scheduled tasks and/or environment
variables taking effect?
Additions or changes to scheduled tasks do not actually happen until the
crontab has been saved.
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Chapter 5

Credits and License

KCron
Program copyright 2000 Gary Meyer gary@meyer.net

Documentation copyright 2000 Morgan N. Sandquist morgan@pipeline.com

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Installation

A.1 How to obtain KCron

KCron is part of the KDE project http://www.kde.org/ .

KCron can be found in the kdeadmin package on ftp://ftp.kde.org/pub/-
kde/ , the main FTP site of the KDE project.

A.2 Requirements

In order to successfully compile KCron, you need the following libraries:

• cron, such as vixie-cron. KCron uses the crontab command to modify user’s
scheduled tasks.

• POSIX-compliant UNIX R©, such as provided by glibc. KCron uses some
standard UNIX R© system calls for localization of dates and times

A.3 Compilation and Installation

For detailed information on how to compile and install KDE applications see
Building KDE4 From Source

Since KDE uses cmake you should have no trouble compiling it. Should you
run into problems please report them to the KDE mailing lists.
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