Chapter 13. Installation of Krusader on KDE4.x

Requirements

In order to successfully use the most recent Krusader, you need KDElibs >= 4.x

Required KDE version:

  • Krusader v1.01: KDE 2

  • Krusader v1.02 - 1.40: KDE 3.0 - KDE 3.2

  • Krusader 1.40: prefers KDE 3.2 (otherwise all features will not be available)

  • Krusader v1.50 - v1.51: KDE 3.2 - KDE 3.3 (Konfigurator crash on KDE 3.4)

  • Krusader v1.60.0 - v1.70.0: KDE 3.3 - KDE 3.5

  • Krusader 1.70.x: prefers KDE >= 3.4 (otherwise all features will not be available)

  • Krusader 1.80.0: KDE 3.4 - KDE 3.5

  • Krusader 1.90.0: KDE 3.2 - KDE 3.5

  • Krusader v2.x.x: KDE 4.x

NOTE: for installation instructions for Krusader-1.x for KDE 2 visit the Krusader website.

Platforms:

  • All POSIX (Linux®/BSD/UNIX®-like OSes), Solaris

  • All BSD Platforms (FreeBSD©/NetBSD®/OpenBSD®/Mac® OS)

In order to handle archives, checksums and other utilities they must be configured in our configuration tool. When running Krusader for the first time the available utilities will be autodetected, and a report will be shown in the first lanch wizard. Afterwards additional utilities can be added/removed/changed.

A package of popular (un)packers, Krusader itself and add-ons can be found on the Krusader downloadpage.

For more requirements, see below. Have a look at the FAQ section as well.