Chapter 9. Command Reference

The Main Tellico Window

Each menu item is discussed below. When there is a keyboard shortcut that performs a menu item function, the default shortcut is listed with the menu item.

The File Menu

FileNew

This command creates a new collection. Tellico supports 12 default collection types along with an empty user-defined custom collection.

FileOpen... (Ctrl+O)

This command opens a Tellico file.

FileOpen Recent

This command opens a file from a submenu that contains a list of recently opened files.

FileSave... (Ctrl+S)

This command saves the collection. If the file is Untitled then Save... is equivalent to Save As. It is only enabled when the collection has been modified.

FileSave As...

This command saves the collection to a new file.

FilePrint... (Ctrl+P)

This command prints the collection. Printing options may be set in the Configuration Dialog.

FileImport

This command imports data from another file. Tellico can import data from a number of other formats.

FileExport

This command exports the collection to another format. Tellico can export data to a number of other formats.

FileQuit (Ctrl+Q)

This command closes the Tellico window. If the collection has unsaved changes, you will be prompted to save them before continuing.

The Edit Menu

EditUndo (Ctrl+Z)

This command undoes the previous action. Not all actions are supported by Undo.

EditRedo (Ctrl+Shift+Z)

This command reverts a previous Undo.

EditCut (Ctrl+X)

This command removes the selected text, if any, and places a copy of the removed text in the clipboard.

EditCopy (Ctrl+C)

This command copies the selected text, if any, to the clipboard.

EditPaste (Ctrl+V)

This command pastes the text in the clipboard, if any, into the editor at the cursor position.

EditSelect All (Ctrl+A)

This command selects all the entries in the collection, in the Column View.

EditDeselect (Ctrl+Shift+A)

This command deselects all the entries in the collection.

EditInternet Search... (Ctrl+I)

This command opens the Internet Search Dialog to search for and import entries from various Internet sites, including Amazon.com.

EditAdvanced Filter... (Ctrl+J)

This command opens the Advanced Filter Dialog.

The Collection Menu

CollectionNew Entry (Ctrl+N)

This command opens the Entry Editor to edit a new entry.

CollectionEdit Entry (Ctrl+E)

This command opens the Entry Editor to edit the selected entries.

CollectionDuplicate Entry (Ctrl+Y)

This command copies, or duplicates, the selected entries as new entries in the collection.

CollectionDelete Entry (Ctrl+D)

This command deletes the selected entries.

CollectionMerge Entries

This command merges the selected entries.

CollectionUpdate Entry

This menu contains a list of all available data sources, and can be used to automatically query the source and update the selected entries.

CollectionCheck-out

This command opens a dialog box for loaning the selected entries..

CollectionCheck-in

This command checks-in any of the selected entries which are currently on-loan.

CollectionRename Collection (Ctrl+R)

This command opens a dialog box for renaming the collection.

CollectionCollection Fields... (Ctrl+U)

This command opens the Collection Fields Dialog.

CollectionGenerate Reports...

This command opens the Report Dialog for generating reports about the collection.

CollectionBibliographyConvert to Bibliography

This command converts a book collection to a bibliography by adding certain fields necessary for Bibtex export, and it is only enabled when a book collection is open.

CollectionBibliographyString Macros...

This command opens a dialog box for editing the Bibtex string macros in the collection. It is only enabled when editing a bibliography.

CollectionBibliographyCheck for Duplicate Keys

This command checks for duplicate Bibtex keys and can filter the collection to show the entries with duplicated keys.

CollectionBibliographyCopy Bibtex to Clipboard

This command copies a Bibtex citation to the clipboard so that it can pasted in a LaTeX document.

CollectionBibliographyCite Entry in Lyx

This command sends a citation for the selected entries to the so-called lyxpipe for use in LyX, Kile, or other LaTeX applications. It is only enabled when editing a bibliography.

The Settings Menu

SettingsToolbars Shown

This command toggles the display of the toolbars.

SettingsShow Statusbar

This command toggles the display of the statusbar.

SettingsShow Group View

This command toggles the display of the Group View.

SettingsShow Entry Editor

This command toggles the display of the Entry Editor.

SettingsGroup Selection

This command changes the field used to group the entries in the collection.

SettingsConfigure Shortcuts...

This command opens the KDE Keyboard Shortcut Configuration Dialog.

SettingsConfigure Toolbars...

This command opens the KDE Toolbar Configuration Dialog.

SettingsConfigure Tellico...

This command opens the Tellico Configuration Dialog.

The Help Menu

These are the KDE standard items for the Help menu:

HelpTellico Handbook (F1)

Invokes the KDE Help system starting at the Tellico help pages. (this document).

HelpWhat's This? (Shift+F1)

Changes the mouse cursor to a combination arrow and question mark. Clicking on items within Tellico will open a help window (if one exists for the particular item) explaining the item's function.

HelpReport Bug...

Opens the Bug report dialog where you can report a bug or request a wishlist feature.

HelpSwitch Application Language...

Opens a dialog where you can edit the Primary language and Fallback language for this application.

HelpAbout Tellico

This will display version and author information.

HelpAbout KDE

This displays the KDE version and other basic information.

Apart from the standard KDE Help menu items described above Tellico has this additional menu entry:

HelpTip of the Day

This command opens the Tip of the Day dialog. You can page through all the tips by using the buttons on the dialog.