Chapter 25. Reference

Revision 4.7.01 (2014-08-30)

Menus

Roger Lum

Below is a complete list of the menu selections in KMyMoney, with a very brief description of what each one does. Note that many of these menu choices will be unavailable, or grayed out, depending on the current display or state of the application. For example, you are not able to edit an account unless you have an account selected or displayed in the current view.

File Menu

FileNew (Ctrl+N)

Creates a new empty KMyMoney data file. Only one KMyMoney file can be open at once, so this will close your current file first, if one is open.

FileOpen (Ctrl+O)

Opens an existing KMyMoney data file.

FileOpen Recent...

Allows quick access to recently opened files.

FileOpen Database...

Opens an existing database.

FileSave (Ctrl+S)

Saves the currently open file.

FileSave As...

Saves the currently open file with a different filename.

FileSave As Database...

Saves the currently open file in a Database.

FileImport...

Imports financial data from other file types, such as QIF and Gnucash, or a template file of accounts and categories that can be used in setting up new accounts.

FileExport...

Exports the current file as a different file type, such as QIF, or exports a list of your accounts and categories as an template.

FilePrint (Ctrl+P)

Prints the current file.

FileBackup

Saves a backup the current file.

FilePersonal Data

Allows to edit personal data.

FileFile information

Displays information about the currently open KMyMoney file.

FileClose (Ctrl+W)

Closes the current file.

FileQuit (Ctrl+Q)

Quit KMyMoney

Edit Menu

EditFind transaction... (Ctrl+F)

Search transactions.

View Menu

ViewShow Transaction Detail (Ctrl+T)

Shows transaction details in the Ledger view. With this option turned on, all lines of the transaction will be shown in the ledger. When it is turned off, only one line will be shown.

If you only want to see details for the currently selected transaction, but only one line for the others, you can turn on the Ledger Lens.

ViewHide reconciled transactions (Ctrl+R)

Hides reconciled transactions on the register.

ViewHide unused categories (Ctrl+U)

Hides unused categories in the views.

ViewShow all accounts (Ctrl+Shift+A)

Shows all accounts in the views.

Institution Menu

InstitutionNew institution...

Add a new institution.

InstitutionEdit institution...

Edit an institution.

InstitutionDelete institution...

Delete an institution.

Account Menu

AccountNew account...

Adds a new account.

AccountEdit account...

Edits an account.

AccountDelete account...

Deletes an account.

AccountOpen ledger

Displays the ledger view of an account.

AccountReconcile... (Ctrl+Shift+R)

Reconciles an account through the reconciliation wizard.

AccountPostpone reconciliation

Postpones reconciliation of an account.

AccountFinish

Finishes reconciliation of an account.

AccountTransaction report

Opens a transaction report of an account.

AccountClose account

Closes an account.

AccountReopen account

Reopens an account, if closed.

AccountUnmap account

Unmaps an online account.

AccountMap to online account

Maps an account to an online account.

AccountUpdate account...

Imports transactions from online banking for an account

AccountUpdate all accounts...

Import transactions from online banking for all accounts.

Category Menu

CategoryNew category...

Adds a new category.

CategoryEdit category...

Edits a category.

CategoryDelete category...

Deletes a category.

CategoryOpen ledger

Displays the ledger view of a category.

Transaction Menu

TransactionNew (Ctrl+Ins)

Adds a new transaction.

TransactionEdit

Edits a transaction.

TransactionEdit splits

Edits the splits of a transaction.

TransactionDelete

Deletes a transaction.

TransactionDuplicate

Duplicates a transaction.

TransactionMark transaction as ...Not Reconciled

Changes a transaction to Not Reconciled status.

TransactionMark transaction as ...Cleared (Ctrl+Shift+Space)

Changes a transaction to Cleared status.

TransactionMark transaction as ...Reconciled (Alt+Ctrl+Space)

Changes a transaction to Reconciled status.

TransactionGo to account

Displays the other account of a transaction.

TransactionGo to payee

Displays the Payee view and focuses on the payee of the selected transaction.

TransactionCreate scheduled transaction...

Creates a new scheduled transaction.

TransactionMatch

Matches imported transactions.

TransactionUnmatch

Unmatches a transactions that KMyMoney has proposed as a match of imported transactions. Note that this menu choice is only present if a matched transaction exists.

TransactionAccept

Accepts a proposed merge of imported transactions.

TransactionSelect all (Ctrl+A)

Selects all transactions on the register.

TransactionPrint check

Prints the contents of the selected transaction in the displayed register, formatted according to the selected template. Note that this menu choice is only present if a transaction is selected in the register. See the section on configuring the Print check plugin for more information.

Tools Menu

ToolsQIF Profile Editor...

Modifies the QIF profile used to import or export QIF files.

ToolsCurrencies...

Lists the currencies known to KMyMoney.

ToolsPrices...

Lists stock and currency prices.

ToolsUpdate Stock and Currency Prices...

Updates stock and currency prices from online sources using the Online Price Quotes feature.

ToolsConsistency Check

Runs a check on your file and tries to fix any problem it finds, if possible.

Make a backup of your file before running this option.

ToolsPerformance-Test

Runs a performance test on your file and displays the results.

Settings Menu

SettingsHide/Show Toolbar

Toggles the toolbar on or off.

SettingsHide/Show Statusbar

Toggles the bottom status bar on or off.

SettingsEnable all messages

Re-enables any messages you may have turned off by checking Don't tell me about this again in a dialog box.

SettingsKDE Language Settings...

Allows to change many locale based settings.

SettingsConfigure Shortcuts...

Configures custom shortcuts.

SettingsConfigure Toolbars...

Customizes KMyMoney toolbars.

SettingsConfigure KMyMoney...

Configures KMyMoney settings.

Help Menu

HelpKMyMoney Handbook (F1)

Invokes the KDE Help system starting at the KMyMoney help pages. (this document).

HelpWhat's This? (Shift+F1)

Changes the mouse cursor to a combination arrow and question mark. Clicking on items within KMyMoney will open a help window (if one exists for the particular item) explaining the item's function.

HelpReport Bug...

Opens the Bug report dialog where you can report a bug or request a wishlist feature.

HelpSwitch Application Language...

Opens a dialog where you can edit the Primary language and Fallback language for this application.

HelpAbout KMyMoney

This will display version and author information.

HelpAbout KDE

This displays the KDE version and other basic information.