Toolbars

Main toolbar

The main toolbar contains the most useful KPlayer commands and options.

  • Play and Play URL buttons invoke the corresponding actions from the File menu that display dialog boxes allowing you to play local files or remote URLs.

  • Properties button corresponds to the command on the File menu that will open the File Properties dialog for the current file.

  • Play, Pause and Stop buttons correspond to the commands on the Player menu and will respectively start, pause and stop playback of the current file.

  • Zoom In and Zoom Out buttons invoke the commands on the View menu that respectively enlarge and reduce the video area by one half of the original video size of the current file.

  • Maintain Aspect button corresponds to the command on the general popup menu that will toggle the option to maintain the video aspect ratio.

  • Full Screen button invokes the command on the View menu that switches to the full screen mode and back the to normal mode.

  • Volume, Contrast, Brightness, Hue and Saturation buttons display popup sliders allowing you to adjust those settings. If you want the slider to stay visible instead of disappearing when it loses the input focus, use the slider toolbars instead. As usual, if you hold the Shift key down, the changes you make to the settings will be applied only to the current file and stored in its properties.

Playlist toolbar

The playlist toolbar contains the current playlist and the most frequently used playlist commands and options.

  • Next and Previous buttons correspond to the commands on the Player menu and will select the next or previous item on the playlist and start playing it.

  • The playlist combo box in the closed state displays the current playlist item. You can drop down the combo box to see the entire list and select a different item to load and play.

  • Loop button is the same as the corresponding command on the Player menu that toggles the option to continue playing from the top of the current playlist after playing the last item.

  • Shuffle button is also the same as the corresponding command on the Player menu that toggles the option to play items in random order.

Progress and seeking toolbar

The progress and seeking toolbar is available when KPlayer knows the time length of the current file. It shows the current playback progress and lets you seek, which is to say, move the playback position forward or backward.

  • The progress slider reflects the current playback position relative to the total time length of the current file, and also lets you seek or change the current position. To seek forward and backward by the distance between the tick marks on the slider, left click to the right or left of the slider thumb. To seek to a specific point, middle click that point, or left click and drag the slider thumb to that point. If your mouse has a wheel, you can roll it up (away from you) to seek forward or down (towards you) to seek backward when the mouse pointer is over the slider. If you hold down the Ctrl key on the keyboard when rolling the wheel, seeking will be faster.

  • Fast Forward and Fast Backward buttons corresponds to the commands on the Player menu that seek forward or backward by the amount which by default is the same as the distance between slider marks. However, internally they use different seeking technique (relative as opposed to absolute), and so sometimes may give different results than left clicking the slider.

Volume toolbar

The volume toolbar allows you to control the sound volume.

  • The volume slider allows you to change the sound volume. If you hold the Shift key down, the setting will be applied only to the current file and stored in its properties. If you want the slider to always disappear after you have changed the volume, hide this toolbar and use the popup slider on the main toolbar instead.

  • Show Volume Toolbar button corresponds to the command on the Settings menu and will hide the toolbar when clicked.

  • Mute button turns the sound off and back on, without changing the normal sound volume. It is the same as the command on the Audio submenu of the Player menu.

Contrast toolbar

The contrast toolbar allows you to control the video contrast.

  • The contrast slider allows you to change the video contrast. If you hold the Shift key down, the setting will be applied only to the current file and stored in its properties. If you want the slider to always disappear after you have changed the contrast, hide this toolbar and use the popup slider on the main toolbar instead.

  • Show Contrast Toolbar button corresponds to the command on the Settings menu and will hide the toolbar when clicked.

Brightness toolbar

The brightness toolbar allows you to control the video brightness.

  • The brightness slider allows you to change the video brightness. If you hold the Shift key down, the setting will be applied only to the current file and stored in its properties. If you want the slider to always disappear after you have changed the brightness, hide this toolbar and use the popup slider on the main toolbar instead.

  • Show Brightness Toolbar button corresponds to the command on the Settings menu and will hide the toolbar when clicked.

Hue toolbar

The hue toolbar allows you to control the video hue.

  • The hue slider allows you to change the video hue. If you hold the Shift key down, the setting will be applied only to the current file and stored in its properties. If you want the slider to always disappear after you have changed the hue, hide this toolbar and use the popup slider on the main toolbar instead.

  • Show Hue Toolbar button corresponds to the command on the Settings menu and will hide the toolbar when clicked.

Saturation toolbar

The saturation toolbar allows you to control the video saturation.

  • The saturation slider allows you to change the video saturation. If you hold the Shift key down, the setting will be applied only to the current file and stored in its properties. If you want the slider to always disappear after you have changed the saturation, hide this toolbar and use the popup slider on the main toolbar instead.

  • Show Saturation Toolbar button corresponds to the command on the Settings menu and will hide the toolbar when clicked.