Popup menus

Like any half decent KDE program, KPlayer sports popup menus that you can get by right clicking different parts of it.

General popup menu

When you right click the video area, the menu bar or the status bar, you get the general popup menu that includes the most frequently used KPlayer commands and options.

  • Play and Play URL commands invoke the corresponding actions from the File menu that display dialog boxes allowing you to play local files or remote URLs.

  • Play List and Play Recent show the submenus from the File menu that allow you to play a playlist or a recent item respectively.

  • Properties command corresponds to the command on the File menu that will open the File Properties dialog for the current file.

  • Play, Pause and Stop commands correspond to the actions on the Player menu and will respectively start, pause and stop playback of the current file.

  • Maintain Aspect command toggles the option to maintain the video aspect ratio.

  • Full Screen command invokes the action on the View menu that switches to the full screen mode and back to the normal mode.

  • The commands on the Settings submenu are the same as the commands on the Settings menu and will show or hide the menu bar, status bar, playlist toolbar, multimedia library, message log, main toolbar, progress and seeking toolbar and volume toolbar.

  • Quit command invokes the action on the File menu that stops playback, saves all settings and closes KPlayer.

Playlist popup menu

When you right click the playlist drop down box on the playlist toolbar, KPlayer displays a menu that lists commands that work on the current playlist.

  • Play... and Play URL... commands invoke the corresponding actions from the File menu that display dialog boxes allowing you to play local files or remote URLs.

  • Play List and Play Recent show the submenus from the File menu that allow you to play a playlist or a recent item respectively.

  • Device submenus are also the same as the ones on the File menu. Please refer to the description above for details.

  • Next and Previous commands invoke the corresponding actions from the Player menu and will select the next or previous item on the playlist and start playing it.

  • Loop and Shuffle commands are also the same as the ones on the Player menu that toggle the options to continue playing from the top of the current playlist after playing the last item and to play items in random order respectively.

  • Edit command opens the current playlist in the multimedia library, allowing you to edit it.

Add submenu

Files...

Displays the standard Add files dialog and lets you choose a file or several files to add to the current playlist.

URL...

Displays the standard Add URL dialog and lets you type or paste in a URL to add to the current playlist.

Add to submenu

Playlist

Adds the contents of the current playlist to the playlist you choose from the list. Each playlist in the Playlists section of the library has its own command on this submenu.

Playlists...

Shows a dialog allowing you to enter a name for a new playlist and saves the current playlist in the Playlists section of the multimedia library under that name.

Collection...

Shows a dialog allowing you to enter a name for a new folder and saves the current playlist in the Collection section of the multimedia library under that name.

Library popup menu

When you right click an item in the multimedia library, KPlayer displays a menu that lists commands applicable to that item or to the currently selected items or to the current folder. The menu is the same as the Library menu on the menu bar.

Message log popup menu

When you right click the message log, KPlayer displays a menu that lists commands applicable to the message log.

  • Select All command selects all the text in the message log.

  • Copy command copies the selected message log text to the clipboard.

  • Clear command removes all messages from the message log.

Toolbar popup menu

When you right click a KPlayer toolbar, you get a standard KDE toolbar popup menu. It contains options that allow you to change the toolbar orientation, text position and icon size, as well as a command that opens the Toolbar configuration dialog.

Title bar popup menu

When you right click the KPlayer title bar, you get a standard KDE title bar popup menu. You can also get it by left clicking the little button in the top left corner of KPlayer window or by pressing Alt+F3. The menu contains commands that let you maximize, minimize, restore, move and resize the KPlayer window, as well as a few options, some of which you may find useful. For example, the Keep Above Others option on the Advanced submenu lets you keep the KPlayer window on top of all other program windows.