Chapter 3. Command reference

The shortcut key combinations shown in this chapter are the default ones. They can of course be changed.

Menu bar

Note that many menu entries are only enabled when they are applicable to the file currently loaded in KPlayer. For example, the items on the View menu will be disabled when playing audio only files.

File menu

Play... (Ctrl+O)

Displays the standard Play files dialog and lets you choose a file or several files to put on the playlist and start playing.

Play URL... (Ctrl+U)

Displays the standard Play URL dialog and lets you type or paste in a URL to put on the playlist and start playing. The URL can be a remote network location, a local file path, or a KDE I/O Slave URL.

Play List

Displays a submenu listing all playlists and lets you choose one of them to play.

Play Recent

Displays a submenu listing the most recently played files and URLs and lets you choose one to put on the playlist and start playing.

Device

Displays a submenu with commands for the particular device. Each device has its own submenu. The submenu label reflects the kind of device it is, for example TV Device or DVD Device. When you put a disk in a disk drive, after a few seconds the label will change to reflect the kind of disk you inserted, for example Audio CD in DVD Device. The list of commands on the submenu will also be updated accordingly to include commands applicable to the disk and the tracks it has. See below for details about the commands.

Load Subtitles... (Ctrl+S)

Displays the standard Load subtitles dialog and lets you choose a subtitle file or files to use with the current file or URL.

After you click Open, KPlayer will start showing subtitles from the first of the files immediately if the video is already playing, and list the subtitle files on the Subtitles submenu of the Player menu. By default it will also remember the subtitles you choose in the current file properties.

This command is available for video files. You can also drag subtitle files from Konqueror File Manager and drop them anywhere in KPlayer except the multimedia library to load and display them.

Properties... (Alt+Return)

Opens the File Properties dialog that lets you choose many options specific to the currently loaded file.

Quit (Ctrl+Q)

Saves the playlist and all settings, stops playing and closes KPlayer.

Device submenu

Play Disk

Plays the entire disk. This command is available if the device is a disk drive.

Play Title

Plays one title of a video DVD. This command is available when KPlayer detects a video DVD in a DVD drive and finds out the number of titles on it. Each title on the DVD has its own command on this submenu.

Play Track

Plays one track of an audio or video CD. This command is available when KPlayer detects an audio or video CD in a disk drive and finds out the number of tracks on it. Each track on the CD has its own command on this submenu.

Load Disk

Detects the kind of disk that is in the disk drive, finds the number of titles or tracks on the disk and updates the submenu accordingly. Usually KPlayer detects this information automatically, but sometimes this command can be useful to initiate the detection process manually. This command is available if the device is a disk drive.

Play Channel

Plays a channel from a tuner device. This command is available if the device is a tuner device. Each channel on the device has its own command on this submenu.

View menu

Commands on this menu are only available for video files.

Full Screen (Ctrl+F)

Switches to full screen video display and back to normal mode. Double clicking the video area also switches between full screen and normal window size.

Zoom In (Ctrl++)

Enlarges the video area by one half of the original video size of the current file.

Zoom Out (Ctrl+-)

Reduces the video area by one half of the original video size of the current file.

Zoom to 50%

Resizes the video area to one half of the original video size of the current file.

Zoom to 100% (Ctrl+Backspace)

Resizes the video area to the original video size of the current file.

Zoom to 150%

Resizes the video area to 150% of the original video size of the current file.

Zoom to 200%

Resizes the video area to twice the original video size of the current file.

Zoom to 250%

Resizes the video area to 250% of the original video size of the current file.

Zoom to 300%

Resizes the video area to thrice the original video size of the current file.

Maintain Original Aspect

Toggles the option to maintain the original video aspect ratio of the current file.

Maintain Current Aspect

Toggles the option to maintain the current video aspect ratio.

Force 4 to 3 Aspect

Toggles the option to maintain four to three video aspect ratio.

Force 16 to 9 Aspect

Toggles the option to maintain sixteen to nine video aspect ratio.

Player menu

Play (Return)

Starts playback of the current file. If the player has been paused, this command resumes playback. This command is available when a file is loaded.

Pause (Space)

Pauses or resumes playback of the current file. This command is available when the player is not idle.

Stop (Esc)

Stops playback of the current file. This command is available when the player is not idle.

Next (Alt+Down)

Starts playing the next item on the current playlist.

Previous (Alt+Up)

Starts playing the previous item on the current playlist.

Loop

Toggles the option to start playing items from the beginning of the playlist after playing the last item on the playlist.

Shuffle

Toggles the option to play playlist items in a random order.

Position submenu

This submenu and the commands it contains are available when playing a file.

Forward (Right)

Moves playback forward by one percent of the time length of the current file.

Fast Forward (Ctrl+Right)

Moves playback forward by ten percent of the time length of the current file.

Backward (Left)

Moves playback backward by one percent of the time length of the current file.

Fast Backward (Ctrl+Left)

Moves playback backward by ten percent of the time length of the current file.

Back to Start (Ctrl+Home)

Moves playback to the beginning of the current file.

Audio submenu

Track

Switches to the selected audio track. If the currently loaded file or stream has more than one audio track, each track will have a command that allows you to switch to that audio track. The command will be labelled with the audio track language if it is known. If there is only one audio track, this command will not be available.

Decrease Volume (Ctrl+Down)

Decreases the sound volume.

Increase Volume (Ctrl+Up)

Increases the sound volume.

Mute (Ctrl+\)

Turns the sound on or off.

Decrease Delay (Ctrl+])

Decreases the delay of sound relative to video.

Increase Delay (Ctrl+[)

Increases the delay of sound relative to video.

Video submenu

This submenu is only available for video files.

Track

Switches to the selected video track. If the currently loaded file or stream has more than one video track, each track will have a command that allows you to switch to that video track. If there is only one video track, this command will not be available.

Decrease Contrast (Ctrl+1)

Decreases the video contrast.

Increase Contrast (Ctrl+2)

Increases the video contrast.

Decrease Brightness (Ctrl+3)

Decreases the video brightness.

Increase Brightness (Ctrl+4)

Increases the video brightness.

Decrease Hue (Ctrl+5)

Decreases the video hue.

Increase Hue (Ctrl+6)

Increases the video hue.

Decrease Saturation (Ctrl+7)

Decreases the video saturation.

Increase Saturation (Ctrl+8)

Increases the video saturation.

Subtitles submenu

This menu is only available when a video file has embedded subtitles or when external subtitles are loaded.

None

Stops showing subtitles while playing video.

Track

Switches to the selected subtitles. If the currently loaded file or stream has embedded subtitle tracks, each track will have a command that allows you to switch to that subtitle track. The command will be labelled with the subtitle track language if it is known. If you load external subtitles, they will also have a command, labelled with the subtitle file name, that allows you to switch to the external subtitles.

Move Down (Ctrl+,)

Moves the subtitles down in the video area.

Move Up (Ctrl+.)

Moves the subtitles up in the video area.

Decrease Delay (Ctrl+')

Decreases the delay of subtitles relative to video.

Increase Delay (Ctrl+;)

Increases the delay of subtitles relative to video.

Advanced submenu

If your system is too slow to play a file, MPlayer can drop some frames so playback does not slow down. This submenu lets you choose a frame dropping option. The soft frame dropping option drops frames less aggressively than the hard one and should not cause playback problems. You should try it when you get video lagging behind audio, for example because you cannot use an accelerated video output. The hard option drops frames more aggressively than the soft one and may sometimes break decoding.

Soft Frame Dropping

Toggles the soft frame dropping option.

Hard Frame Dropping

Toggles the hard frame dropping option.

To turn frame dropping off, unselect the currently selected frame dropping option. The Frame drop option can also be set on the Advanced page either globally in KPlayer Settings or for a particular file in the File Properties.

Library menu

The commands on this menu work on the multimedia library. Most of the commands are available when the library is shown using the Show Library command on the Settings menu or one of the commands on the Go submenu. Other commands become available when you select some items in the library.

Play (Ctrl+Return)

Puts the selected items on the current playlist and starts playing them.

Play Next

Puts the selected items on the current playlist and plays them after the currently playing item.

Queue

Adds the selected items to the current playlist.

Queue Next

Adds the selected items to the current playlist and plays them after the currently playing item.

Add to

Shows a submenu with commands that add the current selection to different locations in the multimedia library. See below for details on each available command.

Add

Shows a submenu with commands that allow you to add items to the current folder. See below for details on each available command.

Select All

Selects all items in the current folder.

Move Up

Moves the currently selected items up in the multimedia library. This command is available for items in the Now Playing, Recent and Playlists sections of the library. You can also move items around in those sections by clicking and dragging them with the left mouse button.

Move Down

Moves the currently selected items down in the multimedia library. This command is available for items in the Now Playing, Recent and Playlists sections of the library. You can also move items around in those sections by clicking and dragging them with the left mouse button.

Remove (Del)

Removes the currently selected items from the multimedia library. Note that KPlayer never deletes any multimedia files from your system, so this command is not available for files and directories.

Rename (Ctrl+F2)

Starts edit mode for the current item in the multimedia library so that you can change the item name.

Edit

Shows a submenu with commands that start edit mode for the chosen field of the current item in the multimedia library. Each editable field has its own command on this submenu. If the field column is not shown, this command will show it. After you are done editing the field, press Enter to apply the changes, or Tab or Shift+Tab to apply the changes and edit the next or the previous field, or Down Arrow or Up Arrow to apply the changes and edit the same field of the next or previous item.

Properties...

Opens the File Properties dialog for the current item in the multimedia library. This command currently does not apply to folders, but it is available for devices and optical disks as well as other items.

Columns

Shows a submenu with commands that show or hide the chosen column in the list view of the multimedia library. Each available column has its own command on this submenu.

Go

Shows a submenu with commands that let you navigate the multimedia library. See below for details on each available command.

Add to submenu

Playlist

Adds the selected items to the playlist you choose from the list. Each playlist in the Playlists section of the library has its own command on this submenu.

New Playlist...

Shows a dialog allowing you to enter a name for a new playlist to add to the Playlists section of the multimedia library and adds the selected items to the new playlist.

Playlists

Adds the selected items to the Playlists section of the multimedia library.

Collection

Adds the selected items to the Collection section of the multimedia library.

Add submenu

Files...

Displays the standard Add files dialog and lets you choose a file or several files to add to the current folder.

URL...

Displays the standard Add URL dialog and lets you type or paste in a URL to add to the current folder.

Folder...

Shows a dialog allowing you to enter a name for a new subfolder to add to the current folder.

Playlist...

Shows a dialog allowing you to enter a name for a new playlist to add to the playlist selected in the multimedia library.

Device...

Shows a dialog allowing you to enter a name, type and path for a new device to add to the Devices section of the multimedia library. Some device types need additional settings.

Go submenu

Folder

Opens the selected folder in the multimedia library. If the library window is not shown, this command will show it. Each folder in the recent history has its own command on this submenu. Each top level folder also has its own command.

Back (Alt+Left)

Opens the previous folder.

Forward (Alt+Right)

Opens the next folder. This command will be available after you use the Back command.

Up (Alt+Shift+Up)

Opens the parent folder of the selected folder.

Down (Alt+Shift+Down)

Opens the selected folder.

To Origin (Alt+Shift+Left)

Opens the origin folder of the selected folder. This command is available when the currently selected folder is linked to an origin folder.

Settings menu

Show Menubar (Ctrl+M)

Shows or hides the menu bar.

Show Statusbar

Shows or hides the status bar.

Show Playlist (Ctrl+P)

Shows or hides the playlist toolbar.

Show Library (Ctrl+L)

Shows or hides the multimedia library.

Show Message Log (Ctrl+G)

Shows or hides the message log.

Show Main Toolbar

Shows or hides the main toolbar.

Show Progress Toolbar

Shows or hides the progress toolbar. This command is available when the time length of the current file is known.

Show Volume Toolbar

Shows or hides the volume toolbar.

Show Contrast Toolbar

Shows or hides the contrast toolbar. This command is available for video files.

Show Brightness Toolbar

Shows or hides the brightness toolbar. This command is available for video files.

Show Hue Toolbar

Shows or hides the hue toolbar. This command is available for video files.

Show Saturation Toolbar

Shows or hides the saturation toolbar. This command is available for video files.

Configure Shortcuts...

Opens a dialog that lets you see and change KPlayer's shortcut key bindings, or associations between actions and the corresponding keys or combinations of keys that activate them. If you change the bindings, make sure not to duplicate an existing shortcut and also not to use the Shift key for your new shortcuts, because the Shift key has a special function in KPlayer.

Configure Toolbars...

Opens a dialog that lets you see and change the command buttons available on KPlayer's toolbars.

Configure KPlayer...

Opens a dialog that lets you configure the program, modifying various aspects of its functionality, user interface and interaction with MPlayer. For more information see the Configuration dialog chapter in this manual.

Help menu

HelpKPlayer Handbook (F1)

Invokes the KDE Help system starting at the KPlayer help pages. (this document).

HelpWhat's This? (Shift+F1)

Changes the mouse cursor to a combination arrow and question mark. Clicking on items within KPlayer will open a help window (if one exists for the particular item) explaining the item's function.

HelpReport Bug...

Opens the Bug report dialog where you can report a bug or request a wishlist feature.

HelpSwitch Application Language...

Opens a dialog where you can edit the Primary language and Fallback language for this application.

HelpAbout KPlayer

This will display version and author information.

HelpAbout KDE

This displays the KDE version and other basic information.