Chapter 10. Building KDevelop from Sources

If you want to have the latest features and bugfixes, you can build KDevelop yourself from the sources.

There exists a more in-detail article here.

Be aware that you could build an unstable version. To help the developers fix bugs, please keep the RelWithDebInfo and report bugs to http://bugs.kde.org, either per hand or using Dr. Konqi.

Requirements

  • kdelibs-devel >= 4.3 - http://www.kde.org

  • qt-devel >= 4.5.2 - http://qt-project.org/

  • boost-devel >= 1.35 - http://www.boost.org

  • g++ >= 4.0 - http://gcc.gnu.org

  • CMake >= 2.6.2 - http://www.cmake.org

  • qjson-devel